none
MAIL DELAYED THEN FAILING

    Question

  • Hi all,

    having a nightmare with this.

    My exchange is sending some email fine, but some will just not send. The ones that will not send first of all get delayed then fail with the following...

    #550 4.4.7 QUEUE.Expired; message expired ##

    I noticed there was a broken NIC team on the exchange which I have resolved now.

    I also noticed there was a reverse lookup zone for an invalid subnet which I have resolved now.

    I also noticed there was no SPF record as the send connector is sending using DNS.

    I also noticed the top two forwarders in DNS were invalid, I removed these and added OpenDNS and googleDNS forwarders.

    Yet mail is still failing to send.

    Am I missing something? Is there another DNS record in addition to the MX and the SPF that I need?

    Thanks in advance.

    Thursday, November 10, 2016 3:18 PM

All replies

  • Hi,

    Send connectors use the domain name system (DNS) to route mail if "MX record associated with recipient domain" is selected under send connectors. Generally, no other DNS record needed. And exchange is sending some email fine, so the setting in DNS record should be fine.

    How many send connectors/DC in your organization? Meanwhile, check the LastError message in queue. Check if you can find something on message tracking log for these messages. Are there any error events in application log?


    Best Regards,

    Lynn-Li
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 15, 2016 9:26 AM
    Moderator
  • Hi,

    Have you checked what I suggested above.

    And one more thing, how many CAS server in your environment? Check the resource server setting on send connector, make sure all CAS servers are in that list.


    Best Regards,

    Lynn-Li
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 18, 2016 2:06 AM
    Moderator