none
Windows could not parse or process unattend answer file.. Ref image error. RRS feed

  • Question

  • I did a ref image in my mdt-build share, and imported the finished images with "hardinstalled" applications and fully updated, into my mdt-production share. And it applied just fine, but after I am getting:

    My Rules looks like this, I guess it have nothing to do with the rules, but who knows..

    [Settings]
    Priority=Default
    Properties=MyCustomProperty

    [Default]
    OSInstall=Yes
    SkipCapture=YES
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipComputerBackup=YES
    SkipBitLocker=YES


    SkipComputerName=YES
    OSDComputerName=PC-#Left(“%SerialNumber%”,12)#

    SkipDomainMembership=YES
    JoinDomain=xxx.us
    DomainAdmin=xxx
    DomainAdminDomain=xxx
    DomainAdminPassword=xxx!

    SkipUserData=YES


    SkipLocaleSelection=YES
    SkipTimeZone=YES
    KeyboardLocalePE="041d:0000041d"
    KeyboardLocale= "sv-SE,041d:0000041d"
    UserLocale= sv-SE
    UILanguage= en-US
    TimeZoneName=W. Europe Standard Time



    • Edited by abborre Saturday, April 30, 2016 8:33 PM
    Saturday, April 30, 2016 8:28 PM

Answers

  • This line was the problem:

    OSDComputerName=PC-#Left(“%SerialNumber%”,12)#

    The quotes was not " but “. That why its not good to copy and paste from websites. ;-)

    • Marked as answer by abborre Sunday, May 1, 2016 2:31 AM
    Sunday, May 1, 2016 2:31 AM

All replies

  • Hi

    What OS are you trying to build a ref image of?

    If it Windows 7 - then look at decrepated settings in the unattend.xml

    Have you tried to replace this KeyboardLocale= "sv-SE,041d:0000041d" with

    KeyboardLocale= "sv-SE" or KeyboardLocale= "041d:0000041d"

    Kind regards

    Per Larsen

    Twitter: @PerLarsen1975 | Blog: osddeployment.wordpress.com
    If this post is helpful please vote it as Helpful or click Mark for answer.

    Saturday, April 30, 2016 8:46 PM
  • Sorry, I missed to type its Windows 10.

    I did change it to what you said. No difference.

    I "stole" the image above from Internet, when I read it afterward it was a minor change to the error message. (Sorry)

    windows could not parse or process the unattend answer file [c:\windows\panther\unattened.xml] for pass [specialize]. The answer file is invalid..

    Saturday, April 30, 2016 9:48 PM
  • its something with my rules it seems. works fine with the default rules..
    Sunday, May 1, 2016 1:21 AM
  • This line was the problem:

    OSDComputerName=PC-#Left(“%SerialNumber%”,12)#

    The quotes was not " but “. That why its not good to copy and paste from websites. ;-)

    • Marked as answer by abborre Sunday, May 1, 2016 2:31 AM
    Sunday, May 1, 2016 2:31 AM
  • Had the same problem....glad to find this post after 3 days of scratching my head...

    JAW

    Friday, December 16, 2016 6:55 PM