none
Exchange 2013 with Co-Existence Exchange 2010sp3 - unable to access ECP for the Exchange 2013 mailbox.

    Question

  • Environment

    AD Windows 2008r2

    Exchange 2010SP3 on Windows 2008

    Exchange 2013 Productin Site  + Exchange 2013 at DR site on Windows 2012r2 with CAS+MBX roles on each server

    We have only few mailboxes on Exchange 2013 and all mailboxes are still homed in Exchange 2010. The strange thing is when tried accessing ECP of the DR site server it automatically redirects to the Exchange 2010 OWA instead showing its own Exchange 2013. The production site server i can access ECP on it properly. 

    I tried accessing using https://localhost/ecp/?ExchClientVer=15 or https://localhost/ecp/ once it authenticate it redirects to Exchange 2010 ECP. How to fix, i did restarting the Exchange 2013 in DR site but still the same. It automatically redirects to https://publicdomainurl.com/owa

    Please help!


    Regards, Ganesh, MCTS, MCP, ITILV2 This posting is provided with no warranties and confers no rights. Please remember to click Mark as Answer and Vote as Helpful on posts that help you. This can be beneficial to other community members reading the thread.

    Wednesday, November 4, 2015 11:41 AM

Answers

  • Hi aganesh,

    Thank you for your question.

    If we want to access ECP of Exchange 2013, we should type user’s mailbox on Exchange 2013, we use https://localhost/ecp on Exchange 2013 server or run https://localhost/ecp/?ExchClientVer=15 on other client which is not Exchange 2013 CAS server.

    If we type the mailbox which belong to Exchange 2010 server when we type Exchange 2013 CAS URL, the URL will redirect to Exchange 2010.

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    • Marked as answer by aganesh007 Monday, November 30, 2015 5:23 AM
    Thursday, November 5, 2015 6:07 AM
    Moderator

All replies

  • Hi,

    Please check that the correct URLs are configured on the ECP virtual directory on the DR server:

    Get-EcpVirtualDirectory | Fl server,*url*

    You can also try moving your mailbox to Exchange 2013 or try the URL https://localhost/ecp/?ExchClientVer=14

    Thanks.


    Please mark as an answer if this answers your question

    Mark Gossa

    MCSE 2003, MCITP Enterprise Administrator 2008 R2, MCSA 2012 R2, MCTS Exchange 2010, MCTS SQL 2012, MCTS SharePoint 2007, VCP4, VCP5, CCNA

    Blog: http://markgossa.blogspot.com   LinkedIn:

    Posts are provided “AS IS” without warranty of any kind, either expressed or implied.

    Wednesday, November 4, 2015 12:28 PM
  • Environment

    AD Windows 2008r2

    Exchange 2010SP3 on Windows 2008

    Exchange 2013 Productin Site  + Exchange 2013 at DR site on Windows 2012r2 with CAS+MBX roles on each server

    We have only few mailboxes on Exchange 2013 and all mailboxes are still homed in Exchange 2010. The strange thing is when tried accessing ECP of the DR site server it automatically redirects to the Exchange 2010 OWA instead showing its own Exchange 2013. The production site server i can access ECP on it properly. 

    I tried accessing using https://localhost/ecp/?ExchClientVer=15 or https://localhost/ecp/ once it authenticate it redirects to Exchange 2010 ECP. How to fix, i did restarting the Exchange 2013 in DR site but still the same. It automatically redirects to https://publicdomainurl.com/owa

    Please help!


    Regards, Ganesh, MCTS, MCP, ITILV2 This posting is provided with no warranties and confers no rights. Please remember to click Mark as Answer and Vote as Helpful on posts that help you. This can be beneficial to other community members reading the thread.

    what does your internal OWA and ECP urls resolve to in your dr site?  Also, if you just moved an account try forcing AD replication and see that makes a difference.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread

    Wednesday, November 4, 2015 2:35 PM
  • Hi aganesh,

    Thank you for your question.

    If we want to access ECP of Exchange 2013, we should type user’s mailbox on Exchange 2013, we use https://localhost/ecp on Exchange 2013 server or run https://localhost/ecp/?ExchClientVer=15 on other client which is not Exchange 2013 CAS server.

    If we type the mailbox which belong to Exchange 2010 server when we type Exchange 2013 CAS URL, the URL will redirect to Exchange 2010.

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    • Marked as answer by aganesh007 Monday, November 30, 2015 5:23 AM
    Thursday, November 5, 2015 6:07 AM
    Moderator