none
DPM 2012 SP1 Crash After Adding SQL Cluster Node RRS feed

  • Question

  • I had a 2 node sql 2012 always on availability cluster, and then added a 3rd node but forgot to install the DPM agent on it.  The DPM server crashed every time it attempted to make a backup of the SQL server.  Obviously I failed to install the agent on the new node, but the DPM server service shouldn't be completely crashing.  As soon as I installed the agent everything went back to normal.  Hopefully somebody will see this and fix it :)

    Here's the error that showed up in the event viewer:

    The description for Event ID 943 from source MSDPM cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event: 

    Unable to connect to the DPM database because the database is in an inconsistent state.    

    Problem Details:
    <FatalServiceError><__System><ID>19</ID><Seq>4</Seq><TimeCreated>2/28/2013 1:04:07 PM</TimeCreated><Source>DpmThreadPool.cs</Source><Line>163</Line><HasError>True</HasError></__System><ExceptionType>DBCorruptionException</ExceptionType><ExceptionMessage>DLS error:  SP='dbo.prc_AM_Server_Get' Error=50001</ExceptionMessage><ExceptionDetails>Microsoft.Internal.EnterpriseStorage.Dls.DB.DBCorruptionException: DLS error:  SP='dbo.prc_AM_Server_Get' Error=50001
       at Microsoft.Internal.EnterpriseStorage.Dls.DB.SqlRetryCommand.ValidateReturnValue(String errorTitle)
       at Microsoft.Internal.EnterpriseStorage.Dls.DB.SqlContext.Close(Boolean disallowReuseConnection)
       at Microsoft.Internal.EnterpriseStorage.Dls.DB.SqlContext.Close()
       at Microsoft.Internal.EnterpriseStorage.Dls.AgentManager.DB.AMServerInfo.GetServerDetails(String serverName)
       at Microsoft.Internal.EnterpriseStorage.Dls.PRMCatalog.DatasourceServerTypeLock.GetAllPhysicalNodes(List`1 resourceGroups)
       at Microsoft.Internal.EnterpriseStorage.Dls.PRMCatalog.DatasourceServerTypeLock.DeregisterAllServerLocksForBackup(Guid taskId, Guid datasourceId, List`1 exceptions)
       at Microsoft.Internal.EnterpriseStorage.Dls.PRMCatalog.DatasourceServerTypeLock.DeregisterAllServerLocksForBackup(Guid taskId, Guid datasourceId)
       at Microsoft.Internal.EnterpriseStorage.Dls.Prm.ProtectionRecoveryTaskExecutor.RWPForOnPremiseDiskReplication(Task task)
       at Microsoft.Internal.EnterpriseStorage.Dls.Prm.ProtectionRecoveryTaskExecutor.RetireWorkplan(Guid jobId, Guid taskId, IXPathNavigable jobXml)
       at Microsoft.Internal.EnterpriseStorage.Dls.TaskExecutor.TaskExecutor.RetireWorkplanOnEngineRestart(Task taskDbObj, IXPathNavigable jobXml)</ExceptionDetails></FatalServiceError>


    the message resource is present but the message is not found in the string/message table


    Lync/Asterisk blog: www.andrewparisio.com

    Thursday, February 28, 2013 4:02 PM

All replies

  • Hi,

    Thanks for reporting it, to date we have not had any customers call into support for this issue.  I'll see if our test team can duplicate the problem.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, March 14, 2013 11:38 PM
    Moderator
  • Hi All,

    Exactly same issue here. I had a 2 node SQL AON and after I created a 3rd node without adding the DPM agent all my RP to Disk jobs started to fail (my SQL, Files and Exchange PG's run at the same time).

    Everything got fixed after I installed the agent on the 3rd SQL node. 

    Note: My SQL AON is on a trusted domain.

    Santiago

    Wednesday, February 26, 2014 9:00 PM
  • Same thing is happening to us. I've added the agent to all nodes but still DPM is crashing. Is there a fix for this?!

    <FatalServiceError><__System><ID>19</ID><Seq>11</Seq><TimeCreated>3/7/2014 7:28:58 PM</TimeCreated><Source>DpmThreadPool.cs</Source><Line>163</Line><HasError>True</HasError></__System><ExceptionType>DBCorruptionException</ExceptionType><ExceptionMessage>DLS error: AMServerInfo: dbo.prc_AM_Server_Get SP='dbo.prc_AM_Server_Get' Error=50001</ExceptionMessage><ExceptionDetails>Microsoft.Internal.EnterpriseStorage.Dls.DB.DBCorruptionException: DLS error: AMServerInfo: dbo.prc_AM_Server_Get SP='dbo.prc_AM_Server_Get' Error=

    Friday, March 7, 2014 7:47 PM