none
the pruneshadowcopies script causes powershell to close? RRS feed

  • Question

  • DPM2012 SP1 - running on Windows 2012 

    I've tried manually running this script during quiet times but each time, powershell pops up a "powershell must close" window after it runs only a few minutes. Based on the way my unallocated space is continuously being used, i'm wondering if this could mean that it doesn't run correctly at midnight? 

    Has anyone run into this? 

    Thanks for any insight. 

    Sunday, April 28, 2013 12:50 AM

Answers

All replies

  • Hi,

    See is this post helps in any way.

    DPM 2010 doesn't remove old recovery point
    http://social.technet.microsoft.com/Forums/en-US/dataprotectionmanager/thread/05a3bcb9-87ad-4cb6-9047-bd0c18f127de

    If that does not help, enter this in the DPM Power shell window before running the pruneshadowcopies2010.ps1 script and see if it provides more information.

    $VerbosePreference= "Continue"


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, April 29, 2013 12:52 AM
    Moderator
  • I've been manually looking at recovery points for some of the early servers we setup, and there appear to be some that are hanging around past the retention, which I am able to delete. Once the server calms down I will use your debug option above and see if I can find out any more info. The link was about a 2008 update, but we're running on 2012 so I saw no reference to it. 
    Thanks.
    Monday, April 29, 2013 1:22 PM
  • Of course, running with verbose turned on...it finished. I did see some output like "Number of SC deleted 1" and a lot of "Sending dismount..." output. So, whatever circumstance was causing the problem has disappeared.

    It's like taking a car into a mechanic...right?

    Thanks for the verbose tip.

    Tuesday, April 30, 2013 1:27 PM