none
Hyper-V-VmSwitch Event id 106 RRS feed

  • Question

  • I have Windows Server 2012R2 with Hyper-V role installed. I,m using network Team.

    When the server starts I receive a error - Hyper-V-VmSwitch EventID 106 - in system event log.

    Log Name:      System
    Source:        Microsoft-Windows-Hyper-V-VmSwitch
    Date:          07.01.2014 18:13:48
    Event ID:      106
    Task Category: None
    Level:         Error
    Keywords:     
    User:          SYSTEM
    Computer:      csmavrtcl06.nlb.si
    Description:
    Available processor sets of the underlying physical NICs belonging to the LBFO team NIC /DEVICE/{CE5C164C-31C5-4EE7-AD31-CC2A1B2E6813} (Friendly Name: Microsoft Network Adapter Multiplexor Driver #2) on switch 25051EB0-C449-4504-A024-DB3F2D16591F (Friendly Name: ClusterSwitch) are not configured correctly. Reason: The processor sets are not identical when LBFO is configured with min-queue mode.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Hyper-V-VmSwitch" Guid="{67DC0D66-3695-47C0-9642-33F76F7BD7AD}" />
        <EventID>106</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2014-01-07T17:13:48.156559500Z" />
        <EventRecordID>3455</EventRecordID>
        <Correlation />
        <Execution ProcessID="4" ThreadID="60" />
        <Channel>System</Channel>
        <Computer>csmavrtcl06.nlb.si</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData>
        <Data Name="NicNameLen">46</Data>
        <Data Name="NicName">/DEVICE/{CE5C164C-31C5-4EE7-AD31-CC2A1B2E6813}</Data>
        <Data Name="NicFNameLen">47</Data>
        <Data Name="NicFName">Microsoft Network Adapter Multiplexor Driver #2</Data>
        <Data Name="SwitchNameLen">36</Data>
        <Data Name="SwitchName">25051EB0-C449-4504-A024-DB3F2D16591F</Data>
        <Data Name="SwitchFNameLen">13</Data>
        <Data Name="SwitchFName">ClusterSwitch</Data>
        <Data Name="QueueMode">1</Data>
      </EventData>
    </Event>

    Tuesday, January 7, 2014 5:47 PM

Answers

All replies

  • What are the NICs being teamed and the teaming setting?

    Do the NICs have different capabilities?  Is SR-IOV enabled?


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Tuesday, January 7, 2014 7:55 PM
    Moderator
  • I teamed two 10GB NICs.

    Team mode is LACP. SR-IOV is not enabled.

    Wednesday, January 8, 2014 7:08 AM
  • Hi Elton,

    I checked similar tread, but there talking about sum-queue mode.

    My teams in Hyper-V host are configured to min-queue mode.

    My Hyper-V server has 4 processors with 10 core each (40 cores). I'm using 2 teams. Each team has two 10 GB NICS.

    The problem (event id 106) is present in both teams.

    In "Windows Server 2012 R2 Nic teaming guide" I found information that I must configure each NIC in team to use same processors. So, if I understand well I must run command below on each NICs in both teams:

    Set-NetAdapterRss -name NIC1 -BaseProcessorNumber 0 -MaxProcessorNumber 39

    Best regards, Simon

    Thursday, January 9, 2014 7:22 PM
  • Friday, January 10, 2014 5:23 AM
    Moderator
  • Hi,

    I run this command:

    Set-NetAdapterRss -name "10GE-S09-SP", "10GE-S09-SP" -BaseProcessorNumber 0 -MaxProcessorNumber 16

    Now both interfaces in team: Team-Cluster use same processors:

    PS C:\Windows\system32> Get-NetAdapterVMQ

    Name                           InterfaceDescription              Enabled BaseVmqProcessor MaxProcessors NumberOfReceive
                                                                                                            Queues
    ----                           --------------------              ------- ---------------- ------------- ---------------

    Team-VM                        Microsoft Network Adapter Mult... True    0:0                            29
    10GE-S11-ZG                    HP Ethernet 10Gb 2-port 530...#45 True    0:0              16            29
    10GE-S09-ZG                    HP Ethernet 10Gb 2-port 530...#43 True    0:0              16            29
    10GE-S09-SP                    HP Ethernet 10Gb 2-port 530...#42 True    0:0              16            29
    10GE-S11-SP                    HP Ethernet 10Gb 2-port 530...#44 True    0:0              16            29
    Team-Cluster                   Microsoft Network Adapter Mu...#2 True    0:0                            29


    PS C:\Windows\system32> Get-NetAdapterRSS


    Name                                            : 10GE-S09-SP
    InterfaceDescription                            : HP Ethernet 10Gb 2-port 530T Adapter #42
    Enabled                                         : True
    NumberOfReceiveQueues                           : 8
    Profile                                         :
    BaseProcessor: [Group:Number]                   : 0:0
    MaxProcessor: [Group:Number]                    : :
    MaxProcessors                                   : 16
    RssProcessorArray: [Group:Number/NUMA Distance] :
    IndirectionTable: [Group:Number]                :

     

    Name                                            : 10GE-S11-SP
    InterfaceDescription                            : HP Ethernet 10Gb 2-port 530T Adapter #44
    Enabled                                         : True
    NumberOfReceiveQueues                           : 8
    Profile                                         :
    BaseProcessor: [Group:Number]                   : 0:0
    MaxProcessor: [Group:Number]                    : :
    MaxProcessors                                   : 16
    RssProcessorArray: [Group:Number/NUMA Distance] :
    IndirectionTable: [Group:Number]                :

    Name                                            : Team-Cluster
    InterfaceDescription                            : Microsoft Network Adapter Multiplexor Driver #2
    Enabled                                         : True
    NumberOfReceiveQueues                           : 0
    Profile                                         : NUMAStatic
    BaseProcessor: [Group:Number]                   : 0:0
    MaxProcessor: [Group:Number]                    : 0:39
    MaxProcessors                                   : 4
    RssProcessorArray: [Group:Number/NUMA Distance] : 0:0/0  0:1/0  0:2/0  0:3/0  0:4/0  0:5/0  0:6/0  0:7/0
                                                      0:8/0  0:9/0  0:10/0  0:11/0  0:12/0  0:13/0  0:14/0  0:15/0
                                                      0:16/0  0:17/0  0:18/0  0:19/0  0:20/0  0:21/0  0:22/0  0:23/0
                                                      0:24/0  0:25/0  0:26/0  0:27/0  0:28/0  0:29/0  0:30/0  0:31/0
                                                      0:32/0  0:33/0  0:34/0  0:35/0  0:36/0  0:37/0  0:38/0  0:39/0
    IndirectionTable: [Group:Number]       

    And the problem (event id 106) is still present....

    Regards, Simon

    Friday, January 10, 2014 9:03 AM
  • Hi Simon,

    Has the problem been solved ?

    Your CPU is  AMD ?

    BTY , "switch dependent" and "address hash" is the teaming configuration ?

    Best Regards

    Elton Ji


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Monday, January 13, 2014 1:54 AM
    Moderator
  • Hi Elton,

    No, the problem is still present....

    Teaming configuration is LACP(switch dependant) anf Hyper-V port....

    Regards, Simon

    Monday, January 13, 2014 8:53 AM
  • Hi Simonaa,

    Please try to use the Teaming configuration :  "switch dependent" and "address hash" .

    As for this command : Set-NetAdapterRss -name "10GE-S09-SP", "10GE-S09-SP" -BaseProcessorNumber 0 -MaxProcessorNumber 16 

    If your cpu is AMD there is no problem , bu if  you are using Intel CPU the "MaxProcessorNumber" normally should be a odd number .

     

    Hope this helps

    Best Regards

    Elton Ji


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    • Marked as answer by Simonaa Monday, January 13, 2014 12:57 PM
    • Unmarked as answer by Simonaa Monday, January 13, 2014 12:57 PM
    • Marked as answer by Simonaa Monday, January 13, 2014 12:57 PM
    • Unmarked as answer by Simonaa Monday, January 13, 2014 12:57 PM
    • Marked as answer by Simonaa Monday, January 13, 2014 12:58 PM
    Monday, January 13, 2014 9:14 AM
    Moderator
  • Hi Elton,

    I'm using Intel processors...

    So, I set odd number to every Nics. I also set BaseProcessorNumber 2 (I found somewhere that processor 0 should not be used)

    I used this command: Set-NetAdapterRss -name "10GE-S09-SP", "10GE-S11-SP" -BaseProcessorNumber 2 -MaxProcessorNumber 15

    And the problem is gone....

    Now I have just one question about max processor number... What is the maximum number of processors that can be used for VMQ?

    Thanks for your help!!!

    Best regards, Simon

    Monday, January 13, 2014 1:12 PM
  • Hi Simonaa,

    "

    1. BaseProcessorNumber – Specifies the starting processor to be used in the system

    2. MaxProcessors - Maximum number of processors to be used by VMQ

    3. MaxProcessorNumber – Specifies the maximum processor to be used in the system

    "

    For details please refer to following blog :

    http://blogs.technet.com/b/networking/archive/2013/09/10/vmq-deep-dive-1-of-3.aspx

    Hope this helps

    Best Regards

    Elton Ji


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    Monday, January 13, 2014 3:21 PM
    Moderator