"Parameter is incorrect" installing driver for any USB storage device RRS feed

  • Question

  • Hi,
    I'm getting a "parameter is incorrect" error when Vista Business RTM is installing ANY USB storage device, whether flash or HDD based.  I've tried several of each and none work.  It appears to find the device driver software and goes to install it and that's when the error occurs.
    Vista Business RTM was an upgrade to Windows XP Pro SP2, rather than a clean install.
    This is the information from the error report:
    Windows encountered a problem while installing device drivers for your USB 
    Flash Disk USB Device
    Problem signature
    Problem Event Name:	PnPDriverInstallError
    Architecture:	x86
    Win32 error:	00000057
    Inf name:	disk.inf
    Driver Package hash:	e503a4f1d821a50e8760410a457dfaea2365371a
    DDInstall section name:	disk_install
    OS Version:	6.0.6000.
    Locale ID:	1033
    Extra information about the problem
    Bucket ID:	12135484
    I understand that this might be more a common issue than I thought.  Has anyone found a solution to this yet?  All of my colleagues have done a clean install and have no issue with USB storage devices.  I wonder if this is as a result of the upgrade, some old drivers or permissions issues causing the problem?
    Friday, November 24, 2006 10:04 AM

All replies

  • I have exactly the same problem.  I too upgraded from XP Pro SP2 to Vista Ultimate, and have this issue with all the USB flash media I have tried.

    I have tried a no-name multi-format card reader, and a Corsair Voyager 1GB USB2.0 flash drive. 

    Any ideas would be greatly appriciated.

    Tuesday, December 5, 2006 7:46 PM
  • I have still to work out how to get it working.  I'm almost thinking about giving up and re-installing as a fresh install.  I've put this post up in a couple of places and no response from Microsoft.  I guess they are very busy fixing Vista bugs ;-)
    Wednesday, December 6, 2006 8:12 AM
  • It seems to be working now, but I'm not quite sure what I've done to get it to work.

    Anyway, I bought myself one of the Sandisk Ultra II 1.0GB SD flash drives that bends to reveal a USB connector.  I plugged it into (admittedly a different port that I normally use - not sure whether this is significant) a USB port and it worked straight away.  As this worked I thought I'd try to plug in some of the drives that were not working.  As I plugged each one in nothing happened visually.  Opening Device Manager showed the yellow icon against the device so I right-clicked and selected to update install software.  As at the time I wasn't connected to the internet, I chose to scan the machine for software and selected the C:\ drive.  It found the software and installed the device ok.  Repeated the process for the other drives no problem!


    Tuesday, December 12, 2006 8:32 AM
  • I appear to have the same problem with all usb drives (I've tried USB flash drive, USB memory stick reader and USB Zip drive) on Vista Ultimate 32bit. Vista was a clean install (albeit on a
    extended partition and executed form XP) not an upgrade.

    Interestingly the USB pen drive works when the computer is booted up with the drive plugged in
    but if it is removed and replugged in, it fails as above (will confirm this with zip drive on next

    I am most intriegued and look forward to discovering the solution.


    Tuesday, February 13, 2007 4:02 PM
  • I had the same problem with a fresh install. If you search for a driver in the Windows folder, it will install the gerneric drivers correctly.
    Friday, February 23, 2007 6:19 PM
  • Have tried this - still doesnt work !!

    Has anybody else found the following (may only apply if you have done an Upgrade rather than a Fresh Install)

    Go into Regedit

    Navigate to HKLM\System\CurrentControlSer\Enum\USBSTOR

    I then found one of my USB Thumb Drives listed as Disk&Ven_I-Stick2........

    Try to delete this entry (effectively making your computer forget the device so it has to look for drivers etc)

    Vista will not let you do it

    Almost like the Registry hives are now write protected

    Strange ??



    Friday, March 2, 2007 1:48 PM
  • I have the same/a similar problem with my clean Vista Ultimate.

    All USB-Devices are working except USB-Sticks and CF-Readers.

    It doesn't depend on which port or an external USB-Hub, everytime the device is installed I get the non-specific "Parameter Incorrect"-Error.

    I found a "solution" in another forum ... "Select on driver installation the manually search for a driver and choose c:\windows and subdirectories". But it does'nt work for me.

    Until the driver installation has failed, my USB-Stick from Sony is correctly labeled in the Device Manager. After the failed driver installation a generic description appears.

    Friday, March 2, 2007 2:40 PM
  • Same thing happens to me, i have tried everything now! There must be a work around. I tried to update my BIOS but there are no updates for it. Do you reckon its the motherboard?

    Basically, i have tried my USB's in the front, back, pci card and a hub and still getting the same message. I have tried my memory stick on a mates Vista and it works. Anyone at all?

    Thanks in advance.
    Wednesday, March 7, 2007 5:06 PM
  • I don't believe on a hardware failure ..

    On my hardware was previously a Win XP Pro running and all my devices worked. After the clean Vista Install the Drives are not working anymore.

    It must me a bug or another bad driver ... maybe the Scanner, the Mouse and Keyboard .. or or or ...

    Wednesday, March 7, 2007 7:13 PM
  • I don't think its a bug cos my memory stick works on my mates Vista PC and not mine!!
    Wednesday, March 7, 2007 8:02 PM
  • This much is true.

    My memory stick works fine in my sons laptop (Vista Home Premium)

    As you say...its not a bug..its a registry issue

    Need to find how to delete the old details from the registry so it can install new details


    Sunday, March 11, 2007 8:59 PM
  • I have found the problem on my Machine ...

    As soon as I uninstalled Netgear SC101 Storage Central Manager, all my USB Storage Devices worked with just tow steps:

    Uninstall bad device installation:
    Connect device, go to Device Manager, uninstall Device

    Install device:
    Unplug and reconnect the USB Storage, auto-install Drivers

    My CF-Reader and Sony Memory Stick are working now.

    Sunday, March 11, 2007 9:31 PM
  • Respect to darkprojekt.

    I too had the Netgear SC101 Storage Central Manager software installed (from when my machine was running XP)

    I removed the software (including deleting the C:\Program Files\Netgear SC101 folders to prevent automatic re-install) and I got my machine to see my memory sticks

    Well done.


    Thursday, March 15, 2007 8:01 PM
  • im getting problems also with USB - my old 128mb usb drive work like a treat

    my new LG 1gb usb driver doesnt find a driver and doesnt install full stop, whatever i do

    i'll search see if ive got the netgear problems

    just dont understand why it works on my other laptop with xp and it doesnt on vista, you should need any special drivers for a usb device, supposed to be plug and play equipement after all

    any fresh idea's for these problems any bug fixes ?
    Wednesday, March 21, 2007 4:25 PM
  • WoW what a catch  - I had the same SC101 software and a USB drive that wouldn't load. Uninstall and it works great.

    Kudos to you darkprojekt

    Friday, March 23, 2007 10:30 PM