locked
Server Error in '/' Application. The resource cannot be found. RRS feed

  • Question

  • whenever i am trying to access my sharepoint site i am getting this error message, please help me resolve this issue. 

    Server Error in '/' Application.

    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

    Requested Url: /sites/dashboard/default.aspx
    Wednesday, April 9, 2014 9:29 AM

All replies

  • I refereed to post below, but I am still experiencing this issue:

    ----------------------------------------

    several days ago, I encountered the same problem with my SP2007 portal.

    this error first appeared while i was editing one of the page layouts. if this the case with you, I think I can help you solve your problem :)

    When I attacked my problem I discovered that the Sharepoint designer automaticly converts the url path that start with: "~/site/page/file.aspx" to "site/page/file.aspx"

    and when the designer saves it, the url becomes invalid for sp2007 interpretation. because of the nature of that specific error I decided that it must be it,

    so I started to look at the pages, that I recently changed, references for url that might be started with: ~/.

    for my suprise I found it in the default.master page which is the most significant page (all the pages by default are using it).

    this file can be found at  Local_Drive:\\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\CONTROLTEMPLATE.

    at the bgining of the page there are the follwing lines (opened using notepad):

    <%@ Register TagPrefix="wssuc" TagName="Welcome" src="~/_controltemplates/Welcome.ascx" %>
    <%@ Register TagPrefix="wssuc" TagName="DesignModeConsole" src="~/_controltemplates/DesignModeConsole.ascx" %>

    while opening the same file with Sharepoint designer I received:

    <%@ Register TagPrefix="wssuc" TagName="Welcome" src="_controltemplates/Welcome.ascx" %>
    <%@ Register TagPrefix="wssuc" TagName="DesignModeConsole" src="_controltemplates/DesignModeConsole.ascx" %>

    its appears that when the SP2007 trying to resolve the master page, it can't find the controls whith mantioned src url, so it crashes.

    because the actual editing of the master page i done by the Sharepoint designer, the ghosted master page was actualy at the site path: /_catalogs/masterpage/default.master so I reghosted it to the actual default.master page. and it WORKED :)

    you can reghost this file using the "http://<site name>/_layouts/settings.aspx" page which is not using default.master of sp2007, so it worked fine

    I hope this information would be helpfull for you

    Regards,

    Daniel

    Remark: Microsoftdoes not recomendes to make actual changing to the default.master filer so be carefull, because each change will reflect on all sites that are using this template which is by default all sites and all pages at that site

    ------------------------------------------------

    But as I checked my master page looks fine, I have tilda sign in the place while I am oppening default.master in notepad and SPD but.

    This is how it looks:

    <%@ Register TagPrefix="wssuc" TagName="Welcome" src="~/_controltemplates/Welcome.ascx" %>
    <%@ Register TagPrefix="wssuc" TagName="DesignModeConsole" src="~/_controltemplates/DesignModeConsole.ascx" %>

    default.master is stored in LAYOUTS catalog.

    Does anyone can advice what might be wrong?





    Wednesday, April 9, 2014 9:33 AM