locked
Timer Job Profile sync not running for one of the servers in farm RRS feed

  • Question

  • We have a Sharepoint 2007-farm which consists of one sql-server, one wfe in DMZ and one internal sharepoint-server that runs all services. AD import of users is configured.

    On the wfe in DMZ the Timer jobs Profile Synchronization and Quick Profile Synchronization runs as scheduled, but on the other internal sharepoint-server these timer jobs (and several other timer jobs) stopped running a few months ago. Is there any way I can make these timer jobs start again? The problems we experience because of this, is eg. that if a user changes title in AD, this isnt replicated to the wss-profile in Sharepoint.

    I have tried the following with no luck:

    stsasm -o sync

    stsadm -o sync -synctiming m:5

    stsadm -o sync -sweeptiming m:5
    Stsadm -o sync -listolddatabases 1

    Stsadm -o sync -deleteolddatabases 1

     Any help in resolving this would be greatly appreciated!

     


    Wednesday, June 22, 2011 12:35 PM

Answers

All replies

  • HI,

    clear the cache on the servers using http://support.microsoft.com/kb/939308 and then check by running the sync n sweeptime

    Thanks,

    Raj

    Thursday, June 23, 2011 7:55 AM
  • Hi,

    I tried clearing the cache according to the attached link, but didnt help.

    However I got these two events in the event-viewer at the same time as the timer jobs stopped:

    The session setup to the Windows NT or Windows 2000 Domain Controller \\DC for the domain *** is not responsive.  The current RPC call from Netlogon on \\Sharepointserver to \\DC has been cancelled.

    AND

    This computer was not able to set up a secure session with a domain controller in domain *** due to the following:
    The remote procedure call was cancelled. 
    This may lead to authentication problems. Make sure that this computer is connected to the network. If the problem persists, please contact your domain administrator. 

    ADDITIONAL INFO
    If this computer is a domain controller for the specified domain, it sets up the secure session to the primary domain controller emulator in the specified domain. Otherwise, this computer sets up the secure session to any domain controller in the specified domain.

    Could there be a connection between these errors? However the server seems to be a correct member of the domain.

    Thursday, June 23, 2011 12:48 PM
  • Hi,

     

    According to your description, I have found a thread to be similar to your question about Profile Synchronization job stopped running, please refer to:

    http://social.technet.microsoft.com/Forums/en/sharepointadmin/thread/e4a143f7-e9c1-4502-a681-ccb412abea45

    I hope it can help you a little.

     

    Best Regards
    David Hu
    • Marked as answer by Emir Liu Thursday, June 30, 2011 1:36 AM
    Friday, June 24, 2011 2:02 AM