none
FS4SP - synonym installation using cmdlets causing error message RRS feed

  • Question

  • Hi,

    I'm  running AddSynonym, Add Keyword powershell cmdlets through a script which inserts synonyms in FAST Search Keywords link, in one of the site collection.. The script runs fine for sometime.. And after that in the log I can see error message "An error occured while trying to communicate to the database".. when I check the site collection -> site settings-> FAST Search keywords, the error message “Unexpected error occured while communicating with Administration Services”, where in this was not displaying this error initially, I have confirmed it was working fine before running the script. We have another log which says that few of the keywords are inserted and exists, but couldn't check due to this issue.

    Note: The error “Unexpected error occured while communicating with Administration Services” occurs only for FAST Search keywords link, all other links in CA related to FAST & Site collection settings works fine.

    workAround did till now:

    Checked the Service account being added in all the FAST Servers in FASTSearchAdministartors Group & FASTKeywordsAdministrators Group.

    Service Account is used as the administration account in central admin -> FAST SSAs

    Could anyone please let me know how to resolve both the error message. Need to resolve this issue as early as possible. Thanks!!!!

    Wednesday, July 18, 2012 4:23 AM

All replies

  • Good Morning,

    Try to add a FASTSearchKeywordAdministrators permission group on each of your FAST machines.

    http://hellosharepoint.blogspot.co.il/2010/10/fast-failed-to-communicate-with-wcf.html

    Amir

    Wednesday, July 18, 2012 5:11 AM
  • Thanks Amir for the reply.. I found one of the server of FAST the FASTSearchKeywordAdministrators  group was not present, I added the service account to it, but still the same error in site collection “Unexpected error occured while communicating with Administration Services”, Do I need to do further actions.
    • Edited by Moniswe Wednesday, July 18, 2012 6:09 AM
    Wednesday, July 18, 2012 6:08 AM
  • Did you restart the server after adding the security group?

    I noticed that most of time these changes don't take affect till restart.

    Also, try to add the app pool account (user who is running the website's application pool) to the administration groups (fast admin and keywords admin).

    Amir

    Thursday, July 19, 2012 7:04 AM