locked
autodiscover in outlook 2007 not working RRS feed

  • Question

  • When I configure outlook 2007 the name of the server does not populate.  I believe this was working in the past.  What do I need to test to find out what might have broken?  Is there a DNS entry that needs to be made?

     

     

    Tuesday, March 22, 2011 6:15 PM

All replies

  • Which version of Exchange are you using? If you are using Exchange 2003 then autodiscover doesn't work. Exchange 2007 and higher it does.
    It then depends on whether the client is a member of the domain or not, as autodiscover works in different ways.

    More information is required.

    You can test autodiscover by holding down CTRL while right clicking on the Outlook icon in the system tray and choosing Test Email Auto Configuration.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    Tuesday, March 22, 2011 11:26 PM
  • After running Auto Configuration, please check whether Autodiscover URL exists. If so, please manually browse the URL to check the result.

     

    Meanwhile, I suggest you run Exchange Remote Connectivity Analyzer and select Outlook Autodiscover option to analyze the problem.

     

    https://www.testexchangeconnectivity.com/

     

    Thanks.

    Novak Wu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Risingflight Saturday, December 28, 2019 7:09 PM
    Wednesday, March 23, 2011 8:17 AM
  • I am running exchange 2007 and outlook 2007.   My goal is to have the server name filled in when outlook is configured for the first time.

     

     

    Wednesday, March 23, 2011 12:20 PM
  • So, please take some time to run Auto Configuration and access Exchange Remote Connectivity Analyzer to check whether Autodiscover URL is set normally or not. If so, please post the error message here for research.

     

    Thanks.

    Novak Wu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, March 24, 2011 8:02 AM
  • Hello everyone i want to configure autodiscover on exchange server 2007 sp1

    please do guide me the powershell command to setup autodiscover.

    PS] C:\Users\Administrator.\Desktop>Get-ActiveSyncVirtualDirectory | fl


    ActiveSyncServer: https://mail.mydomain.com/
    MetabasePath    : IIS://MAIL.mydomain.com/W3SVC/1/ROOT/Microsoft-Server-ActiveSync
    ClientCertAuth  : Ignore
    Server          : MAIL
    InternalUrl     : https://mail.mydomain.com/Microsoft-Server-ActiveSync
    InternalAuthenticationMethods : {}
    ExternalUrl     : https://mail.mydomain.com/
    ExternalAuthenticationMethods : {}
    OriginatingServer: MAIL.mydomain.com

    Get-ClientAccessServer | fl Namae,AutoDiscoverServiceInternalUri
    Name                           : MAIL
    AutoDiscoverServiceInternalUri : https://mail.mydomain.com/autodiscover/autodiscover.xml

    Get-ClientAccessServer | fl Name,AutoDiscoverServiceExternalUri
    Name : MAIL

    [PS] C:\Users\Administrator.Mydomain\Desktop>Get-AutodiscoverVirtualDirectory | ft *url*

    InternalUrl                                                                     ExternalUrl
    -----------                                                                     -----------

    I want EMS command to configure autodiscover
    my exchange server hostname is mail and domain mydomain.com
    please guide me the commands to configure autodiscover properly

    Do cross check these commands
    After running below commands do my external users connect to my exchange using active sync with mail.mydomain.com
    with SSL enabled

    which command should i run

    1. Set-ClientAccessServer -identity "MAIL" https://mail.mydomain.com/autodiscover/autodiscover.xml

    or 
      Set-ClientAccessServer -identity "MAIL" -AutoDiscoverServiceInternalUri : https://mail.mydomain.com/autodiscover/autodiscover.xml

    2. Enable-OutlookAnywhere -Server MAIL -ExternalHostname "mail.mydomain.com" -ExternalAuthenticationMethod "Basic" -SSLOffloading:$False

    Here what does -SSL Offloading mean ( iwant SSL to be used)

    3. Set-OABVirtualDirectory -identity "MAIL\OAB (Default Web Site)" -externalurl https://mail.mydomain.com/OAB -RequireSSL:$true


    4. Set-WebServicesVirtualDirectory -identity "MAIL\EWS (Default Web Site)" -externalurl https://mail.mydomain.com/EWS/Exchange.asmx -BasicAuthentication:$True


    After running these commands do my external users on the internet connect to my exchange using mail.mydomain.com

    Thursday, December 19, 2013 8:40 PM