locked
Lync Enterprise Voice - incoming call disconnects if not picked up in15-20 seconds RRS feed

  • Question

  • Hi!

    We have been successfully using Lync for all our calling needs for 5 months. We started out masquerading outgoing caller ID, so that the recipients called back to our mail number which is handled by a response group, which is working perfectly. However, when external people call our direct numbers, it rings for about 15-20 seconds, and if not picked up within that time, the call is disconnected. We have set the "Unanswered call will go to"-setting to forward to cell phones, and that works if we set the time to 15 seconds. If we set it to more then that, the call is disconnected.

    Is there a global setting for how long calls ring an internal number when called directly? Or could there be something else wrong with our setup?

    We have one standard front end server + one Edge server, and a direct SIP-trunk to our provider.

    Thanks, Christian

    Friday, April 20, 2012 6:51 AM

Answers

  • Hi! I solved my own case:

    After troubleshooting another problem (Calls on hold disconnecting after 20 seconds for all users), I found the solution:

    set-cstrunkconfiguration -identity “global” -enablesessiontimer $True

    set-cstrunkconfiguration -identity “global” -rtcpactivecalls $False -rtcpcallsonhold $False

    It has something to do with how Lync communicates with the sip-trunk. If you need more information about these commands, this is where I found the information:

    http://memphistech.net/?p=169 (My regards to the author!)

    Regards,

    Christian

    • Marked as answer by cfeste Thursday, May 3, 2012 2:09 PM
    Thursday, May 3, 2012 2:09 PM

All replies

  • Hi

    There is a default ring time of 15 seconds on calls so if you set the value to any more than that it will fail.

    You can use the following tool and command to increase the wait time if needed:

    SEFAUtil.exe /server:<servername> <username> /enablefwdnoanswer /callanswerwaittime:30

    I believe its on a per-user basis, the command above certainly is.

    Hope this helps.

    Regards

    Neil

    Friday, April 20, 2012 8:10 AM
  • Hi,

    as NeilCruickshanks

    wrote, the standard ringtime is 20 sec. the maximum ringtime is 60 sec. If you don't have a Exchange UM integration the call will be disconnected after this 20 sec. if the call is not answered.

    The 20 sec. could only be change from the Lync user himself or as Neil mentioned with the sefautil.


    regards Holger Technical Specialist UC

    Saturday, April 21, 2012 7:20 PM
  • Hi!

    Setting this on the client does not work. If I increase the "Unanswered call will go to"-delay to f.ex. 30 seconds, the calls are just disconnected after 20. When setting 15 or 20 seconds, the forwarding works.

    I also suspect that if setting this from SEFAUtil it will be the same.

    Chr.

    Monday, April 23, 2012 1:05 PM
  • SEFAUtil changes the settings in a differant way so you should find that this will work - it certainly did for a client that was having the exact same problems/ requirements you have.

    Regards

    Neil

    Monday, April 23, 2012 1:07 PM
  • Hi, it seems SEFAUtil does the same thing, at least when I make a change with either SEFAUtil or the Lync client, and then use SEFAUtil til output the settings, the excact same things are updated. And: The settings does not work above 30 seconds. Setting to f.ex. 45, the call gets disconnected at 30.

    I am now setting the affected users delay to 28 seconds, which seems to work. With 30 it's actually random if it disconnects or forwards.

    Could there be another default setting of 30 seconds overriding this?

    Chr.


    • Edited by cfeste Tuesday, April 24, 2012 2:22 PM
    Tuesday, April 24, 2012 8:22 AM
  • Hi! I solved my own case:

    After troubleshooting another problem (Calls on hold disconnecting after 20 seconds for all users), I found the solution:

    set-cstrunkconfiguration -identity “global” -enablesessiontimer $True

    set-cstrunkconfiguration -identity “global” -rtcpactivecalls $False -rtcpcallsonhold $False

    It has something to do with how Lync communicates with the sip-trunk. If you need more information about these commands, this is where I found the information:

    http://memphistech.net/?p=169 (My regards to the author!)

    Regards,

    Christian

    • Marked as answer by cfeste Thursday, May 3, 2012 2:09 PM
    Thursday, May 3, 2012 2:09 PM