locked
Outlook 2007 keeps prompting for password after update, please help! RRS feed

  • Question

  • We just updated our SBS 2008 with exchange 2007 setup and right after the updates all users started receiving a dialog box when opening their outlook client.  The strange thing is the dialog box has the external FQDN on top remote.mydomain.com the username is formated \\servername\user when I enter the users password it just comes right back up like the password was rejected.  If I cancel out it says 'Need Password' in the lower right corner of Outlook.  Now the users can still send and receive mail but everytime the send and receive is initiated the box comes up.  I know your probably going to need some sort of log, unfortunately I don't have access to the server right now but I'll be there tomorrow.  In the mean time so I don't waste another day figuring this out can someone post any solutions for this type of issue that I can try? I'm a newbie with exchange so please be gentle! Thanks.
    Tuesday, April 13, 2010 9:57 PM

Answers

  • Here is the answer to this problem. On the server do the following: Click Start >>> Run >>> CMD "Hold Left SHIFT in " Click OK. Now type the following COMMAND in:  "%windir%\System32\inetsrv\appcmd.exe set config -section:windowsAuthentication /useKernelMode:false"  now Enter. exit and VOIALA it goes away.
    Mike Prinsloo [CLP][CNE]
    • Marked as answer by Allen Song Friday, July 9, 2010 3:14 AM
    Thursday, July 1, 2010 9:00 PM

All replies

  • Updated to what? What Sp and Rollup is Exchange?

     

    Wednesday, April 14, 2010 1:31 AM
    Moderator
  • Hi,

    As the user is still able to send/receive email, I believe Outlook can still connect to Exchange mailbox server. I suspect that the issue occurs because incoorect Autodiscover settings. Which Outlook client is used? Outlook 2007 or Outlook 2003?

    If it is Outlook 2007, please check whether the Autodiscover URL or other Web Services URL is configured correctly? You can run Test-OutlookWebServices command to check whether any external URLs are configured?

    By the way, how Outlook 2007 connects to Exchange Server? TCP or RPC over HTTP?

    Mike

    • Proposed as answer by Allen Song Monday, April 19, 2010 8:53 AM
    Wednesday, April 14, 2010 8:35 AM
  • Hi,

    Whether all users had this issue or just certain user? Could you download the OAB? Please press Ctrl+right click the Outlook icon in System Tray, then select Test E-mail AutoConfiguration, click Test button, then post the information under Logs Tab.

    Thanks

    Allen

    Monday, April 19, 2010 8:57 AM
  • I have also experienced this problem after restarting our SBS 2008 server, after which updates were installed. I initially posted this on the Outlook forum but i was advised to re-post in this forum.

    In my situation, this problem only occurs on Windows 7 machines running Outlook 2007 clients on our LAN network. Machines running XP with Outlook 2007 / 2003 do not exhibit this behaviour. Also if a Windows 7 machine that does show this behaviour on the network, connects via our VPN it is not asked for a user password to log on to exchange.

    I am also waiting for an answer to this problem.

    Regards

    SteveMack

     

     

    Monday, April 19, 2010 1:48 PM
  • What SP and RU is Exchange 2007?
    Monday, April 19, 2010 3:04 PM
    Moderator
  • Hi Andy

    We are running SBS 2008 SP2 and am experienceing the EXACT same prompt / problems as SteveMACK do you have any feedback yet ?

    I ran the auto connect wizard, UNABLE to auto connect ..... How do I export the LOG so I can post it where you wanted it ?

    Awaiting response Mike

    Monday, May 3, 2010 10:42 AM
  • On SBS 2008 there is a known issue:

    Outlook 2007 Credential Prompts in Small Business Server 2008
    http://blogs.technet.com/sbs/archive/2010/02/16/outlook-2007-credential-prompts-in-small-business-server-2008.aspx

     


    MCTS: Messaging | MCSE: S+M | Small Business Specialist
    • Proposed as answer by Allen Song Tuesday, May 4, 2010 3:14 AM
    Monday, May 3, 2010 11:21 AM
  • %windir%\System32\inetsrv\appcmd.exe set config -section:windowsAuthentication /useKernelMode:false

     

    Fixed my problem on SBS 2008.  :D

     

    Thanks!!

    • Proposed as answer by Rhindle Monday, May 3, 2010 3:10 PM
    Monday, May 3, 2010 3:10 PM
  • Here is the answer to this problem. On the server do the following: Click Start >>> Run >>> CMD "Hold Left SHIFT in " Click OK. Now type the following COMMAND in:  "%windir%\System32\inetsrv\appcmd.exe set config -section:windowsAuthentication /useKernelMode:false"  now Enter. exit and VOIALA it goes away.
    Mike Prinsloo [CLP][CNE]
    • Marked as answer by Allen Song Friday, July 9, 2010 3:14 AM
    Thursday, July 1, 2010 9:00 PM

  • This fixed my problem on SBS 2008. :)

    Thanks !!
    Thursday, July 8, 2010 12:15 PM
  • this did work for me - However, it broke my ability to login to remote web workplace - I could login to the front page, but I could not access remote machines or owa - is there another option?  thx in advance!  Bill
    Sunday, November 21, 2010 1:15 AM