locked
After connecting Seagate Hard disk, Stuck on "connecting to virtual disk service..." in disk management RRS feed

  • Question

  • Hi, 

     I am using 1TB Seagate Expansion external drive, with external power cable. I was using this with no problem, but about 3 months back, the problem started "when I connect the HD to my laptop, green light starts glowing continuously in the HD, and If I touch it, I can feel its spinning, but when I open computer menu, it shows the external hd as 'local disk', but it has no info about the storage space left on it like the other drives in computer menu, and the green bar at the top loads endlessly.

    In Device Manager, it shows up and I updated the drive and it said I already had the latest driver.

    When I tried to uninstall through Device Manager, once again, it gets hung up on the uninstall endlessly.

    When I go to computer management and click on disk management, there is nothing in the menu, but at the bottom, it says "connecting to virtual disk service...." endlessly.

    when I unplug the drive, and restart my system with out HD, I have no problems In opening disk management.
    I am using windows 8, I tried it in my friends laptop which has Windows 8.2, same problem , I changed the USB cable, from other HD, and I used my cable to other other disk, In other HD its fine, So I found there is no problem with my cable. I am using Seagate company provided adapter.

    I thought, I could keep the HD ideal for some days and try it later, so, I kept it in shelf for about 3 months and I am using now, still same problem continuous, I am so tried of this, can anyone please help me in solving out the issue?

    Thank you.

    Thursday, March 12, 2015 2:09 PM