none
My work view failed to load RRS feed

  • Question

  • One of the Resources recieves the following error  In My work Timesheets or Tasks:

    The View failed to load. Press Ok to reload this view with the default settings. Press cancel to select another view.

    We already tried to delete and recreate the timesheet(s) that were failing but received the following error :Timesheet UID was not found in MSP_Timesheet.. Details: id='24011'

    RDS: The request to synchronize the delete of timesheet TimesheetUid='274a3527-4d55-40f4-9d50-51bdca336ec8' failed.
    RDS: The request to synchronize the delete of timesheet TimesheetUid='50352637-2a30-4287-b356-ae05a31fd4f3' failed.
    RDS: The request to synchronize the delete of timesheet TimesheetUid='a8a69237-b925-4577-8295-b42b6657102f' failed

    I have been trying to identify if one of the above timesheets where orphaned , but have it seems that this is not the case!

    Looking in the ULS log this entry shows up:

    Exception occurred in method Microsoft.Office.Project.Server.BusinessLayer.Statusing.StatusingGetMyWorkForGridJson System.ArgumentException: Invalid start and end times   

    at Microsoft.Office.Project.DataEdit.Contours.Int64ContourEx.SetValueBetween(RelTime timeStart, RelTime timeEnd, Double value, Boolean treatAsUnits)   

    at Microsoft.Office.Project.DataEdit.Assignments.AssnCntr.CreateRemainingWorkContour(AssnNode assnNode, Boolean fForLoad)   

    at Microsoft.Office.Project.DataEdit.Assignments.AssnCntr.EnsureRemainingWorkContour(AssnNode assnNode, Boolean fForLoad)   

    at Microsoft.Office.Project.DataEdit.Assignments.AssnCntr.FixAssnNode(AssnNode assnNode)   

    at Microsoft.Office.Project.DataEdit.Assignments.AssnCntr.SetAssnData(AssnNode node, IAssnData data)   

    at Microsoft.Office.Project.DataEdit.Assignments.AssnCntr.LoadNode(Guid guid)   

    at Microsoft.Office.Project.DataEdit.Assignments.AssnCntr.FindAssnNode(Guid guid)   

    at Microsoft.Office.Project.Server.BusinessLayer.Statusing.ReadStatusTimephasedDataForResource(IList`1 gridChanges, Guid[] vAssnUids, IDictionary`2 assn2proj, StatusingTimephasedPeriod[] tpdPeriods, DateTime tpStart, DateTime tpEnd)   

    at Microsoft.Office.Project.Server.BusinessLayer.Statusing.<>c__DisplayClass57.<CreateTimephasedDataColumnFiller>b__56(IEnumerable`1 Keys)   

    at Microsoft.SharePoint.JSGrid.GridSerializer.BuildOutput()   

    at Microsoft.SharePoint.JSGrid.GridSerializer.ToJson(Serializer s)   

    at Microsoft.SharePoint.JsonUtilities.Serializer.SerializeToJson(Object o)   

    at Microsoft.Office.Project.Server.BusinessLayer.Statusing.GetMyWorkForGridJson(JsGridSerializerArguments gridSerializerArgs, String gridChangesJson, String projectAssignmentsMap, Guid viewUid, String timephasedStart, String timephasedEnd, Byte pane, Int32 durationType, Int32 workType, Int32 dateFormat, Boolean clearPersistedProperties, Nullable`1 rowFilterType)   

    at Microsoft.Office.Project.Server.Wcf.Implementation.PWAImpl.StatusingGetMyWorkForGridJson(JsGridSerializerArguments gridSerializerArgs, String gridChangesJson, String projectAssignmentsMap, Guid viewUid, String timephasedStart, String timephasedEnd, Byte pane, Int32 durationType, Int32 workType, Int32 dateFormat, Boolean clearPersistedProperties, Nullable`1 rowFilterType)

    Can anyone point me in the right direction in trying to identify the issue and working towards a solution?

    Regards,

    Jim

    The Project Server version PS2010 SP1 last update applied CU April 2012.

    <v:shapetype coordsize="21600,21600" filled="f" id="_x0000_t75" o:preferrelative="t" o:spt="75" path="m@4@5l@4@11@9@11@9@5xe" stroked="f">
     <v:stroke joinstyle="miter">
    <v:formulas>  <v:f eqn="if lineDrawn pixelLineWidth 0">
      <v:f eqn="sum @0 1 0">
      <v:f eqn="sum 0 0 @1">
      <v:f eqn="prod @2 1 2">
      <v:f eqn="prod @3 21600 pixelWidth">
      <v:f eqn="prod @3 21600 pixelHeight">
      <v:f eqn="sum @0 0 1">
      <v:f eqn="prod @6 1 2">
      <v:f eqn="prod @7 21600 pixelWidth">
      <v:f eqn="sum @8 21600 0">
      <v:f eqn="prod @7 21600 pixelHeight">
      <v:f eqn="sum @10 21600 0">
     </v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:f></v:formulas>
     <v:path gradientshapeok="t" o:connecttype="rect" o:extrusionok="f">
     <o:lock aspectratio="t" v:ext="edit">
    </o:lock></v:path></v:stroke></v:shapetype><v:shape alt="" id="Picture_x0020_2" o:spid="_x0000_i1025" style="width:381pt;height:111.75pt;" type="#_x0000_t75">
    <v:imagedata o:href="cid:image005.png@01CDFD74.F7F19210" src="file:///C:\Users\jdijken\AppData\Local\Temp\msohtmlclip1\01\clip_image001.png">
    </v:imagedata></v:shape>

    Tuesday, January 29, 2013 10:56 AM

Answers

  • Dose this happen to other users? If you change the view, dose the page display the assignments? If this happens to one user, then I suggest republishing the projects this resource/user is assigned to. 

    Ali Al . Consultant & IT Manager.
    epma
    FB TW IN

    • Marked as answer by JDijken Wednesday, January 30, 2013 2:36 PM
    Wednesday, January 30, 2013 2:15 PM

All replies

  • Dose this happen to other users? If you change the view, dose the page display the assignments? If this happens to one user, then I suggest republishing the projects this resource/user is assigned to. 

    Ali Al . Consultant & IT Manager.
    epma
    FB TW IN

    • Marked as answer by JDijken Wednesday, January 30, 2013 2:36 PM
    Wednesday, January 30, 2013 2:15 PM
  • Ali al,

    Thanks for your reply , this happens to only one user . We have tried your suggestion and that seems to clear the issue.

    Regards,

    Jim

    Wednesday, January 30, 2013 2:36 PM
  • I have this issue a lot with clients, 9 times out of 10 it’s a Project that failed to publish correctly and causes one or more assignments corruption which results in the view issues.  

    glad I can help,


    Ali Al . Consultant & IT Manager.
    epma
    FB TW IN

    Wednesday, January 30, 2013 2:39 PM