locked
Central Administration application pool account RRS feed

  • Question

  • I am standing up SharePoint Services 3.0 for the first time as a small IT portal. One of the tasks is to make the Central Administration application pool account unique (number 5)... When I follow the action link, it takes me to the Operations / Service Accounts link, but I have no indication of what it wants me to change.

    I can see in IIS that my SharePoint Central Administration pool is running as a Network Service, but nothing in the Central Administration console / Operat ions / Service accounts area seems to be associated with the application pool that Share Point is using for central administration... I have assigned a user to every one of them, and it hasn't changed the Central Administration pool...

    Can someone point me in the redirection to complete this task?

    Tuesday, December 27, 2011 4:09 PM

Answers

  • Follow the steps from this article: http://support.microsoft.com/kb/934838

    Extract:

    On the server that hosts the Central Administration Web site, type the following line at the command prompt, and then press ENTER:

    stsadm -o updatefarmcredentials -userlogin <var>DomainName</var>\<var>UserName</var> -password <var>NewPassword</var>
    On all other servers in the server farm, type the following line at the command prompt, and then press ENTER:
    stsadm -o updatefarmcredentials -userlogin <var>DomainName</var>\<var>UserName</var> -password <var>NewPassword</var> -local

    Restart Microsoft Internet Information Services (IIS) 6.0. To do this, type the following line at the command prompt, and then press ENTER:

      

    MCITP|MCTS SharePoint
    • Proposed as answer by Satheesh MSFT Tuesday, December 27, 2011 7:36 PM
    • Marked as answer by Oldguard Tuesday, December 27, 2011 8:13 PM
    Tuesday, December 27, 2011 7:01 PM

All replies

  • Follow the steps from this article: http://support.microsoft.com/kb/934838

    Extract:

    On the server that hosts the Central Administration Web site, type the following line at the command prompt, and then press ENTER:

    stsadm -o updatefarmcredentials -userlogin <var>DomainName</var>\<var>UserName</var> -password <var>NewPassword</var>
    On all other servers in the server farm, type the following line at the command prompt, and then press ENTER:
    stsadm -o updatefarmcredentials -userlogin <var>DomainName</var>\<var>UserName</var> -password <var>NewPassword</var> -local

    Restart Microsoft Internet Information Services (IIS) 6.0. To do this, type the following line at the command prompt, and then press ENTER:

      

    MCITP|MCTS SharePoint
    • Proposed as answer by Satheesh MSFT Tuesday, December 27, 2011 7:36 PM
    • Marked as answer by Oldguard Tuesday, December 27, 2011 8:13 PM
    Tuesday, December 27, 2011 7:01 PM
  • I had done that, but with a -local switch at the end... Looks like dropping the -local fixes the issue. Appreciate your help.

    Tuesday, December 27, 2011 8:13 PM
  • - local parameter needs to be used on the other SharePoint servers that are not hosting central admin.

    If you have only one SharePoint server in the farm this command solves the problem:

    stsadm -o updatefarmcredentials -userlogin <var>DomainName</var>\<var>UserName</var> -password <var>NewPassword</var>
     
    Thanks

    MCITP|MCTS SharePoint
    Tuesday, December 27, 2011 8:24 PM