Windows 7 mapped drive latency with slow green progress bar and red X in Explorer


  • First and foremost:  We did NOT have these issues with Windows XP, and still run over 60 XP machines that have NONE of these problems.

    We are having ongoing problems with Windows 7 and mapped drive latency on our network.  Our environment is as follows:

    Multiple servers running Windows 2008 & 2008 R2, some VMware servers (including our file server).

    Windows 7 x64 came preloaded on a brand new Lenovo thinkpad, 4gb memory.  This occurs on 4 different laptops.  This problem ALSO occurs in exactly the same way on an HP Compaq x64 desktop running Windows 7 32.  All systems are fully patched & up to date on SP's. 

    Running IP 4 & 6 on all servers & Win7 machines

    Connected to GB Cisco switch

    We run login scripts via GPOs that map drives (with net use commands) to 3 shares on our fileserver, drives G, H and S.  A fourth mapped drive to an IBM Iseries does NOT experience these issues.

    In Windows Explorer, mapped drives may or may not appear with red X's, but when clicked on they hang with a spinner and the green bar at the top of Explorer begins to run.  This occurs randomly, but usually not right after boot up.  It can take over a minute to complete.  Also, in Word, which has references to these drives in file locations, file opening and saves can be very slow as it attempts to access these shares.

    This issue has delayed our roll out of Windows 7.  Its unacceptably slow and cannot be used in a production environment. 

    We have tried every suggestion we can find on the Internet:

    Turned off autotuning, indexing, thumbnails, set autodisconnect to the max (both 99999 and ffffffff).  Server & clients.  No luck.

    Changed properties on the mapped drives to optimize for change.

    Changes setting on the network cards to disable flow control, set static link speed & duplex.  Network drivers have been updated.  Even tried using our wireless network and disabling wired change.

    All bios and hardware updates are change.

    Turned on and off network change.

    Disabled SMB2 on servers & change.

    Disabled firewalls, and unloaded antivirus (Trend) change.

    There has GOT to be a solution to this problems or Windows 7 is dead in the water for us.  I have 10 laptops in boxes that we can't roll out.  Please post ANY ideas!!



    Tuesday, December 7, 2010 5:38 PM

All replies

  • Hi,


    Thanks for the post!


    Based on every method you tried, I suggest you enter into the Safe Mode with networking check if the speed is normal.


    If works, try Clean Boot to narrow down the issue.




    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, December 9, 2010 6:15 AM
  • Hello Miya...

    Tried safe mode and clean change.  In clean boot with all non-microsoft services turned off, I still get the latency but it might not last quite as long as when all services are on.  But still not acceptable in production. 

    I'm hoping that someone has additional ideas....


    Monday, December 13, 2010 2:18 PM
  • Have similar problem and found no cure.

    This relates to mapped drives on a SharePoint server. File transfer is also dirt-slow. It is faster for me to move my file from my Windows 7 PC to my XP PC and then move to the SharePoint server.

    Really sad.

    Tuesday, May 24, 2011 10:49 AM
  • The solution is to disconnect all map drives, reboot the computer and allow the script to remap drives...

    This is due to the TCP Global Parameters in Windows 7, didn't exist in XP or before...

    The command to check setting is "netsh int ip show global"

    This resolve my issue after trying everything under the sun for about 3 weeks...

    Wednesday, August 17, 2011 9:06 PM
  • Here, we found that the problem, oddly enough, was related to an Internet Explorer (IE) setting.

    Tools ->Internet Options -> Connections -> LAN Settings -> Automatic Configurations: Make sure that "Automatically detect settings" is unchecked.

    That's all it took. Apparently, it goes out and checks every time. Real smart, Microsoft...

    • Proposed as answer by IFlingPoo Thursday, December 22, 2011 10:10 AM
    Friday, October 7, 2011 2:29 PM
  • Thank you!  Saved me today...


    Tuesday, November 8, 2011 7:34 PM
  • I don't use IE, so never thought to look there... instant solve!


    Thursday, December 22, 2011 10:11 AM
  • In case this helps anybody, I solved this problem by using the FQDN of the VMware server drive that I wanted map.  Previously we had been using physical machines and for whatever reason we only need to connect using the server's "name" like this \\server\C

    When I attempted to do the same thing for the new VMs the connection would hang for a good 10+ minutes.  So I changed my mapping to this \\\C and it worked perfectly.  Just a tip.

    Thursday, April 4, 2013 6:56 PM
  • Okay, so I have one particular Win 7 32-bit computer.  It has a 1TB internal and three 4TB USB 3 drives (I do a lot of digital video programming and need the storage).  It is not interacting with ANY other machine or server, but is stand-alone except for an Ethernet connection to the Internet. I've done everything from set all folders and sub-folders on all of the external drives to Document and made sure that IE's 'Automatically detect settings' is unchecked.  A couple of times, I've been able to access particular large folders without the creeping progress bar, but it soon returns.  Then if I try to re-sort the directory, say from Name desc to Date asc, I get an even slower progress bar creep.  I've taken to starting a re-sort and going for coffee while I wait.  There are NO network drives on this machine (I work remotely from my home and use a different Linux box to VPN into my client's intranet).  None of the suggestions I've read at a dozen sites or Microsoft troubleshooter utilities have helped a bit.  

    So, WTF?   Am I going to have to abandon MS all-together for Linux (I'm already half-way there), move everything over to my old Win XP sp3 workhorse?  Outside of NT 1.54 and XP sp3, Microsoft O/S's have been greater or lesser pieces of cruft.  I even liked DOS better (at least you could program down to the metal in asm or C and not even have the overhead of DOS or BIOS to bother you).

    How do you say "Improved Windows?"   "Ubuntu!"

    Thursday, September 5, 2013 10:32 PM
  • Here it is 2015 and this saved the day.  Two days of checking everything under the sun.  After 5 years with 7 and IE on this machine the Explorer issues starts yesterday.  This solution works immediately, without a reboot or even a restart of Windows Explorer. rock!  Microsoft...not so much.

    Wednesday, September 30, 2015 5:45 PM
  • Thanks! This resolved my issue with slow access every single time I need to click on the mapped drive directory.
    Wednesday, October 21, 2015 7:20 AM
  • Well, 6 years later and multiple windows versions I can definitely say that the huge bug is still there. It's so freaking annoying that my local share doesn't work sometimes and I get green bar of molasses and it ALWAYS works perfectly with shares on my ubuntu. WTF? Why MS still have this bug????

    Thursday, September 22, 2016 8:32 PM
  • Here, we found that the problem, oddly enough, was related to an Internet Explorer (IE) setting.

    Tools ->Internet Options -> Connections -> LAN Settings -> Automatic Configurations: Make sure that "Automatically detect settings" is unchecked.

    That's all it took. Apparently, it goes out and checks every time. Real smart, Microsoft...

    That answer has to be on top page of, this problem was pissing me off for years randomly reminding me about it. Thanks a lot!
    Thursday, September 22, 2016 8:44 PM
  • Thank you!!

    It is odd that IE settings would be affecting that, but it is Windows, so....

    I've been dealing with this issue ever since my company switched out my laptop and could not figure out why.  It would work....ok..... on network, but extremely slow on VPN.  The sharepoint site would work great in a browser though (that the network drive is mapped to).

    This fixed my issue!

    Thursday, September 7, 2017 1:30 PM