none
Windows 8.1 Network Share 0x8007003b Error Copying Files RRS feed

  • Question

  • Hi All,

    I'm having an issue when copying files from a Windows network share. If the file is above 5MB it will start copying and then after a minute or two I will get an error such as:

    Interrupted Action

    An unexpected error is keeping you from copying the file. If you continue to receive this error, you can use the error code to search for help with this problem.

    Error 0x8007003B: An unexpected network error occurred.


    The network share is in a different office and is accessible over a point-to-point VPN, so the connection is not that fast. 

    But before everyone tells me to start diagnosing the router and or VPN please take note of the following:

    • My colleague who is running Windows 7 can copy files from the network share fine
    • If I run a Windows 7 VM on my Windows 8.1 laptop I can copy the files across fine

    I also know it isn't an issue with this particular file share. I set up a little lab, where I had one VM which had a shared folder and 2 other client VMs one running Windows 7 and one running Windows 8.1. I limited the bandwidth to the two client VMs to a similar speed we see across our VPN. The result was that the Windows 8.1 failed with the same error above, whereas the Windows 7 copied fine.

    There is also a noticeable difference visually when copying using Windows 8.1 and Windows 7:

    • Windows 7 - The progress bar progresses smoothly giving the current speed and estimated time remaining
    • Windows 8.1 - The progress bar progresses in a jumpy fashion. E.g. it shows no progress, then after a minute it jumps and shows 16% progress, then shows no further progress, then jumps by another 18%. There is no estimated time remaining.

    I ran Wireshark to investigate what was going on at the network layer. I see the following behaviour:

    • Windows 8.1 - The file is copying fine then all of a sudden there are a lot of TCP dupack packets. After which the Windows 8.1 client sends a RST packet and then the error pops up.
    • Windows 7 - The file is copying fine then you also see a load of TCP dupack packets, however no error is displayed and it continues copying fine.

    I'd appreciate any help with this I'm hoping there are some settings I can change to make Windows 8.1 behave more like Windows 7!

    FYI originally posed here (but was advised to ask on Technet) - https://answers.microsoft.com/en-us/windows/forum/windows8_1-files/windows-81-network-share-0x8007003b-error-copying/300bc9a4-597b-402a-b885-9dd6f6fb51a2

    Thanks,

    Zak

    Wednesday, April 1, 2015 1:09 AM

All replies

  • Hi Zak1234,

    " If the file is above 5MB it will start copying and then after a minute or two I will get an error "

    Do you mean the file below 5 MB will copy fine ?

    Have you tried to copy the files from another Windows 8.1 machine (This will help us to verify whether the issue is casued by the specific machine)?Have you tried to copy another file from the network share to have a check ?

    If this issue only occurred with the specific Windows 8.1 machine ,we can try the follwing link to reset the Tcp/IP stack to have a check .
    ipconfig /flushdns (Clear the dns cache)
    nbtstat -RR (release and refesh NetBIOS names)
    netsh int ip reset (reset ip settings)
    netsh winsock reset (Reset Winsock Catalog)

    "•Windows 8.1 - The file is copying fine then all of a sudden there are a lot of TCP dupack packets. After which the Windows 8.1 client sends a RST packet and then the error pops up."
    If the dupack packets is old ,then we will get a RST packet.
    We can try the following command line to improve the network performance to have a check .

    netsh int tcp set global chimney=disabled
     netsh int tcp set global rss=disabled
     netsh int ip set global taskoffload=disabled
     netsh int tcp set global autotuninglevel=disabled
     netsh int tcp set global congestionprovider=none
     netsh int tcp set global ecncapability=disabled
     netsh int tcp set global timestamps=disabled

    If there is any antivirus software installed ,please turn them off temporarily to have a check .

    Please also check the Event Viewer for any error information to troubleshoot this issue .

    Event Viewer \Windows Logs\Applications,System

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Thursday, April 2, 2015 6:49 AM
    Moderator
  • Hi,

    I am having exactly same problem and I tried this using two windows 8.1 machines. This confirms it is not a machine specific but windows 8.1 problem.

    I'm yet to use the commands you've suggested.

    Thanks

    Thursday, April 2, 2015 3:34 PM
  • Hi,

    I tried all the command except

    netsh int tcp set global congestionprovider=none

    when i checked the help it says "parameter is deprecated Please use netsh int tcp set supplemental instead"

    No change whatsoever is seen. 

    Thursday, April 2, 2015 6:48 PM
  • Hi Rajanmhrjn,

    The command line is used to improve the performance of the network .The congestionprovider seems no longer supported by Windows8.1 .

    "I am having exactly same problem and I tried this using two windows 8.1 machines"
    Would you please explain more details of this ?Do you mean the shared files larger than 5M can not be copied through the VPN connection from a Windows 8.1 machine and it can be copied from a Windows7 machine ,or it takes with the other symptom ?
    Are there any error messages recorded in the Event Viewer ?

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, April 6, 2015 1:21 AM
    Moderator
  • Hi MeipoXu,

    Yes the windows 8.1 machines are connected to the shared drive though remote access vpn. The shared files larger than 5M cannot be copied through vpn connection. While there is no problem at all when windows 7 is ued.

    I do not see any error messages regarding this in event viewer? 

    Best Regards

    Monday, April 6, 2015 1:40 PM
  • HI Rajanmhrjn,

    Is the VPN the built-in feature or a third party software ?

    If it is a third party software ,I am afraid there may be a compatible issue here .If it is a third party VPN ,it is recommended to look for help from the VPN vendor.

    Usually the built-in VPN should both work with Windows 7 and Windows 8.1 .

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, April 8, 2015 1:11 AM
    Moderator
  • Hi MeipoXu,

    I am afraid but I am using builtin vpn. That is RRAS server and builtin vpn connection. 

    Can you think of any settings in either server or client side which can help?

    Thanks for your help.

    Rajan

    Wednesday, April 8, 2015 1:57 PM
  • To be more specific with the vpn I am using PPTP to connect to the server.

    Thanks

    Thursday, April 9, 2015 4:13 PM
  • Hi Rajanmhrjn,

    I would like to apologize for the delay in replying.

    I have created a new VPN Server and connect to it from my Windows 8.1 machine .I can successfully copy files over 5M actually it is over 30M .This issue may be related to the network .If it is possible , try to copy without the VPN to have a check .

    To analyze this issue further ,we could try to capture the network package with the network monitor .

    Microsoft Network Monitor 3.4 (archive)

    http://www.microsoft.com/en-hk/download/details.aspx?id=4865

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.



    Monday, April 13, 2015 9:52 AM
    Moderator
  • Hi MeipoXu,

    Sorry, it has taken me so long to reply. I thought I had subscribed to receive updates on this thread, but I didn't see anything!

    I've ran the commands you gave but some of them did not work, I got the following error: 

    Set global command failed on IPv4 The parameter is incorrect.

    However, output of current settings are below.

    TCP Global Parameters
    ----------------------------------------------
    Receive-Side Scaling State          : disabled
    Chimney Offload State               : disabled
    NetDMA State                        : disabled
    Direct Cache Access (DCA)           : disabled
    Receive Window Auto-Tuning Level    : normal
    Add-On Congestion Control Provider  : none
    ECN Capability                      : disabled
    RFC 1323 Timestamps                 : disabled
    Initial RTO                         : 3000
    Receive Segment Coalescing State    : disabled
    Non Sack Rtt Resiliency             : disabled
    Max SYN Retransmissions             : 2

    To answer your original questions.

    Do you mean the file below 5 MB will copy fine ?

    5MB is not a hard limit. If the file is small enough it will copy before it errors out. A file of around 5MB or so fails with an error.

    Have you tried to copy the files from another Windows 8.1 machine (This will help us to verify whether the issue is casued by the specific machine)?Have you tried to copy another file from the network share to have a check ?

    Yes I've tried from another Windows 8.1 machine and have the same behaviour. It is the same with different files from the network share. And the same with different network shares.

    I am seeing nothing in the event viewer when the error occurs. I do not believe this to be a VPN issue because I can recreate this situation perfectly. As I mentioned in the original post- I also know it isn't an issue with this particular file share. I set up a little lab, where I had one VM which had a shared folder and 2 other client VMs one running Windows 7 and one running Windows 8.1. I limited the bandwidth to the two client VMs to a similar speed we see across our VPN. The result was that the Windows 8.1 failed with the same error above, whereas the Windows 7 copied fine.

    Basically, I had virtual machines all on the same local network. One virtual machine was hosting a file share with files on it. I created one Windows 7 VM and one Windows 8.1 VM. Using VMWare Workstation you can limit the network bandwidth to the VMs. When I did not limit the network bandwidth I could copy all files of all sizes fine. However, when I limit the network bandwidth to a speed of around 30-50KBps, the Windows 8.1 VM fails to copy files with the same error. But Windows 7 VM copies the files fine.

    The point of limiting the bandwidth in this way is to create a similar scenario to that I see when connecting over the VPN.

    This all leads me to believe there is some sort of issue with copying files from fileshares over slow connections using Windows 8.1.

    Cheers,

    Zak

    Thursday, April 16, 2015 10:08 AM
  • I am having the same problem.

    Multiple windows 8.1 machines on different networks using different files all result in the 0x8007003b error after uploading either exactly 4.00MB or 5.00MB.

    My upload speeds are capped at 500Kbps for all tests.

    This problem only appeared after upgrading to 8.1 and at this point it's a big problem since our primary offsite backup is at the end of 500Kbps DSL.

    Monday, April 20, 2015 12:47 AM

  • Hi Applied Tesla Tech,

    Have you compared your symptom with the others in this thread ?Are you using the built-in VPN server ,have you tested whether the issue  will occur in a Windows 7 machine ?Are all the Windows 8.1 machines up to date ?

    "My upload speeds are capped at 500Kbps for all tests."
    It seems that your testing environment is not similar with the OP`s issue though the error message is the same .
    I recommend you to open a separate thread attached with more details of the issue and masters in this forum will help you to resolve the issue .
    One thread one issue and it is very clear for the people who will come across the similar issue in the future .Thanks for your understanding and cooperation .

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Monday, April 20, 2015 5:32 AM
    Moderator
  • Hi Zak1234,Rajanmhrjn,

    According to your descriptions ,this issue seems to be related to the network performance .I have escalated this case to our engineers who are more familiar with the network issues .
    As we discussed before ,please upload the network package of copying files processes to the OneDrive and paste the link here .We will make a deep research for you .This process may cost much time ,please be patient and keep an eye on this thread .Thanks for your understanding and cooperations .

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, April 20, 2015 5:41 AM
    Moderator
  • Hi MeipoXu,

    What do you mean upload network package? You want a packet capture of what happens when copying the files?

    Also it appears Applied Tesla Tech is experiencing the same issues. 500kbps = ~ 50KBps. So it seems it is similar!

    I will upload a full packet capture shortly.

    Thanks,

    Zak

    Monday, April 20, 2015 6:46 AM
  • Hi All,

    I will clarify a bit more.

    In an office with 4 users on the same VPN (externally hosted on the router) we experience this problem on 2 of the machines, each one is running 8.1 fully up to date. The other 2 are running windows 7 and XP, neither experience this problem. Also, there are 2 windows 8.1 laptops that connect periodically, both experience the problem while 2 apple devices do not. We did not have this problem prior to the windows 8.1 update.

    Also worth noting, the basics, like windows firewall, defender, etc. have no effect. I do not run antivirus software.

    I am happy to provide additional data but I second Zak1234, from were would you like me to get it? There are dozens of way to provide network info...

    Thanks!

    Monday, April 20, 2015 9:12 PM
  • Hi Zak1234 ,Applied,Rajanmhrjn,

    After a deep research ,I found the difference between the Windows 7 and Windows 8.1 in copying files from files share is that windows 7 use SMB 2.0 dialect while windows 8.1 client use SMB 3.02 dialect by default.
     Please run the following command line in powershell to check the present SMB configurations both from the Windows 8.1 and Windows 7 machine .This may help us to find out some useful information .
    "Get-SmbClientConfiguration "

    Apart from this ,we can try to disable the SMB 3.02 dialect in Windows 8.1 machine to have a check .
     To disable SMBv3 on the SMB client, run the following commands:
     sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
     sc.exe config mrxsmb20 start= disabled
     Please note that When you enable or disable SMBv2 in Windows 8 or in Windows Server 2012, SMBv3 is also enabled or disabled
     Here is a link for reference:
     How to enable and disable SMBv1, SMBv2, and SMBv3 in Windows Vista, Windows Server 2008, Windows 7, Windows Server 2008 R2, Windows 8, and Windows Server 2012
    https://support.microsoft.com/en-us/kb/2696547

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Wednesday, April 22, 2015 1:25 AM
    Moderator
  • Hi MeipoXu,

    I think you are on the right track! I disabled SMBv2 & SMBv3 following your instructions and now I can copy the files. The copy dialog box is much more responsive. Before I mentioned that when copying it would not give a real-time indication of speed or progress. Instead it would show no progress, then jump to 13%, then hang again, then jump another 10%.  Now that I've disabled SMBv2 & SMBv3 I get a nice real-time indication of the speed and progress.

    I ran the Get-SmbClientConfiguration command output is below:

    ConnectionCountPerRssNetworkInterface : 4
    DirectoryCacheEntriesMax              : 16
    DirectoryCacheEntrySizeMax            : 65536
    DirectoryCacheLifetime                : 10
    EnableBandwidthThrottling             : True
    EnableByteRangeLockingOnReadOnlyFiles : True
    EnableLargeMtu                        : True
    EnableMultiChannel                    : True
    DormantFileLimit                      : 1023
    EnableSecuritySignature               : True
    ExtendedSessionTimeout                : 1000
    FileInfoCacheEntriesMax               : 64
    FileInfoCacheLifetime                 : 10
    FileNotFoundCacheEntriesMax           : 128
    FileNotFoundCacheLifetime             : 5
    KeepConn                              : 600
    MaxCmds                               : 50
    MaximumConnectionCountPerServer       : 32
    OplocksDisabled                       : False
    RequireSecuritySignature              : False
    SessionTimeout                        : 60
    UseOpportunisticLocking               : True
    WindowSizeThreshold                   : 8

    This is from the Windows 8.1 machine. It seems this command does not exist on Windows 7 so I'm unable to give the output.

    Thanks!

    Zak

    Wednesday, April 22, 2015 6:14 AM
  • Thank you MeipoXu, that did it!

    My system responses much faster now when accessing the network drive and files upload with no errors. As Zak1234 stated I also notice the speed monitor is operating in real time.

    Smb Output after running commands:

    ConnectionCountPerRssNetworkInterface : 4
    DirectoryCacheEntriesMax              : 16
    DirectoryCacheEntrySizeMax            : 65536
    DirectoryCacheLifetime                : 10
    EnableBandwidthThrottling             : True
    EnableByteRangeLockingOnReadOnlyFiles : True
    EnableLargeMtu                        : True
    EnableMultiChannel                    : True
    DormantFileLimit                      : 1023
    EnableSecuritySignature               : True
    ExtendedSessionTimeout                : 1000
    FileInfoCacheEntriesMax               : 64
    FileInfoCacheLifetime                 : 10
    FileNotFoundCacheEntriesMax           : 128
    FileNotFoundCacheLifetime             : 5
    KeepConn                              : 600
    MaxCmds                               : 50
    MaximumConnectionCountPerServer       : 32
    OplocksDisabled                       : False
    RequireSecuritySignature              : False
    SessionTimeout                        : 60
    UseOpportunisticLocking               : True
    WindowSizeThreshold                   : 8

    Wednesday, April 22, 2015 9:45 PM
  • Hello, I had the same issue with a network that include a NAS and W7 & W8 PC and notebook. Locally they could transfer files over 5MB, but only W7 could transfer this kind of files over VPN.

    when I revised the windows file service configuration on my NAS, I saw that I was check enable SMB2 and enable large MTU.

    to try solve this issue , in my router I chose manual MTU and wrote 1500, but the trouble continued.

    at the end I disable on my NAS SMB2 and large MTU and in my router I selected automatic MTU. This solved the trouble.

    I hope that will be a little help or that it will some kind of light.

    best regards


    • Edited by Luis_Rios Saturday, April 25, 2015 2:56 AM
    Saturday, April 25, 2015 2:55 AM
  • Hi MeipoXu,

    Whilst disabling SMBv3 and SMBv2 does rectify the issue, I would suggest it is not really a suitable fix as there are a lot of disadvantages to using SMBv1. In that article it also mentions that SMBv2 should only be disabled temporarily for troubleshooting purposes.

    Having done a little more digging I have discovered that the issue does not seem to be the use of SMBv3. Or at least if I perform packet capture of two hosts connecting to a file server, both Windows 8.1 and Windows 7 appear to be using SMBv2. Furthermore, the server does not have support for SMBv3.

    So while downgrading down to SMBv1 does work, it would appear that the issue isn't with SMBv3. But rather something else that changed in the configuration of SMBv2 between Windows 7 and Windows 8.1

    Cheers,

    Zak

    Sunday, April 26, 2015 4:10 AM
  • I'm facing the same problem using OpenVPN and Samba 4.1.6 on Ubuntu 14.04 LTS Server: Wireshark clearly shows that my Win 8.1 and Samba are negotiating to SMB2, not SMB3, and my client starts to transfer 1 MB blocks of data. After exactly 5 of those, my client always resets the connection to the server by issuing TCP RST combined with an ACK. There's no obvious error before the RST or else, the client is just closing the connection to Samba altogether. This is always reproducible with my Win 8.1 and never happens with my Win 7 in a VM which ultimately uses the same OpenVPN connection to the Samba server. The only workaround currently is as mentioned to downgrade SMB2 to SMB1, no changes in TCP Auto Tuning or else worked. The behaviour is always the same: 5 1 MB blocks of data which I'm able to see successfully stored in the filesystem of the Samba server, because while Samba is creating a larger sparse file, "du -h" only shows the allocated 5 MBs of data and looking at the file in a hex editor it contains some data followed by a lot of 0s.

    In case of Samba, instead of reconfiguring the Win 8.1 client one can configure the server as well using the "server max protocol" directive and setting it to "NT1". It is important that NT1 is used, no other SMB2 setting worked in my tests. Additionally to be sure it works, restart your Windows because I had the feeeling that once it negotiated SMB2 in earlier connections, it won't use SMB1 anymore even if Samba gets restarted and Windows reconnects to it. Setting only "client max protocol" to NT1 doesn't work as well, because that only seem to be a recommendation if the server is able to use newer protocols and client and server will still renegotiate to SMB2. I simply set client and server to the same setting and the problem went away, while my Win7 is still working as well.

    Reconfiguring Samba in such an environment has two benefits: One can document the problem directly in its configuration and using the "include" statement and variable substitution feature of Samba it should be possible to downgrade the server to use SMB1 only for Win 8.1 clients, but I didn't test that because I don't care in my environment for now.

    This really looks like a bug in Windows 8.1 SMB2 stack over VPN connections to me and should be investigated further.


    Wednesday, September 9, 2015 8:18 PM
  • It looks this problems also occurs in Windows 10.
    Friday, October 2, 2015 11:11 AM
  • I have the exact same problem. My client is running Windows 10 Pro Version 1511. I am transferring data to and from a Samba 4.1.12 server.

    When being connected directly to the Server via Ethernet, I have no problems whatsoever.

    When being connected through an OpenVPN tunnel which limits the bandwidth to the server, data transfers abort with error 0x8007003B after a few MB (actual size varies).

    I have TCP dumps from both the client and server side showing that the client issues a TCP RST somewhere in the middle of a SMB2 WriteRequest. I do not see an unusual amount of lost/retransmitted packages or late ACKs before that event.

    I can confirm that downgrading to SMB1 solves the issue, but this is no acceptable fix!

    I can also confirm the visual difference that the progress bars of SMB2 transfers jump while SMB1 transfers move more smoothly. I guess this is because SMB2 uses much larger packet sizes.

    Friday, November 20, 2015 10:06 AM
  • Same here with Win10: I try to copy a larger file (4 MB) from remote QNAP NAS which is connected via VPN to a local drive on Win10. The remote QNAP share is connected / mapped via "net use ...". The result is as described above, copying error at the end.

    However, I have a workaround which may work for some of you. If I do select a locally connected QNAP share as the target drive the copying works! (so the file is transferred via VPN from remote QNAP to local QNAP via Windows 10 client. Strange.

    Thursday, March 31, 2016 8:04 PM
  • Same here with Win10 also.  In my situation I have 4 remote users connecting to a QNAP NAS drive.  They can connect using built in Windows PTPP VPN connection or OpenVPN.  They have mapped drives to an SMB share on the NAS, I've also tried it using network locations rather than a mapped drive.  All result in "unexpected network error..." when trying to copy multiple files and/or large files.  One user has an old XP machine and that often fails with "Network Busy" errors and/or "The parameter is incorrect" when using built in PTPP VPN Connection or "Delayed write" error when using OPENVPN.  The speed of the remote network connections varies widely and all are using mass market ISPs and Mass market modem/routers (BT, TALKTALK).  All traffic is going through my own Netgear Modem/Router.

    I am on the same LAN as the NAS and I can happily transfer files either by simply mapping a drive to the SMB share or using a network location.  I can also happily transfer files by creating a VPN tunnel within the LAN or by making a VPN tunnel to the NAS over the Internet to my WAN IP address and mapping to an SMB share - these all work without issue regardless of the VPN method used, but when a remote user connects the problem occurs.

    My tests to date suggest the issue is limited to any VPN/SMB connection that originates from outside the LAN.  I keep coming back to SMB versions/issues and this thread seems to be very close to what I experience, but none of the suggested solutions seem to work for us. Other forums had suggested similar solutions.  I have tried disabling SMB v2/3 but this appears to make no difference on the machine (Win10 Pro latest build and updates) I have been using for testing.

    In trying to resolve this problem we have resorted to using WebDav connections and these seem to work OK, likewise using WinSCP with WebDav also works.  For us WebDav is the workaround and our current solution but it would be good to get the VPN/SMB connection working.

    JT_FG - you propose another workaround "I have a workaround which may work for some of you. If I do select a locally connected QNAP share as the target drive the copying works! " could you elaborate please, I'm not clear what you describe.

    Thursday, May 19, 2016 11:01 AM
  • I am not as tech savvy as those posting here, but I can report I have this same issue copying files over 3-4  MB to and from our remote server at work using Windows 10 Pro Version 1803, and Cisco AnyConnect VPN. In my situation it appears related to my ISP. My ISP at home is DSL through Centurylink. I get the 0x8007003b an unexpected error has occurred on any files over 3-4 using my home DSL . I can however log in to my neighbors ISP (Comcast Xfinity Cable) and transfer larger files with out issue. For me the issue appears to be related to the available speed/bandwidth of the ISP I am using. I have not tried the work arounds described above. While the simple answer for me seems to be change ISPs, that does not help when working remotely out of town or out of country where ISPs and and available speeds/bandwidth can also be  slower.
    Saturday, August 18, 2018 4:03 AM