none
The ribbon on Power query and power pivot is greyed out in Excel 2013 RRS feed

  • Question

  • It is a new install from Office 365 and the latest release.

    Where do I need to look to get Power query and Power pivot working?

    Are there settings that I need to change?

    Wednesday, April 2, 2014 5:58 PM

Answers

  • Can you check what your default save file format is?

    Go to File, Options, Save, and look at what is selected for "Save files in this format".

    Friday, April 4, 2014 8:37 PM

All replies

  • What version of Power Query do you have, you can go to Power Query tab->About to find out.

    Thanks


    Zafar Abbas

    Thursday, April 3, 2014 1:05 AM
  • Version: 2.10.3598.81
    Thursday, April 3, 2014 12:20 PM
  • Is this the case even if you start with a blank workbook? I ask because that's the expected behavior if you start by opening something other than XLSX.
    Friday, April 4, 2014 4:26 PM
    Moderator
  • If I open a new work book the ribbon is greyed out. When I open an existing sheet power query ootions are shown. When and how will options in blank new sheet been shown?
    Friday, April 4, 2014 8:09 PM
  • Can you check what your default save file format is?

    Go to File, Options, Save, and look at what is selected for "Save files in this format".

    Friday, April 4, 2014 8:37 PM
  • Hi David, that was the clou what I was looking for!

    By default at first installation the file save settings are not an Excel workbook by default.

    The moment I had changed it in the Options - save  settings into save as Excel workbook (with or without macro's) the Power query ribbon was displayed completely.

    BTW: I don't understand why Microsoft doesn't ship with the default settings for save as Excel workbook.

    Saturday, April 5, 2014 5:51 PM
  • Glad to hear that fixed the issue for you. As far as I know Excel does ship with .xlsx as the default save file format, so if you did not change it manually, it's possible another add-in might have changed it.
    Monday, April 7, 2014 6:51 PM