none
Yet again - Unexplainable delay installing printers.

    Question

  • Logging onto TS as user for first time, assigned one printer via GPO.

    Prior to this confirmed both the print server and the terminal server have the exact same driver version for this printer.

    If I log on as any account and then add the printer it adds 100% fine within about 10 seconds (why even 10 seconds delay god only knows...).

    I log on as the user with the assigned printer via GPO, it's been sitting there at applying printer policy for 10 minutes.

    The last Application Event Log entry @ 11.45AM:

    The winlogon notification subscriber <GPClient> is taking long time to handle the notification event (Logon).

    Group Policy Event Log Entry @ 11.44AM:

    Starting Group Policy Printers Extension Processing.

    List of applicable Group Policy objects: (Changes were detected.)

    PRI_GMH

    Last User.log entries:

    2012-10-12 11:44:56.788 [pid=0x45c,tid=0x4b08] CSE GUID : {BC75B1ED-5833-4858-9BB8-CBF0B166DF9D}
    2012-10-12 11:44:56.788 [pid=0x45c,tid=0x4b08] Flags : (   ) GPO_INFO_FLAG_MACHINE - Apply machine policy rather than user policy
    2012-10-12 11:44:56.788 [pid=0x45c,tid=0x4b08]         (   ) GPO_INFO_FLAG_BACKGROUND - Background refresh of policy (ok to do slow stuff)
    2012-10-12 11:44:56.788 [pid=0x45c,tid=0x4b08]         (   ) GPO_INFO_FLAG_SLOWLINK - Policy is being applied across a slow link
    2012-10-12 11:44:56.788 [pid=0x45c,tid=0x4b08]         (   ) GPO_INFO_FLAG_VERBOSE - Verbose output to the eventlog
    2012-10-12 11:44:56.788 [pid=0x45c,tid=0x4b08]         (   ) GPO_INFO_FLAG_NOCHANGES - No changes were detected to the Group Policy Objects
    2012-10-12 11:44:56.788 [pid=0x45c,tid=0x4b08]         (   ) GPO_INFO_FLAG_LINKTRANSITION - A change in link speed was detected between previous policy application and current policy application
    2012-10-12 11:44:56.788 [pid=0x45c,tid=0x4b08]         (   ) GPO_INFO_FLAG_LOGRSOP_TRANSITION - A change in RSoP logging was detected between the application of the previous policy and the application of the current policy.
    2012-10-12 11:44:56.788 [pid=0x45c,tid=0x4b08]         (   ) GPO_INFO_FLAG_FORCED_REFRESH - Forced Refresh is being applied. redo policies.
    2012-10-12 11:44:56.788 [pid=0x45c,tid=0x4b08]         (   ) GPO_INFO_FLAG_SAFEMODE_BOOT - windows safe mode boot flag
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08]         (   ) GPO_INFO_FLAG_ASYNC_FOREGROUND - Asynchronous foreground refresh of policy
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Token (computer or user SID): S-1-5-21-1427866509-857593032-1244538494-9894
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Abort Flag : Yes (0x021babd0)
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] HKey Root : Yes (0x00001514)
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Deleted GPO List : No
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Changed GPO List : Yes
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Asynchronous Processing : Yes
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Status Callback : Yes (0x746570bd)
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] WMI namespace : Yes (0x01c4583c)
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] RSoP Status : Yes (0x01fcf66c)
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Planning Mode Site : (none)
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Computer Target : No (0x00000000)
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] User Target : No (0x00000000)
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Calculated session relevance.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed CSE pre-processing.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Calculated list relevance. [SUCCEEDED(S_FALSE)]
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Deleted GPO list is not relevant to the CSE.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Calculated list relevance.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Planning mode not detected.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Processing changed list.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Processing user policy.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Got WMI namespace for logging mode.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed get GPO list.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Initialized internal RSoP storage.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed GPO list pre-processing.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] ----- Changed - 0
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Options : (   ) GPO_FLAG_DISABLE - This GPO is disabled.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08]           (   ) GPO_FLAG_FORCE - Do not override the settings in this GPO with settings in a subsequent GPO.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Options (raw) : 0x00000000
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Version : 131074 (0x00020002)
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] GPC : LDAP://CN=User,cn={D70EA9AE-A3D2-4EC5-BC59-06F8632327D7},cn=policies,cn=system,DC=CHFTE,DC=local
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] GPT : \\CHFTE.local\SysVol\CHFTE.local\Policies\{D70EA9AE-A3D2-4EC5-BC59-06F8632327D7}\User
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] GPO Display Name : PRI_GMH
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] GPO Name : {D70EA9AE-A3D2-4EC5-BC59-06F8632327D7}
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] GPO Link : (   ) GPLinkUnknown - No link information is available.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08]            (   ) GPLinkMachine - The GPO is linked to a computer (local or remote).
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08]            (   ) GPLinkSite - The GPO is linked to a site.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08]            (   ) GPLinkDomain - The GPO is linked to a domain.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08]            ( X ) GPLinkOrganizationalUnit - The GPO is linked to an organizational unit.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08]            (   ) GP Link Error
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] lParam : 0x00000000
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Prev GPO : No
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Next GPO : No
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Extensions : [{00000000-0000-0000-0000-000000000000}{A8C42CEA-CDB8-4388-97F4-5831F933DA84}][{BC75B1ED-5833-4858-9BB8-CBF0B166DF9D}{A8C42CEA-CDB8-4388-97F4-5831F933DA84}]
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] lParam2 : 0x04e9ade4
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Link : LDAP://OU=Users,OU=GMH,OU=Sites,DC=CHFTE,DC=local
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed get GPH path. [SUCCEEDED(S_FALSE)]
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] GPH : C:\ProgramData\Microsoft\Group Policy\History\{D70EA9AE-A3D2-4EC5-BC59-06F8632327D7}\S-1-5-21-1427866509-857593032-1244538494-9894\Preferences\Printers\Printers.xml
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed set extensions.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed get GPO is relevant.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed get GPT path.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] GPT : \\CHFTE.local\SysVol\CHFTE.local\Policies\{D70EA9AE-A3D2-4EC5-BC59-06F8632327D7}\User\Preferences\Printers\Printers.xml
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed RSoP init.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed get next GPO.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed check GPO license usage.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed GPO pre-processing.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Started removing policy.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] GPH data file : C:\ProgramData\Microsoft\Group Policy\History\{D70EA9AE-A3D2-4EC5-BC59-06F8632327D7}\S-1-5-21-1427866509-857593032-1244538494-9894\Preferences\Printers\Printers.xml
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed remove GPH. [SUCCEEDED(S_FALSE)]
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Started applying policy.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] GPE data file : \\CHFTE.local\SysVol\CHFTE.local\Policies\{D70EA9AE-A3D2-4EC5-BC59-06F8632327D7}\User\Preferences\Printers\Printers.xml
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Set user security context.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Opened file.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Got file size.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Created file buffer.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed read file data.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Terminated file buffer.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Closed file handle.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Read GPE XML data file (455 bytes total).
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Set system security context.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed parse of GPE XML data.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed loading of package.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Completed get tree root.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Started package execution.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Set package timestamp variable (2012-10-12 00:44:56).
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Starting class <Printers>.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Handle Children.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] {9A5E9697-9095-436d-A0EE-4D128FDFBCE5}
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Starting class <SharedPrinter> - GMHPR01.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Set user security context.
    2012-10-12 11:44:56.804 [pid=0x45c,tid=0x4b08] Set system security context.

    It's now 12 Noon and the logon window is still at "Applying Group Policy Printers policy".

    What the F*** Is happening? How am I meant to even come close to finding what is happening if every applicable log just stops at that time and there's no entry saying what's going wrong???

    Friday, October 12, 2012 12:59 AM

All replies

  • Attempting to close the broken logon and log back in again just brings up:

    Waiting for Group Policy Client.

    That's now been up for 5 minutes.

    I hate ranting and going on about this on a "professional" forum but there's absolutely no reason I can see for this to occur. I've set everything up fine, both servers have the same driver version, this TS normally works fine for 10 other sites, they're located physically next to each other with gigabit between, I've checked logs (that just tell me nothing).

    I can't do my job. Why would I support any Microsoft product when I do everything right, I follow the MS advise and setup logging and check things and nothing works as I'm told it should.

    Friday, October 12, 2012 1:04 AM
  • So I had to add back in another TS to the farm, removed this one, killed the now 20 minute long "Waiting for Group Policy Client" window, removed the Printer GPO and then log back on.

    Logs on in alike 10 seconds.

    Goto printers, add printer, select the printer in the GPO, installs in like 2 seconds.

    So what caused my TS to break and me to now have to bleed it and reboot it later??

    I try to install a printer just as what's recommended, selected from the printer server, set to upgrade, no other options set or changed and it kills my server??

    I want someone from Microsoft on this. When I do everything 100% as MS recommend and it still doesn't work, and infact breaks things that's a bug or a fault that needs to be addressed.

    Friday, October 12, 2012 1:23 AM
  • No offense, but if you want someone from Microsoft please call the support. It will cost you some, but if it save you some weeks of debugging it's maybe worth it.

    A general's question, Did you try other's way to push your printer to those TS ? did you checked if driver isolation is at on or off on the TS for that printer ? (In some TS I manage I used to put at off the driver isolation for that, it was making the login longer (3min to 1.5min, but not 10min like you) and the spooler was never crasshing, thus the need for isolation was not there)


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/




    Friday, October 12, 2012 2:22 AM
  • I just don't see the justification in paying for support because I followed their initial instructions. I am considering it at this point.

    I've tried deploying via print management to the same GPO and get the same delay, except on "Processing Deployed Printers policy". Unfortunately 2008 servers, so no Isolation.

    With the time iteself, I get delays sometimes and have been troubleshooting them non stop the last week or two it seems, most of it gets under control, but then you have this situation where it never gets past processing printer policy, can sit at it for an hour and nothing. My question really is what do I do next? The logs aren't telling me anything, the driver has no issues installing if done manually.


    Friday, October 12, 2012 3:29 AM
  • Please see, http://social.technet.microsoft.com/Forums/en-US/winserverGP/thread/0a32ecde-d414-4859-8bbf-ad86b1b06070

    If you try via GPP does it give you the same delay ?  In last resort If the RDP's client bring the printer, do you got a delay ?

    To be honest on a critical' TS server I had to make all printqueue locally, and setting all security on each printers so users can't see other printers that they don't belong too (same security's group as the GPO pushing it). It was a xenapp server, so a big delay was not acceptable at all because it's like a remoteapp server, you can't interface a ts app in a workstation pc and tell the user it got to wait 5min. 

    That whole point is, local printer is the faster, if you bring the printer, or push the printer, do you save those profile on your TS ? so the login will be fast the next time.

    Don't forget you can import only the default's printer too in the TS with the RDP's client. You can setup the GPO to work in the background, so the printer will continue to install even if the user isalready's logged, etc..

    The good point is, you found the bug, it's the GPO, make a .html report in worst case and let us see it. Maybe a error in it.


    MCP | MCTS 70-236: Exchange Server 2007, Configuring

    Want to follow me ?  |  Blog: http://www.jabea.net | http://blogs.technet.com/b/wikininjas/

    Friday, October 12, 2012 3:56 AM
  • Hi Allister Wade,

    ..next step after 'Set system security context'  should be 'Properties handled.' which from my knowledge is drivers properties, so I am pretty sure that it is a drivers issue..

    Windows 7 looks for “Package point and print” drivers first.  When it doesn’t find them, it then looks for 'standard drivers'.

    As I remember, you are using Lexmark , is all drivers are 'packaged'? (pls. paste a screenshot of drivers tab from printmanagement).

    If you must stick with those drivers (do not have an option to change them for packaged) I think the only way is to change your GPs to use GP Deployed Printers rather than GPP (located in "User Config\Policies\Windows Settings\Deployed Printers").  

    Friday, October 12, 2012 8:29 AM
  • Hi

    Well, I'am not from MS, but I can try to help you to find an answer, thats why the forum exist.

    If you monitor you TS, do you see the spooler to hang ? (Can you kill the process to see if the login finish faster after on the other session). (A bad driver can of course cause issue like that, so try to put a dummy driver on it to test out)


    Regards, Philippe

    Tuesday, December 10, 2013 3:53 AM
  • Have you tried this QFE?  I'm not sure how Group Policy Preferences adds connections but the symptoms seem the same.  Also make sure the print driver is not throwing UI to session 0.  HP likes to do this in order to obtain installed options for the device

    Long logon time when you use the AddPrinterConnection VBScript command to map printers for users during logon process in Windows Server 2008 R2 SP1

    http://support.microsoft.com/kb/2896881/en-us


    Alan Morris Windows Printing Team

    Tuesday, December 10, 2013 9:24 AM
    Answerer
  • Hi Alan

    Thanks for the reply. Can you elaborate on "QFE". Not something I'm familiar with.

    As for other suggestion I'm aware of issues with HP drivers and UI issues and it possibly being that - did have this at another customers site when I was working nearby and helped them find this as the cause, in this case we just moved to the HP UPD which does behave mostly OK.

    Though it does seem this is what's happening - the process is seemingly waiting on an invisible UI or prompt indefinitely but I don't think from the printer installation dialogue (because this happens with any vendor printer it seems from my experience, at least HP, Fuji Xerox, Toshiba, Lexmark, Canon from top of my head) I'm unsure how to find what it is waiting on - maybe you can help with explaining how to find out if it is waiting on something UI related?

    This currently is with (and seems to be most common on) a Server 2008 machine, NOT R2. In the past I have tried installing basically every possibly related hotfix without resolution.

    Half my issue though is really figuring what is happening here - not that it's happening. I'm Server 2012 MCSA, I've read books like Group Policy Fundamentals by Jeremey Moskowitz, I've followed what I'm apparently meant to do in terms of enabling the "advanced" logging and such, and none of it helps with this issue. Just very frustrating.

    Tuesday, December 10, 2013 9:38 AM
  • QFE == Quick Fix Engineering.  Here's the WIKI

    http://en.wikipedia.org/wiki/QFE

    I look in the Application event log for Interactive Service detection events.  The printer name is typically included in the event.  I've seen Lexmark, HP , and one other vendor throw UI to session 0.  If you can log on locally to the server you should have the option to switch to session 0 to dismiss the dialog. 

    The UI is waiting for the device to return a network call to populate the settings fields.  If something blocks the response I think this gets stuck.  If the device is not actually turned on I expect a network timeout value gets hit and the defaults from the driver are used.

    Throwing UI to the Interactive session is not supported by any driver included in Windows.  Vendors that had code that did this were not allowed into the product until they removed these methods. 

    For Server 2012, the Interactive Service session is disabled.  There is a registry setting that will allow the service to start but disable by default.  HP is fully aware of this (I explicitly informed the group that provides HP code for inbox driver support) since MS has some older Plotter devices with drivers popping session 0 UI.  At least on Server 2003, you could see the UI when logging onto the machine and dismiss it for "hung" shares.


    Alan Morris Windows Printing Team

    Tuesday, December 10, 2013 10:46 PM
    Answerer
  • have seen other threads with slow printing issue, and some of them was a firewall issue.

    if you are using Symantec Endpoint Protection, it comes with a firewall and sometimes for whatever reason it will cause a delay in printing.

    Try disabling firewall or anti virus and do a test print and check if it will help. :)


    Every second counts..make use of it. Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Wednesday, December 11, 2013 7:56 AM
  • Hi Alan

    I've double checked everything with the current client and there is literally nothing being logged when the issue occurs.

    Currently I can 100% reproduce merely via a gpupdate /force as a logged on user with the printer mapped via Group Policy. Just sits on applying user settings forever, nothing logged, no prompts, nothing.

    Just so I have it in writing as well. I started with an existing "normal" TS GP configuration set to replace via loopback scoped to the TS.

    First I tried this all by changing it to merge and having the mappings in another GPO. Of course when it came time to test why this was yet again happening who knows if it is definitely the Mapping GPO or another GPO.

    So I changed back to replace loopback and simply added printer in that GPO and get the same issue.

    This seems weird to me that there is nothing being logged at all when applying the user policies under the Application log for each configuration as I've seen in the past. But even with that all I'd see with this issue is it applying group policy printers and group policy client is taking a long time to respond.

    All of this is detracting from the point though.

    I can double click the print queue as the user and it installs. It just installs. There's no delay, there's nothing installed as the driver is already installed.

    I can use VB Script and it works the exact same.

    I try to use Microsoft's "best practice" and setup via Group Policy and not only doesn't it work but there is literally no given way to figure why not... I've asked and pleaded just to be told how to find out.

    I don't understand how I'm the only one on here posting saying this doesn't work... What are others doing that I'm not? What am I missing because this happens OVER and OVER and OVER with customer after customer and I've never ever been able to fully resolve. It's embarrassing and makes me beyond angry at Microsoft for not making this work.

    Wednesday, December 18, 2013 6:09 AM
  • Here is as much possible logging I can get Alan. This is from the user trace log when enabled via Group Policy settings, enabling for all info, warnings & errors (the most you can enable):

    2013-12-18 17:11:18.644 [pid=0x3e8,tid=0x990] Starting class <SharedPrinter> - SYDPR01.
    2013-12-18 17:11:18.644 [pid=0x3e8,tid=0x990] Set user security context.
    2013-12-18 17:11:18.659 [pid=0x3e8,tid=0x990] Set system security context.

    And that's it. Nothing else will ever be logged. In the past I've seen it sit there for upwards of 30 minutes, hours, random amounts of time and then magically proceed to log in. There'll be no explanation in the log, no reason, nothing.

    HOW DO I FIND OUT WHY?



    Wednesday, December 18, 2013 6:11 AM
  • And after 1 hour (pretty much exactly) the account logs in. Mapped printer is not present. ONLY log entry anywhere I can possibly find is this:

    The winlogon notification subscriber <GPClient> took 3595 second(s) to handle the notification event (Logon).

    Well thanks for all the information Windows.

    Wednesday, December 18, 2013 8:03 AM
  • I do not know how the Group Policy client application creates the logs.  Do all the Group Policy printers connections use the same print drivers?  Have you set up some shares that use Generic Text driver and experience the same delay?

    On server 2008, the critical print events are added to the System event logs.  Have you enabled the Informational print events on your TS server? You can add the Print Server Role and use printmanagement.msc to configure the spooler logging levels

    I'd check if there is a bunch of unused registry keys under

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider

    That was what the previous 2008 R2 QFE was released for.  I have no idea if the same is true for Server 2008. 

    For specific questions on Group Policy logging you should ask in the Group Policy forum.

    As a couple of the guys trying to assist you pointed out, this is a forum, it's not MS support.  Yes the moderators of the forum work for Microsoft.  Many of the best solutions in this forum will come from people who do not work at Microsoft.  These are people how have experience and a passion for technology and they wish to share some of the information they have accumulated here. 

    I know others have been successful using Group Policy Preferences to add printer connections. 


    Alan Morris Windows Printing Team

    Friday, December 20, 2013 8:08 AM
    Answerer
  • Hi,

    Remove each printer one by one to see in your GPO in case if one is having difficulty to map in GPO. Ca you export the GPO in .HTML to be able to see where the bug might come from. As Alan's told, I agree that it appear a GPO's problem, but I can't tell you you did a error on setting B when I can't see it..

    Can you make a magic test, put the a user as a local admin and test out after. If it work it's point and click problem and such... It will rule out a lot of diagnostic path that simple test.

    Thanks


    Regards, Philippe


    Saturday, January 4, 2014 4:58 AM
  • Can we try this fixit?

    http://support.microsoft.com/kb/2853367/EN-US


    Hari Kumar Disclaimer: This posting is provided AS-IS with no warranties or guarantees and confers no rights

    Monday, January 13, 2014 4:48 AM
  • Is there an external firewall on the server?  A lot of services including the print spooler service listen on dynamic ports via rpc (49152-65535).


    • Edited by JS2010 Friday, May 18, 2018 2:07 PM
    Friday, May 18, 2018 2:06 PM