none
VM Backup Failed on DPM Server where VM Disk Stored on Scale out File Server RRS feed

  • Question

  • Hi All,

    Good Day!!!,

    We are stuck in one issue where VM Backup using DPM Server 2012 R2 from Scale-out file share path

    Infra  Details :  We have 8 Blade Server and this we configured Failover cluster , on top of this cluster we created 2 VMs as SOFS01 & SPFS02 , SCDPM server and also have created 10 VMs which host All System center Suites applications for private cloud build.

    Again In between two VMs SOFS01 & 02 Server we used NPIV to attach Storage directly for create cluster and for Scale out file server configurations.

    After create scale out file server we created multiple share on each CSV disk and mapped this shares into Each SCVMM Cloud

    Now VMs are created on all SCVMM Cloud as per the Share mapped from SOFS server.

    We could able to configure Protection group and schedule backup for 12 Management VMs created on top of primary cluster successfully.

    But the same we could not able to do the same for VMs where the store location is on SOFS cluster.

    We are collected Event error Description from Scale Out file server.

    Event Error1:

    Shadow Copy Provider {89300202-3cec-4981-9171-19f59559e0f2}.
    Volume Shadow Copy Service error: Error calling a routine on a Shadow Copy Provider {89300202-3cec-4981-9171-19f59559e0f2}. Routine details BeginPrepareSnapshot({50cf5dbb-2248-4ccb-b8ae-545ec8921366},{3a51c364-670d-4e85-bf5f-09fe9aa4d345},\\SOFS.domain.NET\PRONORMAL\) [hr = 0x8004230f, The shadow copy provider had an unexpected error while trying to process the specified operation.
    ].
    Operation:
       Add a Volume to a Shadow Copy Set

    Context:
       Execution Context: Coordinator

    Error2 :

    Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID {3e02620c-e180-44f3-b154-2473646e4cb8} [0x80040154, Class not registered
    ].
    Operation:
       Obtain a callable interface for this provider
       Add a Volume to a Shadow Copy Set

    Context:
       Provider ID: {74600e39-7dc5-4567-a03b-f091d6c7b092}
       Class ID: {3e02620c-e180-44f3-b154-2473646e4cb8}
       Snapshot Context: 4194329
       Execution Context: Coordinator

    Attaching Image file for more understand

    Pcloud Infra Diagram

    thanks in advance.


    Regards, Kesa_Kara Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    • Edited by kesa_kara Wednesday, November 23, 2016 6:10 AM Diagram Inserted
    Tuesday, November 15, 2016 8:16 AM

Answers

  • Hi All,

    Happy New Year 2017!!!,

    Taken long time to reply this.

    Its actually solved the  issue. The thing is that Permission! Permission! Permission!.

    I was not given correct permission to the share folder on SOFS Share which is updated share path into SCVMM Cluster Group.

    Added Full Control permission on Both Security & Share

          All Hyper-V Host(Host$) Servers(8 Hosts)  given as full control 

          SCVMM Server(Host$) given as full control

          SCDPM server(Host$)  given as full control

          Add SCVMM Admin group as full control

          Add SCDPM admin group as full control

     After do all the above settings we could able to do backup from SCDPM without any issue.

    In Another If we created share Folder from SCVMM -->File Server--> Create File Share

    we will get all permission on Hyper-V Host & SCVMM , but we need to add SCDPM permission on Share manually.

    Hope this may be helpful to some one.

    thanks,


    Regards, Kesavan K M. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by kesa_kara Wednesday, January 4, 2017 8:51 AM
    Wednesday, January 4, 2017 8:51 AM