locked
How to edit TS RemoteApp file extension association RRS feed

  • Question

  • Hi,

     

    I would like to know if it's possible to edit the file type association after you publish an application in TS 2008. During the publishing process there is no way to add your own extensions in the .msi package.

    I would be interested if there is a way to add my own extensions, in special (URL associations).

    To be more specific, I published IE and when I created the .msi package the following extension were added: .html, .htm, .gif, .mfp, .mht.

    For all these extensions the remote IE takes over but when I click on an embedded link in Outlook or any other application that looks like this:

    http://feeds.feedburner.com/~r/securosis/~3/230375437/

    or even

    http://www.microsoft.com

     

    the link association doesn't work.

     

    I managed to change the file type association on the client side for the http url to use the remote IE:

    "mstsc.exe" /Remotefile:"%1" "C:\Program Files\iexplore.rdp"

     

    ....now when I click on an embedded link it opens up the remote IE and it asks me for authentication. After I authenticate a message like this comes up:
    "The remote program server is not configured to open the type of data file that you are attempting to open. The complete name of the file that you are trying to open is:

     http://feeds.feedburner.com/~r/securosis/~3/230375437/ " or "http://www.microsoft.com"

     

    If I open iexplore.rdp (for editing) I can see those extensions there and I could add more....the question would be.....how I could add the "http url" there ...and if it's enough just to change the rdp file...or there is something more to be done on the server side....and how?

     

    I would really appreciate your help on this. I'm stuck and I don't know what to do more...or maybe you could suggest a different forum where I could post this issue.

     

    Thanks in advance,

     

    Adrian

    Wednesday, February 6, 2008 9:08 PM

Answers

  • Hi Adrian,


    Unfortunatly, we dont support this scenario.
    However this is valueable feedback, and we will consider it in the future.
    In the meantime, you can try thridparty MSI authoring tools to accomplish this.

    Cheers,
    Moshe


    “This posting is provided "AS IS" with no warranties, and confers no rights”

    Friday, February 8, 2008 2:00 AM

All replies

  • Hi Adrian,


    Unfortunatly, we dont support this scenario.
    However this is valueable feedback, and we will consider it in the future.
    In the meantime, you can try thridparty MSI authoring tools to accomplish this.

    Cheers,
    Moshe


    “This posting is provided "AS IS" with no warranties, and confers no rights”

    Friday, February 8, 2008 2:00 AM
  •  

    Hi Moshe,

     

    Thanks for your reply.....but could you please be more specific?

    What I'm supposed to modify using third party MSI authoring tools?

    What is the actual process when you launch and .rdp file? Is the .rdp file the one that controls what kind of extensions are associated to the published program or is something on the server that controls it? 

     

    Thanks again,

     

    Adrian 

    Friday, February 8, 2008 2:19 AM
  • Adrian,

     

    I had a similar issue with SolidWorks, if you edit the msi with a tool like Orca or Wise installer's tools or MakeMSI you can add the needed .extention registration to the "extention" table inside the msi.  I was getting this this very same error and editing the msi and allowing commandline args on the TSRA publishing settings  resolved it.

     

    -Kevin.

     

     

    Tuesday, February 19, 2008 1:02 AM
  • Hi Kevin,

     

    I could try to use a third party tool for modifying the msi file, no issues there. The only issue that I have right now is that I don't know how to add "anything that is http or https" in the extension list....this is not an actual extension.....is more like an URL association....

    Anyway, your answer tells me that the issue is not on the server, if you are able to modify the msi file and add more extensions it'll work !!!.... it is good to know.....

    If you could help me with my "http association" issue.....would be great......

     

    Thank you in advance,

     

    Adrian

     

     

    Tuesday, February 19, 2008 4:03 AM
  • My appologies for a reply 2 months after the fact.. lol

    Adrian,

    In short I'm not sure your going to be able to redirect the embedded links as it's not handled by file association but by something else protocol handler?  In any case you could I guess in theory try to hack up the following key to kick off a remote IE instance instead of a local one.

    HKLM\Software\Clients\StartMenuInternet   <--- this is the default browser selection\storage location last I knew
    or HKCU same key.

    I'm thinking if you set the shell\open\command entry like you did the others it might actually work  (might actually avoid all the other work you had to do too).   Also take a look at the following when I have FF as the default
    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\FIREFOX.EXE\Capabilities\URLAssociations

    Would be interesting if you actually got it to work.

    Wish you luck.  (hey maybe you already solved it anyway)






    Tuesday, May 6, 2008 11:20 PM
  • Adrian,

     

    I had a similar issue with SolidWorks, if you edit the msi with a tool like Orca or Wise installer's tools or MakeMSI you can add the needed .extention registration to the "extention" table inside the msi.  I was getting this this very same error and editing the msi and allowing commandline args on the TSRA publishing settings  resolved it.

     

    -Kevin.

     

     


    QP how did you solved the problem with file association for remote APP in SolidWorks ( as example)

    In my situation I installed GIMP on remote APP, and found that is no psd file type association when create MSI.

    I installed make MSI, and ORCA then i iopen in orca gimp.msi, and didn’t find EXTENSION table, cant understand how to add extensions…  

    Tuesday, November 23, 2010 7:58 AM