Why is Network so slow? RRS feed

  • Question

  • When I click on Network (used to be Network Places in XP), it taks 40-45 seconds before it finally shows my other computer in my workgroup. The other is running XP Pro. Going in the other direction, from XP to Win 7, there is no delay.

    What is going on? Is there any way to fix this? It makes network browsing unusable.

    I am not trying to use Homegroup, just a straight Workgroup setup.

    I can access shares on the XP computer directly with no problem, it's just browsing that is so terribly slow.

    Edit: I should have also mentioned my network connection is a Broadcom NetXtreme 57xx Gigabit Controller. There is no indication of a problem in Device Manager.
    • Moved by Novak Wu Thursday, November 5, 2009 3:44 AM (From:Windows 7 Application Compatibility)
    Thursday, November 5, 2009 2:37 AM


All replies

  • Hi,


    Here are some suggestions you can try:


    1. Temporarily turn off firewall on each machine and router (If it has).


    2. Upgrade the NIC driver on Windows 7 machine.


    3. Restart the Windows 7 machine to Safe Mode with Networking to check the result. Does the issue occur in this mode?




    Thursday, November 5, 2009 8:01 AM
  • Thanks Novak.

    1. No effect
    2. Done, no effect
    3. Same in Safe Mode with Networking.

    but ...

    now when I do a normal boot and open Network, both computers show up immediately. Is Windows 7 caching that information somewhere and if so, where?
    Why did running it in Safe Mode with Networking make it perform as it should in normal mode? This is very weird.
    Thursday, November 5, 2009 7:47 PM
  • Actually, Safe Mode with Networking loads the system with the minimum amount of programs and devices. It is only a troubleshooting tool and there is no cache.


    This issue can occur by incompatible third party programs or temporary network issue. Hence, we usually can test the issue in Safe Mode with Networking to eliminate the cause.


    At this stage, I would like to confirm whether everything is working fine now.


    Friday, November 6, 2009 9:31 AM
  • No, the problem still occurs (I did not receive any notice of your update though, which is why I'm only responding now).

    I use Acronis True Image 2009 for backup.
    I also use Mirror Folder.
    Comodo Internet Security.

    What's weird is once I let Network open completely then it opens quickly from then on, which led me to think something was being cached.

    I'll disable everything via msconfig and do a normal boot and see if the problem still occurs. If not then I'll start them one at a time till I find the cause. Will post results here.

    Sunday, November 8, 2009 8:49 PM
  • I have made no changes. I opened Network and let it complete so my other computer was visible and I could browse it. This took 40-45 seconds as I mentioned in my first post.

    I then shutdown and powered off. Left it that way for a few minutes then powered up. Once the boot was complete, I opened Network and the other computer was there, immediately. No delay of any kind.

    I don't even know where to start to try to debug this. Any ideas welcomed.

    Any chance this has something to do with the Broadcom NetXtreme 57xx Gigabit Controller? I think of what but I'm grasping at straws now.

    Sunday, November 8, 2009 9:08 PM
  • No, that makes no sense as it only happens the first time after some event takes place (not sure what that is yet, but having the system powered off overnight seems to trigger it). Other than the first time, it works as expected and I can browse the content of the other computer immediately after opening Network.

    Once I figure out what the trigger is, I'll try Wireshark (Ethereal replacement) and see if I can figure out what it's doing.
    Monday, November 9, 2009 3:31 AM
  • Please refer to the steps from the link below to disable TCP Offload options for a test.

    Disable TCP Offload options

    • Marked as answer by Novak Wu Monday, November 16, 2009 2:13 AM
    Monday, November 9, 2009 9:51 AM
  • Key Words: Windows 7, Broadcom NetXtreme 57xx Gigabit Controller, low LAN Network throughput, Dell D630 Laptop

    Hello there
    My problem seems related to the problem described here.
    Few days ago I've installed Windows 7 on my laptop Dell D630. This laptop has a "Broadcom NetXtreme 57xx Gigabit Controller" as a LAN interface. The OS installation (an upgrade to Home Premium from XP) went smooth. I had a strange feeling that the Internet is crawling so I made few tests comparing the throughput with other computers that I have on my home network. A simple download tests approve that the network throughput from the LAN interface is much slower (I'm talking about factor of 4) then what I'm used to and comparing to other computers on my network.
    I also tried the same tests, but this time I was connected through the Wireless interface and surprisingly the bandwidth went back to the levels I'm used to! I think this is focusing the problem to the compatibility of the "Broadcom NetExtreme 57xx Gigabit Controller" with Widows 7.
    Not to mention that I tried to update/reinstall the device driver - Didn't help.

    I don't know if the solution that Mr. Novak suggested is applicable in my case, any how I don't understand how disabling TCP offload can help?
    The offload is done in HW and by that making a very CPU consuming process redundant in the OS. Disabling this feature will load the CPU that will have to calculate from now on e.g. the checksum for each outgoing packet. How this will increase the network performance? TCP offloading is a must have feature in all gigabit network controllers!

    It will be great if Microsoft  or Dell or Broadcom attend this issue, till then I would be glad to be assisted.

    Thanks, Avi
    Thursday, November 19, 2009 7:27 PM
  • Any more information on this issue? I am having a similar problem with a Dell T3400 with a Broadcom NetXtreme 57xx Gigabit Controller running Windows 7 Enterprise 64.  The network speed is very slow.
    Saturday, January 9, 2010 12:29 AM
  • Thanks for the quick reply.  A few minutes after posting my question, I went ahead and upgraded the BIOS (A09) and changed the NIC speed from 100 Full to Auto.  Problem went away. 
    Saturday, January 9, 2010 4:04 AM
  • 1. From the Run command: ncpa.cpl (or go via Control panel to Network connections)
    2. Right click on 'local area connection' > properties
    3. Click 'configure' to open new dialog box
    4. In 'Advanced' tab: select TCP checksum Offload (IPv6) & select 'Disabled' from drop-down menu.
    Saturday, June 20, 2015 7:18 AM