none
When opening a PDF in IE 10 with Enhanced Protection Mode it displays "This website wants to run acropdf.dll" RRS feed

  • Question

  • I am running my application which requires JRE on Internet Explorer 10. Since the IE need to run in 64 bit mode, we have enabled the "Enhanced Protection Mode" in Security option of Internet Options in Advanced tab. But my application also opens up PDF in the browser, when the page with PDF is invoked it displays "The webpage wants to run 'AcroPDF.dll'. If you trust this site, you can disable Enhanced Protection Mode for this site to run the control.(Disable)(Always Ignore)".  And on clicking any option the PDF is not displayed.

    We would not be able to disable the  Enhanced Protection Mode as the 64 Bit JRE would not be invoked for other part of the application.

    Please let me know how to resolve this issue.

    Regards

    Navin

    Thursday, September 19, 2013 3:04 AM

All replies

  • Hi,

    there is no x64 Adobe PDF viewer (as yet)...

    To avoid the issue in your web documents link to PDF documents using an anchor tag instead of imbedding them with <object> or <iframe> tags

    and/or

    Configure Adobe Reader to not use a Web Browser to open PDF documents... (see the Adobe.com for admx files to apply this setting by group policy) ( http://forums.adobe.com/thread/392489 )

    Start>Adobe Reader>Edit>Preferences>Internet>uncheck "Display PDF in browser"


    Rob^_^

    Thursday, September 19, 2013 4:53 AM
  • ... and/or

    Configure Adobe Reader to not use a Web Browser to open PDF documents... (see the Adobe.com for admx files to apply this setting by group policy) ( http://forums.adobe.com/thread/392489 )

    Start>Adobe Reader>Edit>Preferences>Internet>uncheck "Display PDF in browser"

    It seems that Adobe have recently changed the location of that setting in Adobe Reader (at least on 11.0.4).  They've now hidden it under Edit > Accessibility > Setup Assistant > Then on page 5 of 5, there's a tick box to toggle 'Display PDF documents in the Web Browser'.

    However, it doesn't work like it used to though, as it won't just open a PDF in Adobe Reader instead of the browser.  It will instead ask to disable Enhanced Protected Mode to run acroPDF.dll. 

    And if you try disabling the Adobe PDF reader add-on in Manage Add-ons to try and force it to open in Reader, then when you visit a PDF link, you just get the same blank page (shown below) with the black crossed out circle in the top left, but without the message bar at the bottom of the window.  The only way to open the PDF is to either turn off Enhanced Protected Mode and allow acroPDF.dll to run or if there's an original link to the PDF, right click and select 'save-as'.

    I think it's about time Adobe released an x64 PDF viewer...  Or at least there should be an open/save dialogue box in IE.

    If you've got Reader 11.0.4 installed, you can try it for yourself with this PDF link:
    http://helpx.adobe.com/pdf/adobe_reader_reference.pdf

    (The below screenshot is with 'Display PDF documents in the Web Browser' UN-ticked in Adobe Reader settings, so it should open in Reader instead.  But it doesn't.  And with the Reader add-on disabled you get the same page, but without the message at the bottom.)

    Thursday, September 19, 2013 7:19 PM
  • Merci pour ton message,je vais essayer, ce n' est pas toujours facile pour des débutants, et à 67 ans encore moins. cordialement Genevieve
    Monday, March 3, 2014 7:06 PM
  • Or at least there should be an open/save dialogue box in IE.

    +1.

    Even after disabling the add-on, there is no Open/Save dialog.  Wish someone would figure this out.

    Friday, July 11, 2014 11:36 PM
  • Provide download links for your pdf documents. Don't embed them in iframes, embed or objects.

    or provide download fallbacks in object tags.

    <object data="pdfdoc.pdf" type="application/pdf">

    <embed src="pdfdoc.pdf" type="application/pdf"/>

    <a href="pdfdoc.pdf" target="_blank" class="pdf">download pdfdoc.pdf</a>

    </object>

    Note: for MSIE browsers the type attribute MUST be specified in embed, otherwise TWO requests will be sent (Mime sniffing security zone setting).

    Post questions about html, css and scripting to the IE Web Development forum... Include with your questions a link to your website or mashup that shows your issue and more importantly your COMPLETE page markup.

    Regards.


    Rob^_^

    Saturday, July 12, 2014 1:28 AM
  • Actually, it doesn't matter if the site in question uses an embedded PDF or if they simply create a hyperlink to the PDF file.

    We have IE10 which operated in Enhanced Protected Mode (EPM) for "Internet Zone" sites. Trusted sites have EPM disabled. When you click a link to a PDF or visit a site that has an embedded PDF that is included in the Trusted Sites list, everything functions normally.  HOWEVER, if the site is in the "Internet Zone" and EPM is enabled, then all you get for both an embedded PDF and a hyperlinked PDF is a small box with an 'X' in it.  I tried going into "Manage Add-Ons" and disabling the 32-bit only Adobe PDF add-on, but it still did not allow the "Open/Save" prompt to appear.  I actually had to uninstall Adobe Acrobat completely.  It was only at this point did hyperlinked PDF files provide an "Open/Save" dialog box.

    You'd think, if the add-on was disabled, you'd get the same Open/Save dialog box, but you don't.

    Saturday, July 12, 2014 2:29 AM
  • @Andrew

    Have you disabled the Adobe PDF Link helper addon? (version 8 & 9)

    You may or may not have it installed.

    My adobe pdf properties are

    Name:                   Adobe PDF Reader
    Publisher:              Adobe Systems, Incorporated
    Type:                   ActiveX Control
    Architecture:           32-bit and 64-bit
    Version:                11.0.07.79
    File date:              ‎Thursday, ‎8 ‎May ‎2014, ‏‎6:48 AM
    Date last accessed:     ‎Saturday, ‎5 ‎July ‎2014, ‏‎11:55 AM
    Class ID:               {CA8A9780-280D-11CF-A24D-444553540000}
    Use count:              368
    Block count:            153
    File:                   AcroPDF64.dll
    Folder:                 C:\Program Files (x86)\Common Files\Adobe\Acrobat\ActiveX

    I can't follow the thread if you cannot provide a web link to test.

    Your questions should be posted to the IE Web Development forum, including a link to your website or a mashup for us to test.

    Regards.


    Rob^_^

    Saturday, July 12, 2014 11:22 AM
  • I tried disabling ALL Adobe add-ons.  However, it was not until they were uninstalled that the Open/Save prompt started working when IE was operating in EPM.

    Here is a web link to a PDF:

    Aviation Maintenance Technician Handbook – Airframe - Volume 1 (PDF)
    Saturday, July 12, 2014 3:07 PM