none
WMI Problems RRS feed

  • Question

  • I am trying to use the program for the first time.  When I enter in the information to do a scan, domain, login, etc.  It does the scan fine, but the problem that I am having is that out of the 135 computers that in finds in our domain, only 29 of them successfully connect and provide information.  Most of the computers have a "connection timed out", there's the odd "access denied".  I have setup a group policy to allow remote administration.  Another thing is that there is some computer that were successful that have the windows firewall enabled and some that don't.

    How can I go about being able to connect to all of the computers in our domain?  Any help would be greatly appreciated.

    Curtis
    Wednesday, November 19, 2008 10:02 PM

Answers

  • can you double-check that you connected to the correct namespace?  You should be connecting to root\CIMV2.  On Windows Xp and Windows 2003, the default value that wbemtest gives you is root\default, which won't work for you, you'll need to change it to say root\cimv2

    (0x80041010 is "class not found")

    Thanks,
    Jay
    Tuesday, December 23, 2008 5:14 PM

All replies

  •  The first thing I would check is to make sure you actually have WMI access.   An easy way to do that is to use the WBEMTEST tool that's available in every version of windows since Windows XP.

    The instructions here will help you do a simple test to see if you can connect and retrieve data.  Use the same credentials that you used for MAPS, and run WBEMTEST from the same machine you ran MAPS from.  Make sure that you actually run a WMI query to complete the test, merely connecting doesn't prove that the credentials you use have access to execute queries.

    If you're able to successfully use WBEMTEST against some machines that reported timeout or access denied when inventoried via MAPS, let us know & we'll go to the next step of diagnosis.

    Thanks,
    Jay
    Thursday, November 20, 2008 5:59 PM
  • Jay,

    I tried following the instructions to use the WBEMTEST, but I have no idea what really to do there to see if I can connect and retrieve data.  When I try to put in my credentials, it says that "User credentials cannot be used for local connections" (error # 0x80041064).

    I don't really know what else to try out here.  This is my first time using the MAPS program.  Any other help would be greatly appreciated.

    Curtis
    Thursday, November 20, 2008 7:19 PM
  • Jay,

    I tried the test again not putting in anything for credentials and it gave some query results.  Not sure if this is what you are meaning or if there is something else that I need to do in order to do the WMI query test.

    Curtis
    • Proposed as answer by Kjalen Friday, April 27, 2012 5:53 PM
    Thursday, November 20, 2008 7:40 PM
    • In WBEMTEST, hit "Connect..."
    • In "Namespace", enter \\machinename\root\cimv2, where machinename represents the name of the remote machine you're trying to connect to.
    • In credentials, enter the username you'd like to use in the format domain\username (same username as you used in maps)
    • enter the Password
    • Hit "Connect" button
    • if that succeeds, hit the "Query" button
    • in the query box, enter "select * from win32_Processor" and hit the apply button.
    • If that succeeds, you should see at least one row of data that looks something like: "Win32_Processor.DeviceID="CPU0""

    If you got that far, then WMI is working correctly. If not, report back what errors you received if they're not immediately obvious what the problem is.  If the target machine is running a firewall and the appropriate ports aren't open, the failure from WMI may look as if the target machine is not running ("Connection timed out" or similar message).

    Hope that helps,
    Jay

    • Edited by Jay Sauls Friday, November 21, 2008 5:00 PM edited to correct "cimv2" and remove authority field
    Thursday, November 20, 2008 10:56 PM
  • Jay,

    I followed your instructions, however when I put in the credentials, is gives me the error "Invalid Parameter" when I try to connect.  If I don't put anything in the credentials and try to connect to a computer, I get the error message "The RPC server is unavailable."  This is how I am entering the credentials:

    username: <IE. Admin3>
    password: <password>
    authority: <companies domain name>

    Anything else, I can try?

    Curtis
    Friday, November 21, 2008 4:43 PM
  • sorry, typo on my part.  Namespace should be \\machinename\root\cimv2

    Also, enter the username in the format domain\username and leave the "Authority" field blank.

    Try that & see how it goes.
    Friday, November 21, 2008 4:58 PM
  • I tried that way, and all I get when I try to connect to a machine is "RPC server is not available".
    Friday, November 21, 2008 5:57 PM
  • Have you checked the firewall settings on the remote machine?

    Just so you can see how things are supposed to work with WBEMTEST, try connecting to your local machine first.  Once you've convinced yourself how it's supposed to work, turn back to the remote machine.

    The MAPS getting started guide has instructions on how to configure the firewalls on remote machines.   Take a look at the section titled "Remote Computer Configurations".  The Getting Started Guide is installed with MAPS and available at All Programs --> Microsoft Assessment and Planning Solution Accelerator --> Getting Started Guide

    Thanks,
    Jay
    Friday, November 21, 2008 6:04 PM
  • i setup a group policy yesterday for the domain (as per the instructions in the getting started guide).  however, still getting alot of access denied and timeout errors.  also, i did a wbemtest on my local machine and it works fine.
    Friday, November 21, 2008 6:54 PM
  • I tried again on a remote computer and still getting the error "RPC server is unavailable."
    Friday, November 21, 2008 6:59 PM
  • i manually went to a remote computer that has failed with the RPC error and entered the following command in the command prompt:

    netsh firewall set service remoteadmin enable

    redid a wbemtest on this remote machine and works fine.  now how can I get this to work on all machines without having to manually go to each computer?  the group policy setting didn't seem to work (unless I was setting the policy on the wrong computer)?
    Friday, November 21, 2008 7:15 PM
  • I'm not sure, but here's what I would try:

    Go to a machine that's still not allowing WMI calls.  From that machine, do a gpupdate /force, then reboot and see if that fixes the remote WMI issue.  If not, I would double-check the actual group policy settings that you made on the domain to ensure they're correct, and I would also take a look at the Windows Event log on the machine that's not taking the policy update to see if there are any errors related to applying policy to that machine.

    Hope that helps,
    Jay
    Friday, November 21, 2008 10:41 PM
  • I connected to remote server successfully in WBEMTEST. But when I run the query you mentioned, "select * from win32_Processor",  there is a error occoured. The error is "0x80041010".

    What i need to do?
    wubin
    Saturday, December 13, 2008 5:33 PM
  • can you double-check that you connected to the correct namespace?  You should be connecting to root\CIMV2.  On Windows Xp and Windows 2003, the default value that wbemtest gives you is root\default, which won't work for you, you'll need to change it to say root\cimv2

    (0x80041010 is "class not found")

    Thanks,
    Jay
    Tuesday, December 23, 2008 5:14 PM