locked
VM not reachable after connecting to a different virtual network RRS feed

  • Question

  • Hi there,

    I have a two node Hyper-V cluster (2008 R2) with 5 NIC ports each all connected to the same physical switch (HP Procurve 2510G-48, J9280A). There is one virtual switch per NIC, no teaming. When moving a VM to a different virtual switch or switching over a VM to the other cluster node this VM is not reachable for about 5 minutes.

    I've played with different spanning tree settings for the physical switch without any success. At the moment spanning tree ist completely disabled.

    Any ideas?

    Thanks.

    Te.Be. 

    Friday, January 11, 2013 5:57 PM

Answers

  • Check the Port Security config. Certain settings prevents the same mac change in different port.

     
    Port security: allows access only to specified MAC addresses, which can be learned or specified by the administrator 

    • Marked as answer by Lawrence, Friday, January 18, 2013 6:30 AM
    Friday, January 11, 2013 7:07 PM
  • Ok.

    Try to enable enable Spoofing Of MAC Addresses in virtual network adapter properties.

    If you do not select this option and disallow MAC address spoofing, the following rules are enforced:
    • The virtual switch port that connects the virtual network adapter sends and receives packets that contain any valid MAC address.
    • The virtual network adapter MAC address cannot be moved or associated with another virtual switch port.
    • The virtual switch port does not forward unicast flooded packets (packets that are forwarded to all switch ports if the destination MAC address is not found in the switch forwarding table) to the virtual network adapter.
    •   You cannot override the virtual network adapter MAC address configuration using the NetworkAddress key in the virtual machine registry.

    Regards

    • Marked as answer by Lawrence, Friday, January 18, 2013 6:30 AM
    Friday, January 11, 2013 8:53 PM

All replies

  • Check the Port Security config. Certain settings prevents the same mac change in different port.

     
    Port security: allows access only to specified MAC addresses, which can be learned or specified by the administrator 

    • Marked as answer by Lawrence, Friday, January 18, 2013 6:30 AM
    Friday, January 11, 2013 7:07 PM
  • Thanks, Carlos.

    Forgot to mention there's no port security in place. Physical switch configuration is more or less factory default, spanning tree disabled.

    Ciao.

    Te.Be.

    Friday, January 11, 2013 8:02 PM
  • Ok.

    Try to enable enable Spoofing Of MAC Addresses in virtual network adapter properties.

    If you do not select this option and disallow MAC address spoofing, the following rules are enforced:
    • The virtual switch port that connects the virtual network adapter sends and receives packets that contain any valid MAC address.
    • The virtual network adapter MAC address cannot be moved or associated with another virtual switch port.
    • The virtual switch port does not forward unicast flooded packets (packets that are forwarded to all switch ports if the destination MAC address is not found in the switch forwarding table) to the virtual network adapter.
    •   You cannot override the virtual network adapter MAC address configuration using the NetworkAddress key in the virtual machine registry.

    Regards

    • Marked as answer by Lawrence, Friday, January 18, 2013 6:30 AM
    Friday, January 11, 2013 8:53 PM
  • Hi,

    I would like to confirm what is the current situation? Have you resolved the problem or do you have any further progress?

    If there is anything that we can do for you, please do not hesitate to let us know, and we will be happy to help.


    Lawrence

    TechNet Community Support

    Wednesday, January 16, 2013 8:43 AM
  • Hi,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as 'Answered' as the previous steps should be helpful for many similar scenarios.

    If the issue still persists and you want to return to this question, please reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    In addition, we'd love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems.

    Thanks!


    Lawrence

    TechNet Community Support

    Friday, January 18, 2013 6:30 AM