none
Intranet site lookup searching desktop prior to dns resolution RRS feed

  • Question

  • I have an environment of a thousand and change workstations mostly running Windows 7.  Recently we found that adding an internet explorer shortcut to the desktop with the exact same name as one of our intranet sites it will display a dialog box "What do you want to do with Laborworkx.lnk? From: C:\Users\Public\Desktop  Open, Save, Save as".  The dialog box's title is "Windows Internet Explorer".

    Initially I suspected the issue lay with the option to allow one word intranet sites, but not only is it selected to allow them, but the page works normally with no prompt or dialog box in the event I so much as rename the shortcut.  The only instance in which this occurs is when the shortcut is both on the desktop and has the *EXACT* same name as the site I am attempting to navigate to.  I've been crawling all over the internet in search of a solution but have not found one.

    One word intranet sites is turned on, using the address bar to search is turned off.  I am using IE 10, but customers on IE 9 experience this as well.  (NOT the handful of WinXP boxes we have around) but it is easily reproducible on every single windows 7 box.  Any ideas?

    Monday, February 3, 2014 10:47 AM

Answers

  • It's the "iexplore.exe" "http://intranet.mydomain.org" that you would expect.  

    That might work from the Run... dialog but in a shortcut I would fully qualify the executable.   E.g.  "%ProgramFiles%\Internet Explorer\iexplore.exe"  instead of just what you have.

    So, fix that and then if you still have a problem, try using ProcMon to supplement your symptom description.



    Robert Aldwinckle
    ---

    Wednesday, February 5, 2014 8:16 PM
    Answerer
  • Tools>Internet Options>Content tab, "Autocomplete" settings, uncheck "Use Windows search for better results"

    Close all open IE windows and restart IE for the full changes to take effect.


    Rob^_^

    Friday, February 7, 2014 12:15 AM

All replies

  • Hi,

    Right click on the Desktop icon and select properties from the context menu....

    what type of 'shortcut' is it? lnk or url or website?... Oh I see it is a lnk file....

    what is the command and parameter?

    expected iexplore.exe "http://intranet/Department/homepage.htm"

    or are you pointing to a hta file?


    Rob^_^

    Tuesday, February 4, 2014 12:46 AM
  • Rob,

    It's the "iexplore.exe" "http://intranet.mydomain.org" that you would expect.  This link gets pointed to a virtual IP in my load balancer which then sorts it appropriately.  I know nothing is wrong with the namespace defined in DNS because of the fact the forwarding works flawlessly with no lnk present.  Just can't seem to figure out why the link is searched for first.  Was just able to reproduce this on a Windows 8 machine on my domain as well.  I'm thinking there might be some GPO I have not yet checked that might be causing this behavior.

    Tuesday, February 4, 2014 12:58 AM
  • Worth noting that I renamed a .lnk on my desktop to "testalot" and when I enter that in my URL bar in IE 10 it gives me the exact same dialog box, regardless of if it's actually a functional link.  It must be just searching the desktop for the exact text I entered.
    Tuesday, February 4, 2014 5:27 AM
  • Hi,

    It's the "iexplore.exe" "http://intranet.mydomain.org" that you would expect.

    well almost, but no... (I forgot the quoted iexplore.exe), but the url seems interesting...

    http://intranet.mydomain.org

    expected http://{computername or serverIP address}/intranet.mydomain.org:[port]

    what happens when you ping http://intranet.mydomain.org

    additionally a desktop shortcut (.url) file should work with just the url as the Command parameter. (no need for the iexplore.exe command).

    I would test by deleting the desktop .lnk file, then right-clicking on the desktop and selecting New>Shortcut from the context menu....

    enter

    http://intranet.mydomain.org (I'm pretty sure that http://{computername}/intranetdomain:[port] is the correct syntax though)

    in the command field and complete the process....

    In the Title field, give it a name say Intranet test....

    this should create an Internet Shortcut file (.url) on the desktop desktop...eg. Intranet test.url

    (Open file explorer and navigate to the user's DESKTOP) to view its properties....

    hopefully it will be good to go.....

    Once you successfully open the landing page, select File>Properties from the IE menu and make sure it is mapping to the intranet zone (you should have intranet zones 'autodetect' selected on the IE Security zone settings)...

    here is a screenshot from my desktop... for development purposes I name my websites with a .local domain suffix, rather than a separate host name.

    "Worth noting that I renamed a .lnk on my desktop to "testalot" and when I enter that in my URL bar in IE 10 it gives me the exact same dialog box, regardless of if it's actually a functional link.  It must be just searching the desktop for the exact text I entered."

    for a test go Tool>Internet Options>Content tab, Autocomplete 'Settings' button, turn off autocomplete for the Address bar.(close all open IE instances and restart the browser for the full changes to take effect)... if that works you may have to clear the users typed url's list in the registry or a partial IE Reset..

    I'm not 100% sure on all this... your intranet.mydomain.org url is confusing.


    Rob^_^

    Wednesday, February 5, 2014 5:27 AM
  • .url files work without a problem, pinging the intranet site resolves correctly to the static virtual IP I would expect on our load balancer.  After a bit more research I have found that this is more of a problem with Internet Explorer viewing my desktop as a "Favorites" pool or maybe "bookmarks" is the right word for IE?  When I create a .lnk on my desktop that says ANYTHING and points ANYWHERE if I type that .lnk's name into my browser's address field verbatim it gives me the same open/save dialog box.  Hence the creation of my "testalot.lnk" that goes nowhere experiment.

    At present I am struggling to understand why internet explorer would consider C:\Users\Public\Desktop to be a "favorites" folder and search there for entered text in the URL field.  /boggle

    Wednesday, February 5, 2014 8:57 AM
  • It's the "iexplore.exe" "http://intranet.mydomain.org" that you would expect.  

    That might work from the Run... dialog but in a shortcut I would fully qualify the executable.   E.g.  "%ProgramFiles%\Internet Explorer\iexplore.exe"  instead of just what you have.

    So, fix that and then if you still have a problem, try using ProcMon to supplement your symptom description.



    Robert Aldwinckle
    ---

    Wednesday, February 5, 2014 8:16 PM
    Answerer
  • Tools>Internet Options>Content tab, "Autocomplete" settings, uncheck "Use Windows search for better results"

    Close all open IE windows and restart IE for the full changes to take effect.


    Rob^_^

    Friday, February 7, 2014 12:15 AM