locked
App-V 5 Published Packages not appearing on Publishing Server RRS feed

  • Question

  • Hi There,

    This is probably going to be a really simple overlooked solution but it's causing a lot of headaches.

    I have recently set up a test environment for App-V 5 as follows: (all App V software comes from the Virtual Optimisation Pack 2013 .iso from the MS Volume download site)

    Sequencer - Installed on VMWare Win 7 Pro 64 box with all prerequisites

    Management, Publishing, Reporting Server - Installed together on VMWare Server 2008 R2 SP1 box with SQL 2008 R2 SP2 and all prerequisites including IIS configuration

    Client - Installed on Win 7 Pro 64 (Real Machine) with all prerequisites.

    I have sequenced 2 apps on the Sequencer and set them for use on any machine (ie 7,8 32, 64 etc), transferred them to the Management Server and into a Shared Folder, used the console to 'Publish' the packages and included the 'domain\all users' in the AD listing for access purposes. 

    On the Packages page on the console it says they are published with last modified dates

    On the Servers page it has the AD listing of the server and last publishing attempt listed.

    HOWEVER, when I browse on the server to 'http://servername:publishing server binding' I get the following:

    - <Publishing Protocol="1.0">
      <Packages /> 
      </Publishing>

    When I browse on the server to 'http://servername:management server binding/packages' it shows the packages:

    - <ArrayOfPackageVersion xmlns:i="http://www.w3.org/2001/XMLSchema-instance">
    - <PackageVersion>
    - <Applications>
    - <Application>
      <AppId>[{AppVPackageRoot}]\notepad++.exe</AppId> 
      <Description i:nil="true" /> 
      <Enabled>false</Enabled> 
      <Icon i:nil="true" /> 
      <Id>2</Id> 
      <Name>Notepad++</Name> 
      <Target i:nil="true" /> 
      </Application>
      </Applications>
      <ConnectionGroups /> 
      <Description i:nil="true" /> 
      <Enabled>true</Enabled> 
    - <Entitlements>
    - <Entitlement>
      <GroupName>localdomain\All Users</GroupName> 
      <Id>2</Id> 
      <Sid>S-1-5-21-2455186765-3302476442-3975646137-1143</Sid> 
      </Entitlement>
      </Entitlements>
      <Id>2</Id> 
      <Name>NotePad++_0.1</Name> 
      <PackageGuid>5dab9ddd-d6f2-4146-952e-069d44200ebd</PackageGuid> 
      <PackageUrl>\\appvserver\packages\notepad++\notepad++_0.1.appv</PackageUrl> 
      <TimeChanged>2013-10-16T00:41:11.683</TimeChanged> 
      <Version>0.0.0.1</Version> 
      <VersionGuid>9b495ddb-8ac1-40cf-8951-a166fafdf0ef</VersionGuid> 
      </PackageVersion>
    - <PackageVersion>
    - <Applications>
    - <Application>
      <AppId>[{AppVPackageRoot}]\vlc.exe</AppId> 
      <Description i:nil="true" /> 
      <Enabled>false</Enabled> 
      <Icon i:nil="true" /> 
      <Id>3</Id> 
      <Name>Reset VLC media player preferences and cache files</Name> 
      <Target i:nil="true" /> 
      </Application>
    - <Application>
      <AppId>[{AppVPackageRoot}]\Documentation.url</AppId> 
      <Description i:nil="true" /> 
      <Enabled>false</Enabled> 
      <Icon i:nil="true" /> 
      <Id>4</Id> 
      <Name>Documentation</Name> 
      <Target i:nil="true" /> 
      </Application>
    - <Application>
      <AppId>[{AppVPackageRoot}]\NEWS.txt</AppId> 
      <Description i:nil="true" /> 
      <Enabled>false</Enabled> 
      <Icon i:nil="true" /> 
      <Id>5</Id> 
      <Name>Release Notes</Name> 
      <Target i:nil="true" /> 
      </Application>
    - <Application>
      <AppId>[{AppVPackageRoot}]\VideoLAN Website.url</AppId> 
      <Description i:nil="true" /> 
      <Enabled>false</Enabled> 
      <Icon i:nil="true" /> 
      <Id>6</Id> 
      <Name>VideoLAN Website</Name> 
      <Target i:nil="true" /> 
      </Application>
      </Applications>
      <ConnectionGroups /> 
      <Description i:nil="true" /> 
      <Enabled>true</Enabled> 
    - <Entitlements>
    - <Entitlement>
      <GroupName>localdomain\All Users</GroupName> 
      <Id>3</Id> 
      <Sid>S-1-5-21-2455186765-3302476442-3975646137-1143</Sid> 
      </Entitlement>
    - <Entitlement>
      <GroupName>BUILTIN\Administrators</GroupName> 
      <Id>4</Id> 
      <Sid>S-1-5-32-544</Sid> 
      </Entitlement>
      </Entitlements>
      <Id>3</Id> 
      <Name>VLC Media Player</Name> 
      <PackageGuid>fa0fd6a2-76e6-41b7-8f19-5d18d2ab5fca</PackageGuid> 
      <PackageUrl>\\appvserver\packages\VLC Media Player\VLC Media Player.appv</PackageUrl> 
      <TimeChanged>2013-10-16T00:41:13.403</TimeChanged> 
      <Version>0.0.0.1</Version> 
      <VersionGuid>22861066-5e81-4aed-9855-bb4092e3bdc3</VersionGuid> 
      </PackageVersion>
      </ArrayOfPackageVersion>

    This is the same as when I browse to the pages on the client station as well.

    I have used Powershell on the client to attach the publishing server and sync-ed it (both through Powershell and through the Silverlight UI) though it is showing 'Virtual Apps 0'.

    The packages were uploaded yesterday and are still not showing so I doubt it is to do with the publishing server Sync.

    We have also tried restarting the app-pool in IIS (plus the service), and restarting the publishing site. 

    We have uninstalled/installed the publishing server to make sure that it is pointed correctly to the management server, removed the server and readded it in the console and removed the published apps and republished them.

    Any help would be greatly appreciated!

    Wednesday, October 16, 2013 3:53 AM

Answers

  • Hi Falko,

    Thanks for your advice again. I actually managed to get it working properly. I found and followed the App-V 5.0 Trial Guide paper by Microsoft on TechNet. It turns out I hadn't set the sharing permissions up correctly on the package folder (both for the AD distribution groups and I didn't select the server itself). All the Apps are now streaming correctly. Now to build another test server and see how it performs in a terminal services environment.

    Kind Regards

    Joseph

    • Proposed as answer by znack Tuesday, October 22, 2013 6:53 AM
    • Marked as answer by David WoltersModerator Tuesday, October 22, 2013 1:41 PM
    Tuesday, October 22, 2013 3:43 AM

All replies

  • Hello,

    Have you tried assigning the packages to a different group, which you are a member of?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, October 16, 2013 6:40 AM
  • Is there anything in the server's App-V event logs? Not sure if 'all users' would be appropriate, can you use 'domain\domain users' instead?

    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Wednesday, October 16, 2013 12:34 PM
    Moderator
  • Hi There,

    Thanks for your suggestions Nicke and Falko. I have changed the AD group to an internal one though the apps are still not appearing on the publishing server website.

    Falko in regards to the Event Logs, on the 'Server-Publishing' log there are 2 errors cropping up

    ID 214 - Server-Publishing - The request URL doesn't contain the query string for the client version

    ID 215 - Server-Publishing - The request URL doesn't contain the query string for the client OS

    The 'Server-Management' just has information saying 'package version (serial) is successfully updated' which co-insides with the time the apps have been set to 'published'.

    By the way, I should point out we are operating in a SBS DC environment if that has anything to do with it

    Kind Regards

    Joseph

    Monday, October 21, 2013 4:40 AM
  • Your post indicates that - during Sequencing - you selected 'all' OS Versions. COuld you try to create one package that does hav _no_ OS pre-selected (i.e. has the option to 'allow executing this app on every OS' or so enabled) or change that for one package (in the Sequencer's [Deplyoment] tab)?


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Monday, October 21, 2013 11:05 AM
    Moderator
  • Hi Falko,

    Thanks for your advice again. I actually managed to get it working properly. I found and followed the App-V 5.0 Trial Guide paper by Microsoft on TechNet. It turns out I hadn't set the sharing permissions up correctly on the package folder (both for the AD distribution groups and I didn't select the server itself). All the Apps are now streaming correctly. Now to build another test server and see how it performs in a terminal services environment.

    Kind Regards

    Joseph

    • Proposed as answer by znack Tuesday, October 22, 2013 6:53 AM
    • Marked as answer by David WoltersModerator Tuesday, October 22, 2013 1:41 PM
    Tuesday, October 22, 2013 3:43 AM
  • I have installed App-V 5.1  server 2012R2 (management, publishing, streaming) the DBs are on a different machine (2008R2 sql)

    and the problem I facing is exactly as you describe where the web console show the Apps as published, but the xml on the iis publish port show with no packages.

    I was trying to find the missing permission that you mentioned, but I couldn't find anything in HERE.

    finally I gave AD\Domain users Share and NTFS permission, and also to the server itself (the files sits o the App-v server itself so it was pointless but I did it anyway)

    bottom line I would love for some help

    thanks

    Monday, August 22, 2016 7:54 AM