none
Group Policy Preferences - Services - Log on as - Configure Network Service?

    Question

  • This does not seem to be possible, or am missing something? I've tried

    NT AUTHORITY\NETWORK SERVICE

    and

    NETWORK SERVICE

    with location set to KDAVIS (machine).

    "An object (User) with the following account name cannot be found: NETWORK SERVICE"

    Right now, we are setting this service account manually, but I sure would prefer to do it via GP.

    Tuesday, May 31, 2016 5:36 PM

All replies

  • Hi Laurin,

    In my opinion, you need check the box Built-in security principals after click Object Types.

    If you do not check the type, you will see the error message:

    An object (User) with the following account name cannot be found: NETWORK SERVICE

    Here is a similar thread below for your reference.

    https://social.technet.microsoft.com/Forums/en-US/39b8da31-fc09-4663-b8ef-76acd192bd78/where-is-nt-authoritynetwork-service

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 01, 2016 2:44 AM
    Moderator
  • Well, yesterday, when I posted this Built-in security principals was not available under Object Types, but today it is - Users was the only option. Today, I have that option.
    Wednesday, June 01, 2016 4:55 PM
  • That is not correct. Built-in security principals is only available if I select the domain as the location, but Network Service is a machine account, not a domain account.
    Wednesday, June 01, 2016 4:56 PM
  • Weird, I tried just using Network Service under the domain yesterday and that failed, but today I tried it and it worked.
    Wednesday, June 01, 2016 4:58 PM
  • Actually, it looks like I could have just entered this directly all the time:

    NT AUTHORITY\Network Service

    I guess I should have just tried it first.

    Wednesday, June 01, 2016 4:59 PM
  • Hi Laurin,

    You mean you could type NT AUTHORITY\Network Service manually?

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 02, 2016 2:28 AM
    Moderator
  • I don't know if it would have worked, but I did not try it. I only tried using that in the lookup dialog box.
    Thursday, June 02, 2016 12:46 PM
  • Hi Laurin,

    If it works when you try it with lookup dialog?

    If yes, please mark it as answer as it would be helpful to anyone who encounters the similar problem.

    Thank you.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, June 03, 2016 2:48 AM
    Moderator
  • It does, but one thing that is not noted in the answer and is confusing is to NOT select the local machine, but to select the domain. That does not make sense because this is not a domain account, but a machine account. 

    The solution IS to check Built-in security principals, but that only works if you select the domain, not the machine as the location (again, that does not make sense). 

    How do I mark that, but also indicate this specific point?

    Friday, June 03, 2016 4:22 AM