locked
Issue with auto archving using Outlook 2010 RRS feed

  • Question

  • I have a user that wants the email in his "deleted items" folder that is older than 6 months to be archived.  He uses his Deleted Items folder to store his older emails.  I know this is crazy but he is one of the company owners so I have to do along with him.

    Anyway - I have set this up many times before for him but last year I swapped him Windows XP computer for a Windows 7 system.  He was using Outlook 2010 before and is still using Outlook 2010.  I go in and setup auto archiving to run only on his Deleted Items folder and to archived (move) emails older than 6 months old to an archive file I have specified on his computer.  It ran fine on the old Win XP computer but for some reason is not working right on the new Win 7 system.  I can tell it is running because it creates an "Archive.pst" file but it doesn't actually put any emails in the archive file.  The size never grows.  It stays 265KB which lets me know it is an empty pst file.  Where can I look to help me troubleshoot why this is not working correctly?  I have set it up at least twice thinking I had done something incorrectly the last time.  Then when it runs 14 days later it just creates the empty pst file again and never adds any old emails to it.  Yes, there are many many emails in his Delete Items folder that are older than 6 months old.  Someone please help me with this one.  thanks already

    Monday, February 6, 2017 4:08 PM

Answers

  • Hello,

    How did you set AutoArchive on the Deleted Items folder? Did you do it via right clicking the Deleted Items folder, selecting Properties > AutoArchive tab?

    What type of email account is the user using? If the user is using an Exchange or IMAP account, please make sure he has cached all items in his Deleted Items folder to local Outlook data file. Otherwise, Outlook won't archive these old items even though they are older than 6 months.

    If above doesn't apply, please also try archiving via manually archive to see the result. To do this, click File-> Cleanup Tools-> Archive.

    In addition, archiving works based on the modified date of an item by default. When migrating to a Windows 7 system, did you import the old items from the old computer to the new one? If this is the case, it could change the modified date of the deleted items which could then caused autoarchive to not work. Some antivirus software, especially mail scanner, could also cause the modified date to change. To workaround this issue, we may try to set the following registry key to force Outlook use archive based on the sent/received date:

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences
    REGDWORD: ArchiveIgnoreLastModifiedTime
    Value: 1

    Hope this helps.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Poly Admin Thursday, February 9, 2017 8:25 PM
    Tuesday, February 7, 2017 3:10 AM

All replies

  • Hello,

    How did you set AutoArchive on the Deleted Items folder? Did you do it via right clicking the Deleted Items folder, selecting Properties > AutoArchive tab?

    What type of email account is the user using? If the user is using an Exchange or IMAP account, please make sure he has cached all items in his Deleted Items folder to local Outlook data file. Otherwise, Outlook won't archive these old items even though they are older than 6 months.

    If above doesn't apply, please also try archiving via manually archive to see the result. To do this, click File-> Cleanup Tools-> Archive.

    In addition, archiving works based on the modified date of an item by default. When migrating to a Windows 7 system, did you import the old items from the old computer to the new one? If this is the case, it could change the modified date of the deleted items which could then caused autoarchive to not work. Some antivirus software, especially mail scanner, could also cause the modified date to change. To workaround this issue, we may try to set the following registry key to force Outlook use archive based on the sent/received date:

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences
    REGDWORD: ArchiveIgnoreLastModifiedTime
    Value: 1

    Hope this helps.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Poly Admin Thursday, February 9, 2017 8:25 PM
    Tuesday, February 7, 2017 3:10 AM
  • Yes, I set the AutoArchive on the Deleted Items folder by right clicking, Properties, AutoArchive, etc

    The mail account is an Exchange account.  The account is cached.

    I will try the manual archive using File - Cleanup Tools - Archive and see if that works.

    When I swapped out his computer system I just configured Outlook and it downloaded his mailbox to the new system and cached it.  I agree the issue could be the modified date somehow got changed in the transition.  I will make the registry change as well so this is not an issue.

    I will re-post with the results of what I find based on your recommendations above.  thank u

    • Edited by Poly Admin Tuesday, February 7, 2017 2:29 PM
    Tuesday, February 7, 2017 2:29 PM
  • Thank you for the update. Please let me know the result at your most convenient time.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, February 8, 2017 2:16 AM
  • Well I guess it had something to do with the modified date because as soon as I created the registry entry it started working.  I will mark your post as answer.  thank you
    Thursday, February 9, 2017 8:25 PM
  • Great! Thank you for letting us know that!

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, February 10, 2017 1:33 AM