locked
Disable UAC RRS feed

  • Question

  • Is there a workaround for this? Everything is being moved from the control panel to the new settings and I can't access it. 

    Turning UAC back on is not a solution. 

    Friday, May 8, 2015 6:37 AM

All replies

  • This is unacceptable. 

    Friday, May 8, 2015 6:38 AM
  • Read my posts on UAC. I explain why it is an ineffective security model.

    Unfortunately to fix it windows would have to be redesigned from scratch. Which will never happen with MS too lazy.

    MS idea of security is to just add prompts and warnings messages. They think if they bombared the user with enough confirmation prompts it will solve security issues.

    A great example of the broken security is how they prevent writing to program files directory but leave appdata completely open to writes. Most malware then just copies to the appdata folder. This has forced me to implement software restrictions in group policy for my work network and have exceptions for software that runs from there.

    dropbox and firefox will both bypass administrator restrictions and install to appdata if in a limited user account, which kind of defeats the entire security model in my opinion.

    As for the modern apps, no use to me, i prefer the 20 year old quality applications anyway.

    To make it worse, when you do have domain administrator rights you still get prompted about installing applications and running .exe files. Which creates problems when trying to roll out software silently.
    • Edited by Johnmclain Friday, May 8, 2015 9:43 AM
    Friday, May 8, 2015 8:57 AM
  • Hello,

    Is this system is a part of domain? Make sure you haven't lost administrator rights. If you have lost them, refer this fix:

    http://www.thewindowsclub.com/lost-administrative-rights-in-windows

    Let us know if this helps, Good luck :)

    Windows Troubleshooting & How to guides - http://www.kapilarya.com




    Friday, May 8, 2015 11:13 AM
  • No domain. This is a personal computer. I have admin rights. The issue is the modern app stuff is disabled when UAC is disabled. 
    Friday, May 8, 2015 2:53 PM
  • I completely agree with you. Problem is they are moving everything to the modern apps. Applets are being removed from control panel and new features are going solely in the new settings area. With Windows 8 i could disable UAC and just ignore metro. With Windows 10 that wont be possible. 

    For me, I am a poweruser, I find UAC useless and annoying. I gave Win 10's UAC a chance but then a couple days ago I was prevented from saving a picture on my HDD, not a prompt but a message saying I could not and asked me to save in pictures instead. I am in the administrator of my computer I do not need windows telling me I can't save something where I want and dictating me to save it elsewhere. Maybe average users like this feature but I, as a poweruser, hate it. 

    I am the sysadmin at work. I have proper domain and permissions set up there. At home I shouldn't need to worry about that as its a single user computer on a isolated network. 

    • Edited by Tkaya Friday, May 8, 2015 3:18 PM
    Friday, May 8, 2015 2:56 PM
  • Hi,

    What's version of Windows 10 on your computer?

    The UAC small applet is still in the Control Panel. What setting did you want?

    And it's not recommended that disable the UAC. There is no way to run the "Windows Store Apps" when UAC is disabled.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Monday, May 11, 2015 6:44 AM
    Moderator
  • Hi,

    What's version of Windows 10 on your computer?

    The UAC small applet is still in the Control Panel. What setting did you want?

    And it's not recommended that disable the UAC. There is no way to run the "Windows Store Apps" when UAC is disabled.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    I am running Build 10061.

    In the control panel app, if i turn UAC slider all the way down it still blocks me from doing basic tasks. I was unable to save a picture on my data drive; instead it asked me to save to pictures instead. That was the last straw, I DO NOT want microsoft controlling where I can or can not save stuff. I am a power user I have zero need for something like UAC. It is just annoying and unnecessary. 

    Thursday, May 14, 2015 5:28 AM
  • Hi,

    Enable the Group Policy: User Account Control: Admin Approval Mode for the Built-in Administrator account.

    1. Open Run, type secpol.msc, Press Enter.

    2. Expand the following items by sequence: Local Policies\Security Options

    3. Find the policy and switch its status to Enabled.

    4. Logoff built-in Administrator account and login again.

    In addition, I suggest you update to latest build 10074. It resolve some known issue in build 10061 and improve some more features. More information, please read this blog:

    New Windows 10 Insider Preview Build 10074 now available

    https://blogs.windows.com/bloggingwindows/2015/04/29/new-windows-10-insider-preview-build-10074-now-available/

    If you sign in with administrator account, it won't prevent you from copying files.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    • Proposed as answer by siwonshi Tuesday, May 19, 2015 11:02 AM
    • Edited by Karen HuModerator Friday, May 22, 2015 9:22 AM update
    • Marked as answer by Zen the OcelotModerator Monday, May 25, 2015 9:45 AM
    • Unmarked as answer by Tkaya Saturday, July 18, 2015 4:55 PM
    • Unproposed as answer by Tkaya Saturday, July 18, 2015 4:55 PM
    Friday, May 15, 2015 8:51 AM
    Moderator
  • Hi,

    Enable the Group Policy: User Account Control: Admin Approval Mode for the Built-in Administrator account.

    1. Open Run, type secpol.msc, Press Enter.

    2. Expand the following items by sequence: Local Policies\Security Options

    3. Find the policy and switch its status to Enabled.

    4. Logoff built-in Administrator account and login again.

    In addition, I suggest you update to latest build 10074. It resolve some known issue in build 10061 and improve some more features. More information, please read this blog:

    New Windows 10 Insider Preview Build 10074 now available

    https://blogs.windows.com/bloggingwindows/2015/04/29/new-windows-10-insider-preview-build-10074-now-available/

    If you sign in with administrator account, it won't prevent you from copying files.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    This would do the exact opposite of what I want.

    "Enabled. The built-in Administrator account uses Admin Approval Mode. By default, any operation that requires elevation of privilege will prompt the user to approve the operation."

    No, I don't want any prompts. I want full access to my system at all times. I want everything run with highest admin rights. Disabling UAC accomplishes this task. However disabling UAC cripples Win 10. I can't even access windows update, windows explorer from start menu, any metro app, any new settings, the lock screen, etc.

    Provide a method for power users to run with full admin privileges all the time without interruption.


    • Edited by Tkaya Saturday, July 18, 2015 4:57 PM
    Saturday, July 18, 2015 4:57 PM