none
Connection to hosted CRM RRS feed

  • Question

  • I am trying to connect to a hosted CRM instance. I think it is described as an IFD, as it is not on-prem but neither is it CRM Online.

    I am using the OData connection under From Other Sources. I am using the URL from the Organization Data Services entry under Settings>Customization>Developer resources in CRM. However, when I try to connect I get this error message

    DataFormat.Error: OData: The given URL neither points to an OData service or a feed:

    What am I doing wrong?


    Propdev

    Monday, March 16, 2015 3:31 PM

Answers

  • It looks like the cause of this is the fact that I am working remotely and I am not actually on the network.

    Propdev

    • Marked as answer by Fiddler69 Monday, March 23, 2015 9:02 AM
    Monday, March 23, 2015 9:02 AM

All replies

  • This generally suggests that authentication is failing and we're being redirected to an HTML-based error page. What form of authentication does the instance use?
    Monday, March 16, 2015 3:44 PM
  • I am told it is claims based authentication.

    I think user id may be the issue. I am logged onto my laptop outside the network, and that user id is not provisioned for access to CRM. So I guess I need to imitate my CRM user in some way, but the OData connector doesn't ask for a user id. So I guess I need to log on to the network and run a local copy of Excel.


    Propdev

    Monday, March 16, 2015 4:01 PM
  • The only OAuth provider we support for OData is Azure Active Directory, so if it's any other OAuth-based approach it likely won't work.
    Monday, March 16, 2015 4:14 PM
  • It looks like the cause of this is the fact that I am working remotely and I am not actually on the network.

    Propdev

    • Marked as answer by Fiddler69 Monday, March 23, 2015 9:02 AM
    Monday, March 23, 2015 9:02 AM