locked
you are not authorised to access this resource RRS feed

  • Question

  • Hi

    when i try to launch a virtual application i created i get "you are not authorised to access this resource", i have created an unlimited license under "application licenses" in the appv server console and then selected the unlimited linces in the properties of the virtual app but i still get the error when i try to launch ANY application, if i loook in the server log file it says

    [2009-06-11 11:50:41.586] TS-APPV-01 3928 3812 SW_LicenseConduitSQLServer::ObtainNewLicense 993855719 "Default Provider" stud1 FireFox/FireFox.sft 2 41474 "Access Denied.  License not available.

    even though the app has an unlimited license associated with it ?

    anyone got any ideas ?

    Cheers in advance
    Thursday, June 11, 2009 11:06 AM

Answers

  • right i have fixed it, i re-ran the server installation of appv and told it to do a repair of the installation, i then rebooted the server and all the default provider and any licenses you associate to applications now get applied properly

    many thanks for your efforts /Znack
    • Marked as answer by Garethhwilson Thursday, June 11, 2009 2:51 PM
    Thursday, June 11, 2009 2:51 PM

All replies

  • Hello,

    Please review this KB-article;
    http://support.microsoft.com/kb/930617

    /Znack
    Thursday, June 11, 2009 11:16 AM
  • Hi m8

    i have been through that KB article and everything is set ok, i am in both the groups for the application license and the default provider policy
    Thursday, June 11, 2009 11:20 AM
  • Hello,

    Can you please explain on which apps are configured for which group and license.
    Which provider-policy is used and how its configured
    Which license group is configured and how.

    /Znack
    Thursday, June 11, 2009 11:23 AM
  • what i have just noticed is that if i open the osd file on the server it has the following line

    <CODEBASE HREF="RTSP://ts-appv-01.systest.swan.ac.uk:554/FireFox/FireFox.sft" GUID="61F5A7AA-19B4-4055-AC64-2E183444F38B" PARAMETERS="" FILENAME="firefox3.5\firefox\firefox.exe" SYSGUARDFILE="firefox3.5\osguard.cp" SIZE="24811794"/>

    but it doesnt have any ?customer=PolicyProviderName, i am using the default policy provider so surely i dont have to add that to all my osd files ? i thought you only had to do that if you use a second policy provider ??

    can anyone clarify this ?
    Thursday, June 11, 2009 11:26 AM
  • Hello,

    Well, this depends on setup of course - but yes it could be applicable that you would have to add that to all your OSD-files.
    (again - depends on what you want todo and how you want todo it...)

    /Znack
    Thursday, June 11, 2009 11:27 AM
  • on all my apps i have set the license to the "unlimited license" that i created under the "application licneses" section (this is set not to expire), i have then configured the "default provider" under the "provider pipeline" tab all boxes are ticked and these are :

    Authentication (set to windows authentication)
    enforce access permission settings
    log usage information
    licensing (enforce license policies is selected)

    i then restarted the services as promtped. but the apps dont load on the workstations i get

    The Application Virtualisation Cliernt could not launch {application name}.
    You are not authorized to access this resource.
    Error code: 4513CDC-1690150A-20000193
    Thursday, June 11, 2009 11:32 AM
  • Hello,

    Which active directory security groups are used for all these settings?

    /Znack
    Thursday, June 11, 2009 11:36 AM
  • i have 2 groups in

    a) the application - access permissions tab
    b) Default Provider - Group assignment tab

    these 2 groups are called APPV-Users & APPV-Admins and they contain my users and admins, respectively

    Cheers
    Thursday, June 11, 2009 11:40 AM
  • Hello,

    If the users are not part of the group assigned to the default provider policy they can not access the applications.

    The admin-group should only be assigned for administrating the server.

    This is as described in the previously posted KB-article.

    /Znack
    Thursday, June 11, 2009 11:43 AM
  • i have double checked and triple checked and they are definately in that group, i have just also domain users to the default provider policy and i still cant launch the application :(

    if i change the default provider to audit mode then i can launch the app but not if the enforce licneses option is selected :(
    Thursday, June 11, 2009 11:57 AM
  • Hello,

    If you uncheck the Enable checkmark for the License, does it work then?

    /Znack
    Thursday, June 11, 2009 12:11 PM
  • no it still fails :(
    Thursday, June 11, 2009 12:16 PM
  • Hello,

    Then its not that license that restricts the users. Do you have anything else configured that might be relevant?

    /Znack
    Thursday, June 11, 2009 12:19 PM
  • not as far as i can see its a very basic install at the meoment as we are still just testing things ibelow is a screenshot of the default provider/provider pipeline tab and the advanced button i havent changed anything here but was wondering if i neded to ?

    http://www.systems.swan.ac.uk/appv1.png
    Thursday, June 11, 2009 12:36 PM
  • How is your license and your application configured (firefox in question).

    Or try it in a different manner...
    1. Create a new provider policy and set the settings as per-specified above.
    2. Uncheck the enforce licenses in the default provider policy
    3. Configure the applications you wish to license to use the alternate provider policy.
    4. Configure your type of license for the applications specified.

    Verify the following;
    how the application using the default provider policy acts
    How the applications using the alternate provider policy acts


    /Znack
    • Proposed as answer by znack Thursday, June 11, 2009 1:22 PM
    Thursday, June 11, 2009 12:42 PM
  • 1. ok i created a new policy provider called "test"
    2. i disabled the enforce licenses tick box on the default policy provider and then restarted the appv server services as prompted
    3. i then edited the osd file of the firefox app and told it to use ?Customer=test in the XML
    4. I created 2 licenses one was unlimited and the othr was concurrant, i gave firefox the unlimited licenses license in the application properties and i gave another application (notepad++) the restricted license (the notepad++ app also had the osd file changed to point to the new "test" provider)
    5. firefox now launches fine as does the notepad++ application but the notepad++ application has a concurrent license set to 1 but i can launch it multiple times on different pc's

    another thing i just noticed was in the server eventlog i was getting a few of these

    [2009-06-11 14:00:42.573] TS-APPV-01 3356 2300 SW_ProtocolServer::HostToServerRecord - - - - 2 41495 "Server record not found in data source for following: TS-APPV-01

    so i looked at http://support.microsoft.com/kb/931165 but all my settings are fine so i was wondering if this problems was effecting the licensing side of things

    thanks for your help omn this so far by the way m8e :)
    Thursday, June 11, 2009 1:18 PM
  • Hello,

    When you say that you launch it multiple times, is that with the same user account?

    /Znack
    Thursday, June 11, 2009 1:22 PM
  • yes same user different pc's, am just checking what happens when i try different users
    Thursday, June 11, 2009 1:58 PM
  • ok it doesnt let me lauch the app at all again now as anyone on any pc :S
    Thursday, June 11, 2009 2:31 PM
  • right i have fixed it, i re-ran the server installation of appv and told it to do a repair of the installation, i then rebooted the server and all the default provider and any licenses you associate to applications now get applied properly

    many thanks for your efforts /Znack
    • Marked as answer by Garethhwilson Thursday, June 11, 2009 2:51 PM
    Thursday, June 11, 2009 2:51 PM
  • I had this exact problem today and this was the only result found in a google search on the issue.

    I tried a repair install as detailed above, but no luck.

    Everything would work great if licensing was not enforced, but turning on license enforcement resulted in errors.

    In the server logs I was seeing "Server record not found in data source for following: [SERVERNAME]" where [SERVERNAME] was the NetBIOS name of my App-V Management server, however under Default Server Group I was using the FQDN of the server.

    My issue was resolved by changing the App-V server name under Default Server Group from its FQDN to simply the NetBIOS name ([SERVERNAME]) rather than [SERVERNAME.fully.qualified.domain]

    Restarted the service and now it's working great.

    Note that after getting this working, you have to assign your apps to a license group or they will generate the same error.  (i.e. don't leave them set to 'none' under Application License Group - at the very least create an 'Unlimited License' and assign them to that.)

    • Proposed as answer by xxzzNobody Wednesday, September 22, 2010 9:22 PM
    Wednesday, September 22, 2010 9:16 PM