locked
App-V 5.0 x86 Client not displaying Virtual Apps RRS feed

  • Question

  • I have setup an App-V 5.0 server and sequenced a few apps.  Everything works great with the x64 client.  The x86 client, however, never seems to see the Virtual Apps.  I re-sequenced the app, specifying every version and architecture, but that didn't help.  No errors are logged in event viewer.  It looks like it refreshes normally with a 0x0 return code.  I'm sure it's something simple, but I can't find it for the life of me.

    Please help!

    Wednesday, November 21, 2012 4:32 PM

Answers

All replies

  • Hello,

    How did you publish the package? What does the output of get-appvclientconfig look like? Have you followed these steps for troubleshooting;

    http://support.microsoft.com/kb/2778168

    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, November 21, 2012 5:59 PM
  • Yes, the package is published and everything works as expected with the x64 client.  I followed that KB article, and everything seems normal.  The output of get-appvclientconfig looks normal:

    Thanks for your help.

    Wednesday, November 21, 2012 6:10 PM
  • During sequencing did you include x86 as an OS? Or just x64? If just x64 it will not be available to your x86...

    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Wednesday, November 21, 2012 6:48 PM
  • At first, I didn't change it, thinking all platforms were selected by default.  Then to make sure, I re-sequenced the app and explicitly selected all platforms, but that didn't help.

    I just checked a package, and it shows "Any Operating System" is selected.

    • Edited by MrHanMan Wednesday, November 21, 2012 6:56 PM
    Wednesday, November 21, 2012 6:52 PM
  • If you look at the logs and the event viewer do you see anything out of place. Like that application being ignored?

    If you browse to the publishing server URL via IE. Does it bring up your applications XML contents?


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Wednesday, November 21, 2012 8:13 PM
  • All I see in the event viewer is the sync starting, and then finishing without error.  If I browse to the URL of the publishing server, I see all the apps I have published.  Other than in the event viewer, what logs are there?
    Wednesday, November 21, 2012 8:19 PM
  • In Event Viewer if you go to View-->Analytic and Debug Logs that should expand out all of the event viewer logs.

    other than that my only suggestion, which I'm sure you've already tried is to remove the publishing server via Powershell and then add it in again. Then try a reboot and try to refresh the client via Powershell again. You can see the publishing server so I'd bet it's ok. I did have an issue with the beta version setup. Somehow 2 reboots fixed my problems.


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Wednesday, November 21, 2012 8:35 PM
  • I've rebooted and re-added the publishing server details I don't know how many times.  The additional logs revealed by that option were all completely empty.  I've tried more than one PC, and the x86 client does nothing where the x64 works great.  I've checked and re-checked prerequisites and configurations.  I've re-sequenced multiple apps.  I'm at a loss as to how to proceed.
    • Edited by MrHanMan Wednesday, November 21, 2012 8:47 PM
    Wednesday, November 21, 2012 8:41 PM
  • Hello,

    When you perform Step 5 from the article I posted above;
    Do you see your package listed in the the response?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, November 22, 2012 10:58 AM
  • Yes, all the expected packages appear when I browse to the publishing server.
    Thursday, November 22, 2012 1:32 PM
  • Hello,

    Would you mind posting the results here?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, November 22, 2012 2:30 PM
  • Sure

    Thursday, November 22, 2012 3:54 PM
  • Hello,

    What events are generated in the App-V Event-log (admin) when performing a sync?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, November 22, 2012 7:36 PM
  • The admin event log is empty, as is the application event log.  The operational event log has two repeating entries - a sync started followed by a sync completed.
    Thursday, November 22, 2012 9:29 PM
  • Hello,

    I am assuming that when performing a publish refresh - the App-V Management Server has decided there aren't any packages to be delivered. I suggest you verify if that could be the case.

    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, November 26, 2012 1:20 PM
  • The only error I see on the publishing server is an occasional failure to refresh publishing metadata.  By occasional, I mean once a day or less.

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-AppV-Server-Publishing-Private" Guid="{213b8d98-9a5e-4453-a2ab-a9b68a3c3eea}" /> 
      <EventID>103</EventID> 
      <Version>0</Version> 
      <Level>2</Level> 
      <Task>0</Task> 
      <Opcode>0</Opcode> 
      <Keywords>0x8000000000000001</Keywords> 
      <TimeCreated SystemTime="2012-11-25T14:57:32.440952000Z" /> 
      <EventRecordID>3</EventRecordID> 
      <Correlation /> 
      <Execution ProcessID="2864" ThreadID="1852" ProcessorID="0" KernelTime="1" UserTime="2" /> 
      <Channel>Microsoft-AppV-Server-Publishing-Private/Debug</Channel> 
      <Computer>APPVSRV.contoso.com</Computer> 
      <Security UserID="S-1-5-82-2328726408-2934389453-588761924-931894053-1211897402" /> 
      </System>
    - <EventData>
      <Data Name="str0">DownloadMetadataError (URL: http://localhost:8080/Publishing/Metadata/)</Data> 
      <Data Name="str1">An exception occurred during a WebClient request.</Data> 
      <Data Name="str2">at Microsoft.AppV.Server.Publishing.HttpPublishingMetadataSource.DownloadToLocalFile(WebClientExtended webClient, String url, Int32 timeout, String sequenceNumber, String localFile) at Microsoft.AppV.Server.Publishing.HttpPublishingMetadataSource.GetPublishingMetadata(String url, Int32 timeout, String sequenceNumber, String localFile) at Microsoft.AppV.Server.Publishing.DataManager.RefreshPublishingMetadata() at Microsoft.AppV.Server.Publishing.DataManager.DoRefreshOnTimeEvent()</Data> 
      </EventData>
      </Event>

    Monday, November 26, 2012 2:15 PM
  • Hello,

    I suggest you verify that the server is setup properly;

    http://blogs.technet.com/b/appv/archive/2012/05/08/walking-through-the-app-v-5-0-beta-server-setup-part-1.aspx

    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, November 26, 2012 2:17 PM
  • I checked everything again, rebooted and still no luck.  I checked the prerequisites on the server and clients as well.  I really can't understand why x64 works fine, but not x86.  What could the difference possibly be?
    Monday, November 26, 2012 3:30 PM
  • Hello,

    Since you haven't really explained what each "prerequisites" is or exactly what you have checked, I can't really suggest anything specific.

    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, November 26, 2012 4:53 PM
  • I checked these prerequisites on the clients, mentioned on your blog for App-V deployment with SCCM:

    Windows Management Framework 3.0
    Visual C++ 2005 SP1 ATL Security Update
    Visual C++ 2005 SP1 MFC Security Update
    Visual C++ 2008 SP1
    Visual C++ 2008 SP1 ATL Security Update
    Visual C++ 2008 SP1 MFC Security Update
    Visual C++ 2010 SP1
    Visual C++ 2012
    .NET Framework 4.5
    Microsoft Security Advisor: Insecure library loading could allow remote execution

    I checked all the prerequisites on the server that were mentioned in the article you linked.

    Monday, November 26, 2012 5:16 PM
  • Hello,

    Cool - I suggest you keep verifying against the rest of the steps the article outlined. Quite a few left


    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, November 26, 2012 9:12 PM
  • I followed through the entire article, checking and rechecking every step.  The only thing I found that was not correct in my setup is I had not disabled anonymous access in IIS.  Correcting this oversight and restarting has not changed anything.  64-bit works great; 32-bit doesn't work at all.

    I did notice this warning in the IIS event log for WAS:

    Log Name:      System
    Source:        Microsoft-Windows-WAS
    Date:          11/26/2012 8:35:37 AM
    Event ID:      5011
    Task Category: None
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      APPVSRV.contoso.com
    Description:
    A process serving application pool 'AppVPublishing' suffered a fatal communication error with the Windows Process Activation Service. The process id was '1848'. The data field contains the error number.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-WAS" Guid="{524B5D04-133C-4A62-8362-64E8EDB9CE40}" EventSourceName="WAS" />
        <EventID Qualifiers="32768">5011</EventID>
        <Version>0</Version>
        <Level>3</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-11-26T14:35:37.000000000Z" />
        <EventRecordID>6032</EventRecordID>
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Channel>System</Channel>
        <Computer>APPVSRV.contoso.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="AppPoolID">AppVPublishing</Data>
        <Data Name="ProcessID">1848</Data>
        <Binary>18020780</Binary>
      </EventData>
    </Event>

    I'm not sure if this is relevant or not.  Searching for more information about this error hasn't turned up much.  It has only occurred twice early this morning.

    Monday, November 26, 2012 10:23 PM
  • Hello,

    Sounds great - still no idea what you checked.

    The steps you are describing has worked flawlessly in many cases, but in your instance there is an issue.

    Whats different about your issue? Is it due to how you setup your server? How you created your packages?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, November 26, 2012 10:57 PM
  • I followed this Technet article for sequencing apps.  The sequencing was done on a clean Windows 7 Enterprise x64 VM that was restored to a clean state before each app was sequenced.  I've explicitly specified 32-bit OS support, and I've used the default option which should apply to all operating systems.  I've tried 4 different apps (7-zip, Filezilla, GIMP, and LibreOffice), all with no success (though the same packages work fine on x64).  I followed this Technet article for setting up the server.  I followed this Technet article for setting up the clients.  The client appears to sync, and the event log shows Return code: 0x80 - 0x0.  After I noticed the problem, at your recommendation I went over each step here and verified it all.  I've very meticulously been over each article multiple times to ensure I haven't missed anything.  I've replicated the problem on multiple computers, both virtual and physical.  I don't know what other information to provide.  I have no idea why 64-bit clients could be working perfectly, while 32-bit clients sync but display no apps.  Surely, I can't be the only person who has ever encountered this problem, right?

    Tuesday, November 27, 2012 3:23 PM
  • Hello,

    I suggest you create your packages on a 32-bit machine

    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, November 27, 2012 3:38 PM
  • Thank you so much!  I admit, I didn't think that was going to make a difference.  I should have known it would be something like that.

    So, why did that work?  Why does it matter what architecture you sequence from?  Since it obviously does matter, why isn't it mentioned anywhere?  Am I going to have to sequence apps for 64-bit clients on a 64-bit sequencer, even though the apps themselves are 32-bit?  Or will the apps sequenced on the 32-bit machine work fine on 64-bit hardware?

    Thanks again!

    Tuesday, November 27, 2012 9:45 PM
  • Hello,

    I'm current working in a similar problem to this.

    At the documentation we have the following information:

    Microsoft Application Virtualization 5.0

    Sequencing Guide

    http://download.microsoft.com/download/F/7/8/F784A197-73BE-48FF-83DA-4102C05A6D44/App-V%205.0%20Sequencing%20Guide.docx

    Applications sequenced on a 32-bit  OS are often likely to run on a 64-bit client OS.  However, applications  sequenced on a 64-bit OS will never run on a 32-bit client OS.   Certain applications that are compatible with both 32-bit and 64-bit  operating systems may only work if sequenced separately on a 32-bit  Sequencer and a 64-bit Sequencer.  This screen enables targeting  two separate packages of the same application to the appropriate client  operating systems.

    I think that also answers  Nicke Källén

    Thank you Very much,

    Renato Pacheco

    Friday, December 27, 2013 6:55 PM