none
Microsoft Office Document Imaging 2003

    General discussion

  • Here's an odd one. So Microsoft deprecated .mdi format in office 2010. .mdi, .tif and .tiff could be opened by MODI 2003. So maybe you'd like to sequence it. mdi files can be opened by other third party viewers, Sharepoint Designer 2007, some can be opened by the built in Windows Photo Viewer in Windows 7 but not all can be opened in their proper format.

    Step 1 - Prepare the sequencing machine by adding the following Exclusions to the Exclusions list:

    Launch the App-V Sequencer. Browse to Tools-->Options

    %CSIDL_WINDOWS%\Installer

    \REGISTRY\MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall

    \REGISTRY\MACHINE\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

    Ensure Windows Search and Windows Defender services have been stopped on the machine.

    Step 2 - Sequence the Application

    Choose all defaults in the App-V Sequencing Wizard until you get to the window prompting you to provide a Package name. Name the package accordingly e.g. Microsoft MODI 2003. Take note of the Primary Directory e.g. Q:\Microsoft MODI 2003 as you'll want to install the application here. Click Next.

    Choose Perform a custom installation. Click Next.

    Launch Setup.exe. Ensure you select custom during the installation, For this application I allow it to install to the default Install Directory. However I do a custom installation and select unavailable for all components and sub-components except for the Office Document Imaging component which I select to run from this computer.

    Check the box to indicate the install has been completed once you have successfully installed the application.

    One the next screen you can launch the app to ensure there's no unexpected prompts or errors. Once application is closed again. Click Next.

    If you would like to stream from a server you should choose to customize the application further. This will allow you to modify the File Type associations and shortcut if you would like. Include the File types you would like. I removed .tif and .tiff. Leaving only .mdi which is the file type I had issues with on Windows 7.

    Now you may launch to capture the Feature Block 1 (What will appear first to the user) Here I launch the application and click on File, Edit and Help to ensure the menus appear right on launch time. When complete close the application and click next.

    You can then either save or continue to modify. Continue to modify. You will now see the Sequencer Interface with multiple tabs e.g. Deployment, Files, Virtual Registry etc. Browse to the OSD tab. Expand Implementation-->Expand VIRTUALENV--> Expand POLICIES. Click on LOCAL_INTERACTION_ALLOWED and change the text from False to TRUE.

    When complete you may select File-->SaveAs

    Save the application to the relevant path (what you set in the Deployment tab)

    Step 3 - Application Complete

    You can now deploy the application however you see fit. The reason we set the LOCAL_INTERACTION_ALLOWED for this application is due issues with the application in some cases causing issues with the users mouse and/or touchpad. The application appears to interact with the service for these when opening some .mdi files on Windows 7.

    I hope this is helpful for somebody!


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    • Changed type RorymonMVP Sunday, October 7, 2012 4:59 AM
    Sunday, October 7, 2012 4:58 AM

All replies

  • Thank you! I have a custom app that will only function correctly when opening tiff files with MODI 2003.
    Friday, November 16, 2012 11:22 AM