none
DPM 2010 Replication inconsistent, verification in progress - never finishes RRS feed

  • Question

  • Hello all,

    I'm trying to pick up a problem with DPM but unfortunately, I have very little experience with this and was hoping someone could help point me in the right direction.

    There are many physical and virtual servers protected and one particular server hasn't been protected for a month. The alert advised that the backup wasn't consistent and to perform a consistency check. I have tried to run this a couple of times but it never appears to finishe, it always states 'verification in progress'

    I have tried removing the server from the protection group, uninstalling the client, re-installing then running the consistency check again but it made no difference.

    The server in question is a file server running 2012R2 with ABE, DDUPE and has shadow copy enabled. The volume being protected is 1TB in size with approx 500GB free.

    Any help would be much appreciated.

    Kind Regards


    Wednesday, August 29, 2018 2:15 PM

All replies

  • Hello Gary,

    For how long have you been waiting for the consistency check?

    A consistency check checks every file in a 2 steps process. A lightweight comparison of file metadata to see what files may be different, then a heavyweight comparison of the files data to correct differences.

    Inconsistencies can occur for the following two reasons:

    • The filter driver on the protected server loses track of block level changes (for example: system crash, or unexpected cluster failover)
    • A Sync failed in the middle and we could not update the replica.

    A month is still quite long, and if it's a file server, there usually are a lot of files, you mentioned half of the 1TB is free so that leaves 500GB of data. In this case it's quite normal that the consistency check can take some time to finish.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:


    • Edited by Leon Laude Wednesday, August 29, 2018 2:23 PM Added some formatting.
    Wednesday, August 29, 2018 2:22 PM
  • Hi Leon,

    Thanks for replying. The consistency check has now finished (took 3 days) and it shows replica is inconsistent. It looks like a need to run a manual synchronization but if I click on create recovery point in the actions pane, the only option is to create a recovery point without synchronization. If I select this option, it fails with the message:

    Triggering create recovery point on D:\ failed:
    Error 208: No recovery point was created, either because synchronization has not occurred since the last recovery point was created, or because no changes were found during synchronization.
    Recommended action: If synchronization has not occurred since the last recovery point was created, you can synchronize the replica with the protected data on the protected computer and then create a recovery point. For more information, see "How to synchronize a replica" and "How to create a recovery point" in DPM Help

    This is what I am trying to do?

    Thursday, August 30, 2018 7:47 AM
  • The replica is synchronized, or updated, at regular intervals according to the settings that you configure.

    How often do you have it to synchronize? Check whether there are any synchronization jobs in progress aswell.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, August 30, 2018 8:01 AM
  • One recovery point should be created every day. I'm not sure how to find the synchronization schedule but can see it's sue to synchronize tonight 18.00 by looking at today jobs.

    I don't think it will work though as historically it's failing with the message below and I can't force a manual sync.

    Type: Recovery point
    Status: Failed
    Description: No recovery point was created, either because synchronization has not occurred since the last recovery point was created, or because no changes were found during synchronization. (ID 208)
    More information
    End time: 30/08/2018 08:27:27
    Start time: 30/08/2018 08:27:27
    Time elapsed: 00:00:00
    Data transferred: 0 MB
    Source details: D:\
    Protection group members: 1
    Details
    Protection group: File Servers

    Thursday, August 30, 2018 1:38 PM
  • The synchronization can be configured and checked if you right click a Protection Group and click Modify protection group and then head to the Select short-term goal step.

    Was this error taken from the Monitoring pane under Critical alerts?


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, August 30, 2018 1:49 PM
  • Thanks for showing me where it is.

    It's currently set with a retention range of 60 days and to synchronize just before creating a recovery point. The recovery point is created at 18:00 every day.

    Yes, that it where I saw the details.

    Many Thanks

    Monday, September 3, 2018 7:09 AM
  • You might want to try removing the protected server (retain data) from the protection group and re-add it.

    Blog: https://thesystemcenterblog.com LinkedIn:

    Monday, September 3, 2018 7:47 AM
  • I did try that. I also tried uninstalling the agent and re-installing.

    There are some Windows updates pending and it hasn't been restarted in a while so i'll look into getting this done.

    Thanks for your help with this.


    Monday, September 3, 2018 10:08 AM
  • Let us know how it goes!

    Blog: https://thesystemcenterblog.com LinkedIn:

    Monday, September 3, 2018 11:16 AM
  • Hello,

    Just wanted to update that a colleague investigated this issue and found the cause of the problem to be network connectivity problems within the physical SAN itself. Frames were being dropped which was causing this (and other) DPM backups to fail.

    He is still investigating but is pretty sure this is the issue.

    Tuesday, September 25, 2018 10:32 AM
  • Hi,

    Ok, thanks for sharing this with us! Hopefully you will get it fixed.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, September 25, 2018 11:55 AM