locked
Lync 2013 Application is not getting discovered in SCOM 2012 RRS feed

  • Question

  • Hi All,

    I installed SCOM agent on Lync 2013 servers, SCOM can able to detect windows operating system of the agent.  But there is no information related to Lync in Lync 2013 views, nothing is discovered so far.

    Lync servers are deployed in separate domain, we are managing them through GW server.  I imported Lync 2013 management pack in SCOM 2012 and enabled agent proxy for all Lync servers.  Almost 15 hours completed, nothing is discovered. Did i miss anything?

    Do I need to configure watcher node which is comes with Lync 2013 MP?  Please advice.

    Thanks in advance.

    Regards

    Karthick M

    Friday, February 13, 2015 5:39 AM

Answers

All replies

  • I wish I could find the old article on system center central, about discovery not working and the reg hacks they had to perform in order for the discovery to work.

    We deployed the Lync 2010 MP to SCOM 2007 R2 a few years ago.  I told the Lync Admin that he needed to do some things in order for discovery to work.  He did these things, and yet we were still not getting any discovered inventory.

    I googled, and found an article on System Center Central about a similar problem.  We designated one of the lync servers as a discovery agent (per the advice in the MP), however our discovery data was TOO large for an agent to process (over 5 MB maybe?).  There was/is a hard limit for agents, management server, I believe is like 15 MB.  So according to the article on SCC, (the person worked with PSS on this issue), they had to add a reg key to a management server which would make it a discovery node for Lync.  Then I think you had to add it to the lync pool, maybe not, I forget, but you might have to manually add it to a Lync group.  Once we did this, our large Lync environment was discovered and is monitored to this day.

    We are moving to SCOM 2012 R2 soon, so I will have to find out what I did (since I failed to document it), so as to replicate it for SCOM 2012.  I believe this agent discovery ability may not have been fixed in 2012, but I could be wrong.

    Anyway, first thing to do is send the MP guide to your Lync admin and have him/her read through it and configure lync accordingly.  If after that nothing is coming in, then you can turn on logging on one of the discovery Lync nodes, and you will probably find that it's hitting it's discovery buffer limit and dropping it all (as we did).  Then you will just have to hack the reg on one of your management servers, and let it be the discovery node.  Our environment has not been negatively impacted by this additional workload, but get guidance from your MSFT resource before doing so...if this is your issue.


    Regards, Blake Email: mengotto<at>hotmail.com Blog: http://discussitnow.wordpress.com/ If my response was helpful, please mark it as so, if it answered your question, then please also mark it accordingly. Thank you.

    Friday, February 13, 2015 6:37 AM
  • Hi,

    Please try to reboot "System Center Management Service".

    And we can look into operation manager event logs and check is there any error messages regarding to Lync discovery.

    In addition, you may follow the articles below to be able to monitor Lync server:

    Configuring Lync Server 2013 to work with System Center Operations Manager

    https://technet.microsoft.com/en-us/library/jj205188.aspx

    Ive Imported Lync 2013 Management Pack for SCOM 2012 but what next?

    http://lyncme.co.uk/microsoft-lync-server-2013/ive-imported-lync-2013-management-pack-for-scom-2012-but-what-next/

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.



    • Edited by Yan Li_ Monday, February 16, 2015 5:56 AM edit
    • Proposed as answer by Yan Li_ Sunday, February 22, 2015 3:05 AM
    • Marked as answer by Yan Li_ Monday, February 23, 2015 1:21 AM
    Sunday, February 15, 2015 5:00 AM