locked
Fail to promote a single server as the array manager RRS feed

  • Question

  • I try to change a single server into the Array Manager.

    I use the array manager, and just select 'set this server as the array manager'.
    It goes through the motions (spinning gears) and eventually that it is succesfully configured as the array manager.

    But when I close and reopen the UAG Management console it still show as a single server.

    What can I do to troubleshoot this?

     

     


    Thursday, July 14, 2011 3:52 PM

Answers

All replies

  •  

    I have followed the Test Lab Guide for UAG RTM http://www.microsoft.com/downloads/en/details.aspx?displaylang=en&FamilyID=7fb64cad-5dac-471a-9fbf-a6c9d03ffbad

    I'm in the exact same situation to start with.

    One single server with two public ip-adresses and one internal ip-address.

    I do exactly as in the Guide. Change all ip-address, both external and internal.

    But I can not simple take the fist step into making this first UAG the Arrary Manager.

    The whole purpose is to migrate the work that i have done on my first UAG server towards two new servers.
    But if i loose to much time with figuring out how to solve this array manager business, i will be better of starting from scratch.

    I cannot help feeling that managing UAG is quite a tricky thing to do. It demands so much effort to solve al kind of hurdles on the way.
    I love the result that the product is delivering, but i will shiffer every month when I need to hit the update button.

     

     

    Thursday, July 14, 2011 6:32 PM
  •  

    I just tried to promote one of my newly installed UAG servers as the Array Manager.

    With just the same result. It passes the configuration but when I go and look again in Array Management Wizard it still remains a single server!

    So continuing has no sense since I will not be able to configure my two new servers in an array.

    Guess I will need to call MS support.

    Or does anybody have a pointer where to look for a solution?

    Thursday, July 14, 2011 7:22 PM
  • Hi,

    there's no problem with your server, and it is probably correctly configured as an array manager. You won't however see any visual changes in the UAG Management console until you add a second server to this array.

    Regards,


    -Ran
    • Marked as answer by JohnDBE Monday, July 18, 2011 6:33 AM
    • Unmarked as answer by JohnDBE Monday, July 18, 2011 6:34 AM
    Saturday, July 16, 2011 8:13 PM
  • Hi Ran,

    Thank you for your reply. I appreciate it!

    That is very strange, because when I go back to my first server.
    Close UAG management console.
    Open the UAG management console.
    Go to Array Manager.
    At the bottom it clearly states ! Current server status: Single server.

    Ok, but I went through it again.

    On the UAG management console of my first server:
    I assigned my first server as the array manager.
    And added the first of the new servers to be joined.

    Then from the Management console from the first new server to be joinded:
    I choose add this server to an array.
    And point to the first server using browse and using domain admin credentials.
    I click next.
    Checking connectivity to the array manager. (Gears spinning for two to three seconds)
    You have successfully completed the wizard. When you click finish, this server connects to the array manager using the settings provided.
    I click finish.
    Joining the array. This might take a few minutes. please wait.... (Gears spinning for seven minutes, then stop spinning)
    Eventually an error: This server cannot join the array.

    So it could be that I'm doing something wrong, but I think this is the procedure that I should follow?

    Thanks, John

     

     


    The server cannot join the array.

    Monday, July 18, 2011 7:04 AM
  • Hi,

    The procedure you describe looks OK to me, and I can't say that I spot anything missing in it.


    -Ran
    Monday, July 18, 2011 5:15 PM
  • Ran,

    The testlab guide states to install hotfix: http://support.microsoft.com/kb/977342

    I have to mention that the installation of this hotfix failes on my first server: The update is not applicable to your computer.
    Originally it was a UAG2010 install.
    Later on, I installed SP1 for UAG2010.

    Eventviewer logs this event:
    Windows update could not be installed because of error 2149842967 "" (Command line: ""C:\Windows\system32\wusa.exe" "C:\KB977342\Windows6.1-KB977342-v2-x64.msu" ")

    Now, I don't think that is important at this stage of the array congiguration. I believe the hotfix comes into play when using NLB and the support for Teredo and 6to4.

    Or do you think this could be the reason?

    thanks john

    Tuesday, July 19, 2011 7:03 AM
  • Hi John,

    No, you're right, this hotfix is not important at this stage, it should only influence NLB functionality, and has nothing to do with the array functionality. Furthermore, if your server's OS is Windows Server 2008 R2 SP1, there's a good chance that installing this hotfix is not needed anymore (see this thread http://social.technet.microsoft.com/Forums/en/winserverwsus/thread/851b8de7-4415-4a67-affc-5f6bb698b685 about an error similar to the one you get)

    Regards,


    -Ran
    • Marked as answer by Erez Benari Friday, August 26, 2011 10:58 PM
    Tuesday, July 19, 2011 7:33 AM