locked
CUCM and Sfb integration RRS feed

  • Question

  • Hi,

    We are trying to integrate CUCM with SFB (not by Edge server but internally) in order to IM and have presence.

    We ran through all steps and what I see:

    1. Jabber client can send IM to SfB client (Sfb client sees it).

    2. SfB client cannot send message back

    3. Sfb client cannot see Jabber's presence 

    4. Jabber client sees all Sfb users as offline 

    Regard 1 and 2:

    CUCM sends INVITE message and in Contact Header the Cisco places Presence server.

    After it SfB tried to send messages to this address from Contact Header.

    It seems that it should work this way (from SIP perspective) but functionalities should work other way.

    What can we change or configure to make it work?

    Saturday, June 22, 2019 11:05 AM

All replies

  • Hi,

    In my research, on the Skype for Business server side, I suggest you could check the related port is opened (5060, 5061,5062/5080), and the required DNS records are added, the used certificates are trusted within the organization.

    In addition, have a try to restart the services on both Skype for Business and CUCM side.

    Here is a related guide you could refer to.

    Note: This response contains a reference to a third party World Wide Web site. Microsoft can make no representation concerning the content of these sites. Microsoft is providing this information only as a convenience to you: this is to inform you that Microsoft has not tested any software or information found on these sites and therefore cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software on the Internet.


    Best Regards,
    Shaw Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by Shaw_Lu Monday, July 1, 2019 8:41 AM
    Monday, June 24, 2019 3:07 AM
  • Thank you very much for your answer Shaw Lu.

    I checked the configuration on SfB server and I see that I have configured:

    - TrustedApplication

    - TrustedApplicationPool

    - TrustedApplicationComputer

    - StaticRoutes

    For Cisco I use one name: Cisco.ad.local.

    I have 2 domains:

    - sfbdomain.com in SfB

    - Sfbcoamin.be in Cisco

    So the domains are different!

    Can you show me your SIP Invite message from Cisco to SfB? I still see that in Contact Header the IP Address of Presence Cisco server. And to these IP Address SfB tries to send messages back.

    Can we compare our SIP Messages?

    Monday, June 24, 2019 7:32 AM
  • Hi,

    Unfortunately, I don’t have a cisco environment now.


    Best Regards,
    Shaw Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, June 25, 2019 6:59 AM
  • Anyone else can help?

    Tuesday, June 25, 2019 3:13 PM
  • Hope any one in our forum can share the experience when encountering this kind of scenario.

    In addition, as this is related to CUCM, I think you may also try to connect to Cisco to see if there is any clue. 


    Best Regards,
    Shaw Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by Shaw_Lu Monday, July 1, 2019 8:41 AM
    Thursday, June 27, 2019 8:06 AM