none
Problem applying web template features missing

    Question

  • Hello,

    I created a new site under the 2013 environment then created a template from it. When I try to apply that template to a new site we get the following error:
    Problem applying web template

    It then list the following features as not installed:
    List Feature
    Module Feature
    Web EventReceivers Feature
    Property Bag Feature

    With other templates this error does not pop out.

    1. What is the option in creating the template site that causes the error ?
    2. Everything seems work fine, what are these features worth for ?

    There was a similar question in thread 

    Problem applying web template
    answered Dimitri Ayrapetov (MCSE: SharePoint) December 2014

    They suggested to run the Powershell script Get-SPFeature | select ID, DisplayName, Scope

    to verify if these solutions appear. If not disable them with

    http://featureadmin.codeplex.com

    I have to ask the administrator to do this, is it necessary ? 

    Thanks for your kind attention

    Best regards

    Marco

    Here is a screenshot of the error

    



    Marco Furlan

    Wednesday, April 05, 2017 11:11 AM

All replies

  • Hi Marco Furlan,

    This issue is caused by these features are not available.

    The “Get-SPFeature” cmdlet is used to get all SharePoint Features. We can use it to check if the feature is installed. Have you installed these features to the site?

    You should add the features to the site and active them.

    Another workaround, remove these feature from the original site and recreate the template, or create a site template from a site without these features, then create a new site with the new template.

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, April 06, 2017 5:52 AM
    Moderator
  • Hi Linda,

    thank you for answering.

    Unfortunately I don't have direct control on the server, I have to ask the system admin to run the cmdlet. It is a corporate installation.

    1. Accessing Sharepoint from the browser or Sharepoint designer, how do I know if a site have these features or not and how do I remove the features from the site ?
    2. For my information, what are these features for ? From the name they seem important, but sharepoint, an enterprise installation, seems working fine without them.

    Thank you

    Marco


    Marco Furlan

    Thursday, April 06, 2017 8:12 AM