none
Could not find stored procedure 'dbo.prc_PRM_Replica_GetAllLogicalReplicas'. RRS feed

  • Question

  • Hi, the DPM 2012 R2 CU3 of one of my customer suddenly stopped working.

    The GUI crash with windows error some second after you openend it. Customer did nothing on that server and the last upgrade was some month ago. 
    In the eventviewer I got this message:

    The description for Event ID 945 from source MSDPM cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event: 

    Unable to connect to the DPM database because of a general database failure.  Make sure that SQL Server is running and that it is configured correctly.

    Problem Details:
    <FatalServiceError><__System><ID>19</ID><Seq>5828</Seq><TimeCreated>20.01.2015 16:57:46</TimeCreated><Source>DpmThreadPool.cs</Source><Line>163</Line><HasError>True</HasError></__System><ExceptionType>SqlException</ExceptionType><ExceptionMessage>Could not find stored procedure 'dbo.prc_PRM_Replica_GetAllLogicalReplicas'.</ExceptionMessage><ExceptionDetails>System.Data.SqlClient.SqlException (0x80131904): Could not find stored procedure 'dbo.prc_PRM_Replica_GetAllLogicalReplicas'.

    (...)

    The connection to SQL is ok (it's on the same machine) and all the users involved are not locked and working. Disk is not full and it was not full. We restarted server and all the services.

    I checked in the SQL and I cannot find a stored procedure with that name. So why DPM is searching it ? Off course, we didnt' deteted a stored procedure.

    I took a look on another two DPM with identical version, but none of them have that stored procedure.

    So what's wrong??

    Someone can help us please

    Thursday, January 22, 2015 4:23 PM

All replies

  • Hi

    the stored Procedur 'dbo.prc_PRM_Replica_GetAllLogicalReplicas' is a part of SCDPM 2012 R2 UR4, so i think someone tried to upgrade to UR4 and this gone wrong.

    So, thats a bad Situation, there are 2 Ways

    1: (the best and supported) hoppefully you got a backup, uninstall DPM and SQL, install SQL, DPM and UR3, restore backed up DB, and all is done. than try to upgrade to UR4

    2:(not recommended)  try to install a SCDPM 2012 R2 UR4 on a different Server, Export the 'dbo.prc_PRM_Replica_GetAllLogicalReplicas' and Import it to your DPM


    Seidl Michael | http://www.techguy.at | twitter.com/techguyat | facebook.com/techguyat | youtube.com/techguyat

    Thursday, January 22, 2015 7:10 PM
  • Hi, thank you for reply. I have no signs or events related to an upgrade done by the customer or someone else, so sound very strange to me that we have a stored procedure of UR4.

    Someone else please can confirm it?

    No customer have a very old backup. The best we can do probably is to try to install the UR4 and hope that it will work. Or reinstall everything from scratch.

    But really, I have no signs of patching installation...

    Friday, January 23, 2015 8:37 AM
  • Try to run the UR4 installation, maybe it works.

    Seidl Michael | http://www.techguy.at | twitter.com/techguyat | facebook.com/techguyat | youtube.com/techguyat

    Sunday, January 25, 2015 8:54 AM
  • Hi,

    installing only the UR4 didn't resolve the issue. After the UR4 installation, the GUI continues to crash, but we no longer have the error related to stored procedure.

    We solved running a DBCC CHECKDB on DPM Database and after running .\DPMSync.exe -sync.

    After these operations, customer's DPM is now ok

    Tuesday, January 27, 2015 8:52 AM