none
installing packages fails RRS feed

  • Question

  • I'm unable to install any packages. When I try to, I get the following errors and warnings (the below is taken from an attempt to install plyr):

    make: /usr/local/clang4/bin/clang++: No such file or directory
    make: *** [Date.o] Error 1
    ERROR: compilation failed for package ‘Rcpp’
    * removing ‘/Library/Frameworks/R.framework/Versions/3.4.3-MRO/Resources/library/Rcpp’
    Warning in install.packages :
      installation of package ‘Rcpp’ had non-zero exit status
    ERROR: dependency ‘Rcpp’ is not available for package ‘plyr’
    * removing ‘/Library/Frameworks/R.framework/Versions/3.4.3-MRO/Resources/library/plyr’
    Warning in install.packages :
      installation of package ‘plyr’ had non-zero exit status

    I'm running MRO 3.4.3 in R Studio in OSX El Capitan. Installing and running packages works when using standard R-3.4.3.



    • Edited by orangeman51 Monday, January 22, 2018 7:28 PM
    Monday, January 22, 2018 7:27 PM

Answers

  • Microsoft R Open 3.4.3 on the Mac requires packages to be built from source; packages such as Rcpp that require compilation require installation of the Mac development tools. These include clang 4.0.0 and gfortran 6.1.

    Cheers,

    Rich Calaway

    Microsoft R Open team

    • Marked as answer by orangeman51 Saturday, February 3, 2018 6:15 PM
    Monday, January 22, 2018 8:36 PM