none
MDT 2012 deployment using USB media to REFRESH a remote PC with STATIC IPs. RRS feed

  • Question

  • I've searched all over for the solution but cannot seem to find it.

    I'm using MDT 2012 to create USB LTI media to deploy a REFRESH task sequence to remote PCs configured with STATIC IPs.

    The USB LTI media successfully completes the REFRESH sequence, user data restore, OS upgrade, app installs, all that works fine.

    The only thing I can't get working is copying the old static IP settings and applying them to the new OS.

    I've tried using the Capture Network Settings and Apply Network Settings Task Sequence steps, but those don't work. The PC always ends up with DHCP enabled.

    Can someone point me to a step-by-step guide to configure MDT to accomplish this?

    I can't configure this one-by-one because I'll have to use this method on over 100 remote PCs with no DHCP.

    Thursday, July 25, 2013 2:39 AM

All replies

  • Thursday, July 25, 2013 4:39 AM
    Answerer
  • Yes, about an hour before I posted the question.

    He says to capture the settings, use "Capture Network Settings" (Which I already stated didn't work) I tried it with the switches and without, didn't make any difference.

    You'll note he lists that as a method to capture the settings, but he doesn't bother to say how to Apply the settings.

    I assumed it was supposed to be applied with "Apply Network Settings", but again, those two commands don't work and the PC still ends up with no network settings and DHCP enabled.

    He says the settings captured were stored in a file in MININT... I'm gonna see if I can pause the deployment mid-stream and see if I can see what is in that file... At least that will tell me if the settings are actually being captured like the command is supposed to.

    Thursday, July 25, 2013 12:12 PM
  • I found the ZTINicConfig.log...
    <![LOG[Microsoft Deployment Toolkit version: 6.1.2373.0]LOG]!><time="15:22:29.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[The task sequencer log is located at C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log.]LOG]!><time="15:22:29.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[ZTINicConfig Script Entered.]LOG]!><time="15:22:29.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[             PHASE = STATECAPTURE]LOG]!><time="15:22:29.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[ Deployment Method = MEDIA]LOG]!><time="15:22:29.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[   Deployment Type = REFRESH]LOG]!><time="15:22:29.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Capture Network Settings from local machine and write to Environment.]LOG]!><time="15:22:29.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Query networking adapters...]LOG]!><time="15:22:29.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Networking Adapters found! Count = 2]LOG]!><time="15:22:29.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Save Network Adapter(0) MAC = True Broadcom NetXtreme 57xx Gigabit Controller]LOG]!><time="15:22:29.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0EnableDHCP is now = False]LOG]!><time="15:22:29.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0Name is now = Local Area Connection]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0MacAddress is now = 00:1C:23:54:91:63]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0Description is now = Broadcom NetXtreme 57xx Gigabit Controller]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0IpAddressList is now = xxx.xxx.xxx.xxx]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0SubnetMask is now = 255.255.255.128]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0Gateways is now = xxx.xxx.xxx.xxx]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0DNSServerList is now = xxx.xxx.xxx.xxx]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0EnableDNSRegistration is now = False]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0EnableFullDNSRegistration is now = True]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0EnableLMHOSTS is now = True]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0TCPIPNetBiosOptions is now = 0]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0EnableWINS is now = True]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0WINSServerList is now = xxx.xxx.xxx.xxx]LOG]!><time="15:22:30.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0EnableIPProtocolFiltering is now = False]LOG]!><time="15:22:31.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapterCount is now = 1]LOG]!><time="15:22:31.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[ZTINicConfig processing completed successfully.]LOG]!><time="15:22:31.000+000" date="07-24-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property ForceCapture is now = ]LOG]!><time="15:24:18.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Microsoft Deployment Toolkit version: 6.1.2373.0]LOG]!><time="15:24:18.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[The task sequencer log is located at X:\windows\TEMP\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log.]LOG]!><time="15:24:18.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[ZTINICConfig Script Entered.]LOG]!><time="15:24:18.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[             PHASE = PREINSTALL]LOG]!><time="15:24:18.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[ Deployment Method = MEDIA]LOG]!><time="15:24:18.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[   Deployment Type = REFRESH]LOG]!><time="15:24:18.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Capture Network Settings from local machine and write to Environment.]LOG]!><time="15:24:18.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Query networking adapters...]LOG]!><time="15:24:18.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Networking Adapters found! Count = 1]LOG]!><time="15:24:18.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Property OSDAdapterCount is now = 0]LOG]!><time="15:24:19.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[ZTINICConfig processing completed successfully.]LOG]!><time="15:24:19.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Microsoft Deployment Toolkit version: 6.1.2373.0]LOG]!><time="16:00:21.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[The task sequencer log is located at C:\Users\ADMINI~1\AppData\Local\Temp\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log.]LOG]!><time="16:00:21.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[ZTINICConfig Script Entered.]LOG]!><time="16:00:21.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[             PHASE = STATERESTORE]LOG]!><time="16:00:21.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[ Deployment Method = MEDIA]LOG]!><time="16:00:21.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[   Deployment Type = REFRESH]LOG]!><time="16:00:21.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[No Settings Saved, Exit...]LOG]!><time="16:00:21.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[ZTINICConfig processing completed successfully.]LOG]!><time="16:00:21.000+000" date="07-24-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    
    From what I can tell, it seems the Capture sequence is reading the NIC settings but not saving them. When it tries to apply them, it responds "No Settings Saved, Exit..."
    Thursday, July 25, 2013 1:21 PM
  • I looked at a few of my logs and only see ZTINic getting called once during a deployment, but your log shows that it's getting called three different times (StateCapture, PreInstall, StateRestore).  It looks like under StateCapture it's finding and capturing the settings, but that it's called again under Preinstall and the settings are then set to 0 so that when it's called in StateRestore, there is nothing to restore.  Do you have an extra step in PreInstall area calling ZTINicConfig?


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, July 25, 2013 3:17 PM
    Answerer
  • The one in StateCapture is the Capture Network Settings command I added, it's the same command from Scriptimus' blog.

    The one in PreInstall I did not add, it must have been added by the original task sequence wizard. I never looked in there for it.

    The one in StateRestore is the Apply Network Settings command I added in an attempt to restore the settings.

    So, should I remove one of the first two? Which one? I'm thinking I should remove the one the Wizard added in PreInstall. The Pre-Install one won't execute until the computer has already rebooted into WinPE... I think it'll be too late to capture the settings properly by that point... I'll bet that's why it's returning 0 network adapters.

    I'll do that. I'll leave the Capture and Apply in StateCapture and StateRestore, respectively and remove the Capture in PreInstall.

    I wonder why the Wizard put the Capture in PreInstall when it can't capture the settings at that point?

    Thursday, July 25, 2013 3:47 PM
  • Ok, figure this out...

    <![LOG[Property ForceCapture is now = ]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property RestoreWithinWinPE is now = ]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Microsoft Deployment Toolkit version: 6.1.2373.0]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[The task sequencer log is located at C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log.]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[ZTINicConfig Script Entered.]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[             PHASE = STATECAPTURE]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[ Deployment Method = MEDIA]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[   Deployment Type = REFRESH]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Capture Network Settings from local machine and write to Environment.]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Query networking adapters...]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Networking Adapters found! Count = 2]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Save Network Adapter(0) MAC = True Broadcom NetXtreme 57xx Gigabit Controller]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0EnableDHCP is now = False]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0Name is now = Local Area Connection]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0MacAddress is now = 00:1C:23:54:91:63]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0Description is now = Broadcom NetXtreme 57xx Gigabit Controller]LOG]!><time="13:22:17.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0IpAddressList is now = xxx.xxx.xxx.xxx]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0SubnetMask is now = 255.255.255.128]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0Gateways is now = xxx.xxx.xxx.xxx]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0DNSServerList is now = xxx.xxx.xxx.xxx]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0EnableDNSRegistration is now = False]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0EnableFullDNSRegistration is now = True]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0EnableLMHOSTS is now = True]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0TCPIPNetBiosOptions is now = 0]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0EnableWINS is now = True]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0WINSServerList is now = xxx.xxx.xxx.xxx]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapter0EnableIPProtocolFiltering is now = False]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Property OSDAdapterCount is now = 1]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[ZTINicConfig processing completed successfully.]LOG]!><time="13:22:18.000+000" date="07-25-2013" component="ZTINicConfig" context="" type="1" thread="" file="ZTINicConfig">
    <![LOG[Microsoft Deployment Toolkit version: 6.1.2373.0]LOG]!><time="14:01:38.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[The task sequencer log is located at C:\Users\ADMINI~1\AppData\Local\Temp\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log.]LOG]!><time="14:01:39.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[ZTINICConfig Script Entered.]LOG]!><time="14:01:39.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[             PHASE = STATERESTORE]LOG]!><time="14:01:39.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[ Deployment Method = MEDIA]LOG]!><time="14:01:39.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[   Deployment Type = REFRESH]LOG]!><time="14:01:39.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Network Config Adapter Count: 1]LOG]!><time="14:01:39.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Query networking adapters...]LOG]!><time="14:01:39.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Networking Adapters found! Count = 1]LOG]!><time="14:01:39.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Restore Network Settings (0).]LOG]!><time="14:01:39.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Found Network MAC Settings (00:1C:23:54:91:63) = Broadcom NetXtreme 57xx Gigabit Controller]LOG]!><time="14:01:39.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Load Network Adapter(0) = Broadcom NetXtreme 57xx Gigabit Controller]LOG]!><time="14:01:39.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Action: oAdapter.EnableStatic(IPAddress,SubnetMask)]LOG]!><time="14:01:39.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[WMI Function: Adapter.EnableStatic(IPAddress,SubnetMask) FAILURE: -2147180508   Unknown Error: -2147180508]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="2" thread="" file="ZTINICConfig">
    <![LOG[Action: oAdapter.SetGateways(Gateway, GatewayMetric)]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[WMI Function: Adapter.SetGateways(Gateway, GatewayMetric) Success!]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Action: oAdapter.SetTcpipNetbios]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[WMI Function: Adapter.SetTcpipNetbios Success!]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Action: oAdapter.SetWINSServer(1,2)]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[WMI Function: Adapter.SetWINSServer Success!]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Action: oAdapter.SetDNSServerSearchOrder()]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[WMI Function: Adapter.SetDNSServerSearchOrder Success!]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Action: oAdapter.SetDNSDomain()]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Action: oAdapter.SetDynamicDNSRegistration(...)]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[WMI Function: Adapter.SetDynamicDNSRegistration Success!]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Action: oAdapter.EnableIPFilterSec(...) ]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[Action: oAdapter.Name(...) ]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[	Change [Local Area Connection] to [Local Area Connection]]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">
    <![LOG[ZTINICConfig processing completed successfully.]LOG]!><time="14:01:40.000+000" date="07-25-2013" component="ZTINICConfig" context="" type="1" thread="" file="ZTINICConfig">

    I simply disabled the PreInstall Capture sequence and re-ran it.

    It is successfully setting the DNS and WINS settings staticly, but the IP settings are still DHCP.  The log is showing "FAILURE: -2147180508   Unknown Error: -2147180508" when it tries to set the IP.

    Any idea what that is?

    Thursday, July 25, 2013 7:28 PM