locked
vpn not working after upgrade to windows 10 with MAC VPN Server l2tp/ipsec RRS feed

  • Question

  • After upgrading to windows 10 I can no longer connect to my office VPN Server.

    Here's the background, My office uses a Mac server to provide L2TP/IPSEC vpn for remote access to the office network. After a lot of digging around I found this support page with details about how to tweak windows 7 to connect to the Mac server (https://support.apple.com/en-us/HT202384). Because I have the home premium version of windows I don't have access to secpol.msc but I was able to make the necessary changes directly in the registry and get The VPN connection to work great in windows 7.

    After upgrading to windows 10, the vpn connection no longer works. I appear to be getting error 788.

    I've checked all of the registry changes that I had originally made in windows 7 and they are all still intact. 

    There must be something that changed between the way that windows 10 and windows 7 handles vpn security...

    Before someone says this is a Mac problem, it worked flawlessly for months with windows 7 and broke immediately after the upgrade. 

    On a side note, provided that windows 10 works, my plan is to upgrade to the pro version but I don't want to spend the money if I'm just going to roll back to windows 7 because VPN doesn't work...

    Monday, August 24, 2015 7:31 PM

Answers

  • Hi,

    Thanks for your feedback, I won’t say it is a MAC problem. The error code states that The L2TP connection attempt failed because the security layer encountered a processing error during initial negotiations with the remote computer.

    Possible causes for this issue could be:

    a> L2TP based VPN client (or VPN server) is behind NAT.

    b> Wrong certificate or pre-shared key is set on the VPN server or client

    c> Machine certificate or trusted root machine certificate is not present on the VPN server.

    d> Machine Certificate on VPN Server does not have 'Server Authentication' as the EKU

    Since you mentioned that it is a MAC VPN server and I am supposing that you don’t have set/change Pre Shared Key (PSK) or any certificate, the most possible reason is that L2TP VPN server is behind NAT. unfortunately since we don’t have such device to test that due to limitations of our test environment. But if that is the reason, I think this issue should be widespread. We need to wait for some more similar issues and updates released from Microsoft see if can be fixed. The PPTP should works according to description from other users.

    Regards,

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Deason Wu Monday, September 7, 2015 9:05 AM
    • Marked as answer by Michael_LS Wednesday, September 9, 2015 1:18 AM
    Monday, August 31, 2015 2:50 AM
  • I have found a solution, maybe help.

    1. Event Viewer>Windows Log>Find the error>Check the detail and find the error code.

    2. Bing and find the solution https://support.microsoft.com/en-us/kb/926179

    3. Restart your pc

    It works for me.

    • Marked as answer by Deason Wu Monday, September 14, 2015 1:09 AM
    Friday, September 11, 2015 2:29 PM

All replies

  • Hi,

    Thanks for your feedback, I won’t say it is a MAC problem. The error code states that The L2TP connection attempt failed because the security layer encountered a processing error during initial negotiations with the remote computer.

    Possible causes for this issue could be:

    a> L2TP based VPN client (or VPN server) is behind NAT.

    b> Wrong certificate or pre-shared key is set on the VPN server or client

    c> Machine certificate or trusted root machine certificate is not present on the VPN server.

    d> Machine Certificate on VPN Server does not have 'Server Authentication' as the EKU

    Since you mentioned that it is a MAC VPN server and I am supposing that you don’t have set/change Pre Shared Key (PSK) or any certificate, the most possible reason is that L2TP VPN server is behind NAT. unfortunately since we don’t have such device to test that due to limitations of our test environment. But if that is the reason, I think this issue should be widespread. We need to wait for some more similar issues and updates released from Microsoft see if can be fixed. The PPTP should works according to description from other users.

    Regards,

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Deason Wu Monday, September 7, 2015 9:05 AM
    • Marked as answer by Michael_LS Wednesday, September 9, 2015 1:18 AM
    Monday, August 31, 2015 2:50 AM
  • My L2TP VPN works well on Windows 8, Android and my Macbook, but my new pc which was installed windows 10 cann't use it anymore. 

    I think there must something changed windows 10

    Friday, September 11, 2015 1:47 PM
  • I have found a solution, maybe help.

    1. Event Viewer>Windows Log>Find the error>Check the detail and find the error code.

    2. Bing and find the solution https://support.microsoft.com/en-us/kb/926179

    3. Restart your pc

    It works for me.

    • Marked as answer by Deason Wu Monday, September 14, 2015 1:09 AM
    Friday, September 11, 2015 2:29 PM
  • Not sure if this helps anyone, but I usually uncheck "Use default gateway on remote network" under the Network > IPv4 properties under the Advanced button > IP Settings and it works on Windows 7 and 8, but does NOT work on Windows 10. Once I checked that box in Windows 10, the L2TP client connected. 

    Wednesday, February 24, 2016 4:53 AM
  • @Omnigate: I do not have this option as you described.

    @Daniel: Maybe this helps:

    https://support.microsoft.com/de-de/kb/926179

    Tuesday, October 4, 2016 7:04 PM
  • at my place it works enabling CHAP in the VPN settings > security > allow following protocols ...
    Tuesday, October 4, 2016 7:10 PM
  • Omnigate, I do not have this option you describe
    Tuesday, October 4, 2016 7:12 PM