locked
xxxxxx0A-00002002 RRS feed

  • Question

  •  

    I've installed App-V management on a Windows 2008 64 Bit server, with the database on a second Windows 2008 64 Bit SQL 2005, and the latest APP-V client on a Windows 2003 Terminal server, when I try to refresh I get an error message : The server will not allow a connection without a valid NTLM credentials, Report the following error code to your system administrator.

     

    I found this KB on support.microsoft.com

     

    http://support.microsoft.com/?kbid=930721, that one of the more less informative KB's I've seen..

     

    I am logged on to the domain on both the APP-V server and the APP-V client.

     

    I get the same error if I change to the port 554 on the client.

     

    On the APP-V server I have both protocols enabled.

     

    Anyone got any suggestions?

     

     

     

     

     

     

     

     

     

    Wednesday, December 3, 2008 12:02 PM

Answers

All replies

  • I ended up with a complete reinstall of APP-V, done by the book and now it  works fine.. Smile

     

     

     

    Monday, December 8, 2008 12:57 PM
  • Any idea what actually caused it? I am running into the same problem.
    Saturday, August 15, 2009 2:59 AM
  • I'd like to know myself If anyone know the cause of the problem, and How can I solve this? (I've already reinstalled my server, and it didn't change a thing)

    Thanks for your answers!
    Friday, January 22, 2010 11:01 AM
  • I finally found my problem, I forgot to put the full DNS name for my publication server
    Friday, January 22, 2010 11:20 AM
  • For service "Application Virtualization Management Server"  to assign "Log On" = "Local System account".
    Thursday, April 1, 2010 12:49 PM
  • What?
    Thursday, August 5, 2010 2:56 PM
  • true... I cant believe this.. I've tried a dozen things and this finally works for me... changed to Local System Account...

    good work :)

    Wednesday, March 9, 2011 1:00 AM
  • thanks.... it also helped me....

     

    Claus

    Friday, April 8, 2011 12:09 PM
  • So, what should run as the Local System Account?

    Both my server and client are configured that way by default. On one machine with the exact same configuration of the client, I can connect but on the other I get the error. Also, the one with the problem used to work, it's like it becomes corrupt at some point. So far, I am unable to resolve by reinstalling the app, but if I wipe the desktop clean and rebuild it, it will work for a while.

    Friday, May 13, 2011 9:48 PM
  • I just ran into this myself and sure enough, if I change the App-V Management Server service to run as Local System, the problem went away.  Note that the App-V Management Server runs as Network Service by default.  It appears the problem is somehow tied to the client that is trying to connect because I had one client that was working fine and another that was failing with the 2002 error.

    I turned on verbose logging on the App-V Server and turns out that calls to AcceptSecurityContext() were failing with SEC_E_UNSUPPORTED_FUNCTION.  So... appears that for some reason the token the server was getting from the failing client required more access than the tokens being received from other clients.   Why is still a mystery to me.

    Tuesday, October 18, 2011 7:44 PM
  • (I realise that this is an old topic, but with the adoptation of Office 365 it could be hot and burning again).

    I also can confirm that running the AppV 4 Server service as Local System fixed this issue for our environment.

    Had this problem before with some Windows Live Essentials installations (error 0A-00002002). Removed to software or removing "livesp" from Security Packages in HKLM\SYSTEM\CurrentControlSet\Control\Lsa fixed the issue.

    But the issue reappeared in an Office 365 POC, as Office 365 uses the same authenication protocol I guess.. ? Removing "msoidssp" from the registery is out of the question.

    Changing AppVirtServer service to log on as Local System account solved the issue for the Office 365 prerequisites.

    Thursday, July 25, 2013 12:55 PM
  • App-V 4.6 SP2 Hotfix 3 should fix this issue.

    http://blogs.msdn.com/b/sgern/archive/2013/10/18/10457918.aspx

    Friday, October 18, 2013 2:29 PM