none
DPM 2010 upgraded to 2012 - secondary server Agent install on Primary not allowed, Catch 22? RRS feed

  • Question

  • I've upgrade my primary DPM from 2010 to 2012 successfully. (Primary)

    I've upgrade the secondary DPM from 2010 to 2012 successfully. (Secondary)

    The Secondary stated, as expected that the agent on the Primary needs to be updated but as you can see below cannot be done remotely (more information link goes nowhere)

    So I login to the Primary and browse to the installer to be met with...

    Catch 22, no?

    http://technet.microsoft.com/en-us/library/hh757845.aspx

    Says...

    Applies To: System Center 2012 - Data Protection Manager

    From the secondary DPM server, in the Management task area, install a protection agent on the primary DPM server. For step-by-step instructions for installing a protection agent

    Which leads here...

    http://technet.microsoft.com/en-us/library/hh757789.aspx

    tried DpmAgentInstaller_x64.exe /q <DPMServerName>

    this appears to have installed the correct version.

    Now I have same connection problem as before with DCOM on 2008 R2 server installation where the agent on the primary server is unable to communicate with the secondary server.

    tried SetDpmServer.exe –dpmServerName <DPMServerName>

    But it appears the agent folders (from 2010 or 2012) are not in the default install diretory for the agent, so Setdpmserver.exe is not available. I ran it from a share from another machine with the agent installed and it competed succesfully but the secondary server again reported the agant on the primary needs to be updated.

    also getting the usual.... on the Primary when trying to query it from secondary (status update).

    "Log Name:      Application
    Source:        DPMRA

    Date:          6/12/2012 8:42:02 PM
    Event ID:      83
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          SYSTEM
    Computer:      H*****DPM01.ad.by*****up.co.uk
    Description:
    A DPM agent failed to communicate with the DPM service on MIT****DPM01.ad.byr*****up.co.uk because the host is unreachable. Make sure that MIT****DPM01.ad.byr*****up.co.uk is online and remotely accessible from the computer running the DPM agent. If a firewall is enabled on MIT****DPM01.ad.byr*****up.co.uk, make sure that it is not blocking requests from the computer running the DPM agent (Error code: 0x2c7850, full name: MIT****DPM01.ad.byr*****up.co.uk)."

    • Edited by Insane_Homer Tuesday, June 12, 2012 7:48 PM more bollocks, still not working...
    Tuesday, June 12, 2012 5:05 PM

Answers

  • Hi insane_Homer,

    I could be wrong but you don't need to install DPM Agent on DPM server itself because Agent's components are allready embedded in DPM server.

    You just have to Attach agents through Management TAB:

    From DPM1 attach DPM2

    From DPM2 attach DPM1

    Stephane

    • Marked as answer by Insane_Homer Monday, June 18, 2012 7:20 AM
    Friday, June 15, 2012 8:26 AM

All replies

  • bump!

    nothing? anyone from MS care to explain why the instructions and implementation don't match?

    Wednesday, June 13, 2012 3:29 PM
  • still nothing...

    no one knows why a prescribed documented method of backup is not possible because of a new restriction placed on the agent installer?

    any idea of a work around?

    Friday, June 15, 2012 6:21 AM
  • Hi insane_Homer,

    I could be wrong but you don't need to install DPM Agent on DPM server itself because Agent's components are allready embedded in DPM server.

    You just have to Attach agents through Management TAB:

    From DPM1 attach DPM2

    From DPM2 attach DPM1

    Stephane

    • Marked as answer by Insane_Homer Monday, June 18, 2012 7:20 AM
    Friday, June 15, 2012 8:26 AM
  • Hi insane_Homer,

    I could be wrong but you don't need to install DPM Agent on DPM server itself because Agent's components are allready embedded in DPM server.

    You just have to Attach agents through Management TAB:

    From DPM1 attach DPM2

    From DPM2 attach DPM1

    Stephane

    Stephane,

    Many thanks!

    I removed the existing connection between the 2 machines.

    Then used the attach Agent as you suggested. that seemed to have worked, but now I'm back to the same problem with DPM 2010 on Windows 2008 R2, the DCOM security is all messed up and as a result the Primary cannot 'see' the Secondary Server.

    So I can attach from DPM02(secondary) to DPM01(primary) (sticks on attempting to connect since it does not get a response from DPM1)

    But I cannot attach from DPM01(primary) to DPM02(secondary) using th same method. (the more Information link is a dead link).


    Log entry on the DPM1

    "Log Name:      Application
    Source:        DPMRA
    Date:          6/15/2012 3:47:53 PM
    Event ID:      83
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          SYSTEM
    Computer:      HQ*****.ad.b*****p.co.uk [DPM1]
    Description:
    A DPM agent failed to communicate with the DPM service on MIT*****.ad.b*****p.co.uk[DPM2] because the host is unreachable. Make sure that MIT*****.ad.b****p.co.uk is online and remotely accessible from the computer running the DPM agent. If a firewall is enabled on MIT*****.ad.b*****p.co.uk, make sure that it is not blocking requests from the computer running the DPM agent (Error code: 0x331f93c0, full name: MIT*****.ad.b*****p.co.uk)."

    Firewalls are off on both machines.

    Friday, June 15, 2012 3:26 PM
  • OK!

    Why weren't the 2 boxes seeing each other?

    DHCP on the second server (as it's temporarily in this location to sync them before moving off to DR site location).

    but not just DHCP...

    Our main office is on a Class B network for the primary server was on

    10.2.2.x

    the DHCP enabled secondary on 

    10.2.10.x

    somewhere it's assuming a Class C subnet of was passing the traffic to the DFGW?

    As soon as I change the IP to the static (10.2.2.x) on the second machine the Agent reported back correctly!


    Friday, June 15, 2012 4:41 PM
  • Nice job :)

    Please remember to click “Mark as Answer” on the post that helps you.

    Stephane


    Friday, June 15, 2012 8:19 PM