locked
2007 Exchange Mail Que slow to release RRS feed

  • Question

  • I am running a windows 2003 R2 64 bit server

    I have Exchange 2007 running and everything has been running fine up until 3 days ago when the que started filling up, it seems to get just under 200 and then it sends the emails out and then the que starts to build again. Anti virus has been disabled.

    Any suggestions would be appreciated,

    Thanks!

    Chris

    Monday, December 9, 2013 8:44 PM

Answers

  • In our environment (Exchange 2007 in Windows 2008 SP2) we face similar issue as well, where the MailQueue was piling up and cause the email delay in delivery. You may need to setup perfmon to look specifically into HUB performance. We actually using the template from Perfwiz replacement for Exchange 2007

    As for our case, it is because of poor disk performance. So change to faster disk subsystem (e.g. EMC) solved the issue. This involved quite some times of our SAN vendor to fine tune the disk subsystem as well.

    Monitoring Hub Transport Servers

    
    Wednesday, December 11, 2013 7:43 AM

All replies

  • Also all the logs are clean, nothing to indicate any issues with exchange.
    Monday, December 9, 2013 8:50 PM
  • In our environment (Exchange 2007 in Windows 2008 SP2) we face similar issue as well, where the MailQueue was piling up and cause the email delay in delivery. You may need to setup perfmon to look specifically into HUB performance. We actually using the template from Perfwiz replacement for Exchange 2007

    As for our case, it is because of poor disk performance. So change to faster disk subsystem (e.g. EMC) solved the issue. This involved quite some times of our SAN vendor to fine tune the disk subsystem as well.

    Monitoring Hub Transport Servers

    
    Wednesday, December 11, 2013 7:43 AM