none
RD Connection Broker HA - SQL Connection String

    Question

  • Hi,

    I'm trying to configure HA for our Remote Desktop Connection Broker on Windows Server 2016, but I cannot connect to the database during the wizard. I'm not sure if I have the correct SQL Connection String?

    I've followed this guide, https://nedimmehic.org/2017/05/16/remote-desktop-services-2016-standard-deployment-part-6-rd-connection-broker-high-availability/, and I've tried both of the options, Dedicated database server and Shared database server. I've pre-created the database and given the RD Connection Broker servers db_owner permission (via an AD group).

    But on the wizard where the DB connection string is specified I only get the error "The database specified in the database connection string is not available from the RD Connection Broker server..."
    I can connect to the database from ODBC Data Source Administrator on the RD Connection Broker Server.

    It feels like the connection string is wrong. We're using SQL Server 2014, version 12.0.4422.0. The connection string:
    DRIVER=SQL Server Native Client 11.0;SERVER=LABSRV01;Trusted_Connection=Yes;APP=Remote Desktop Services Connection Broker;Database=RDCB

    Is that connection string correct?

    Kind regards,
    Andreas


    AN



    Thursday, May 17, 2018 2:29 PM

Answers

  • After some more work on this, it turned out it is some GPO setting in our environment that breaks the RDCB HA configuration. We didn't yet figure out which one though. Just tried to block all GPOs, so will continue to work on that later on.

    Thanks,
    Andreas


    AN

    Monday, June 25, 2018 6:34 AM

All replies

  • Hi,

    Please confirm your configuration steps reference article “Add the RD Connection Broker server to the deployment and configure high availability”:
    https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/rds-connection-broker-cluster

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 18, 2018 9:17 AM
    Moderator
  • Hi,

    Thanks for your answer.

    So, I did a new test and followed that guide. I tried both with Azure SQL DB and On-Prem SQL DB (installed a new SQL 2016 Server), but I get the same error message.

    The connection string I get from Azure SQL is: Driver={ODBC Driver 13 for SQL Server};Server=tcp:devnorsqltest.database.windows.net,1433;Database=RDCB;Uid=user@sql_server;Pwd={your_password_here};Encrypt=yes;TrustServerCertificate=no;Connection Timeout=30;

    On the RD Connection Broker server, I can use ODBC Data Source Administrator, configure connection with ODBC Driver 13 for SQL and it works both to On-Prem and to the Azure DB.

    Any ideas?

    Thanks,
    Andreas


    AN

    Friday, June 1, 2018 1:38 PM
  • After some more work on this, it turned out it is some GPO setting in our environment that breaks the RDCB HA configuration. We didn't yet figure out which one though. Just tried to block all GPOs, so will continue to work on that later on.

    Thanks,
    Andreas


    AN

    Monday, June 25, 2018 6:34 AM