none
DPM requires TCP\IP protocol be enabled RRS feed

  • Question

  • I am embarrassed to put up this post as it would seem obvious how to correct this issue...but it isn't working. Upgraded SQL 2008 to SQL 2008 R2 in preparation for DPM 2012 beta. Upgrade went fine and DPM 2010 works just fine. I go to perform the upgrade to DPM 2012 beta and it fails during the pre-req check during the RemoteDbTCP check saying:

    DPM requires TCP\IP protocol to be enabled on the selected SQL Server instance.Run SQL Server Configuration Manager tool and enable the network configuration on the selected SQL Server instance.

    I have opened the Configuration Manager and repeatedly checked to make sure that TCP/IP is properly enabled on this instance (see attached). I am really left scratching my head here as to why it thinks TCP/IP is not enabled. Anyone have any thoughts here?

    • Moved by Larry Yin Wednesday, March 28, 2012 11:28 PM (From:DPM 2012 Beta - Locked)
    Thursday, September 15, 2011 8:12 PM

Answers

  • HI,

    If you are using a Remote SQL Server 2008 R2 instance you will need to install the instance seperately in a SQL server box. Then enable the TCP\IP protocol for that instance and start the Upgrade.

    NOTE: To use Remote SQL instance, you need to have a Standard\Enterprise SKU of SQL server 2008 R2 installed in a seperate box.

    If you  want the DPM database to be present in the same box as the DPM server post Upgrade , you just need to launch DPM 2012 BETA in Upgrade mode and follow the default flow, whereby DPM will install the SQL 2008 R2 instance.

    What Upgrade flow are you planning to use ?

     


    Thanks, Bortik - [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights

    Friday, September 16, 2011 4:27 AM

All replies

  • HI,

    If you are using a Remote SQL Server 2008 R2 instance you will need to install the instance seperately in a SQL server box. Then enable the TCP\IP protocol for that instance and start the Upgrade.

    NOTE: To use Remote SQL instance, you need to have a Standard\Enterprise SKU of SQL server 2008 R2 installed in a seperate box.

    If you  want the DPM database to be present in the same box as the DPM server post Upgrade , you just need to launch DPM 2012 BETA in Upgrade mode and follow the default flow, whereby DPM will install the SQL 2008 R2 instance.

    What Upgrade flow are you planning to use ?

     


    Thanks, Bortik - [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights

    Friday, September 16, 2011 4:27 AM
  • Thanks for the reply. I looked further down in the beta docs and see that I am supposed to select 'dedicated' as the SQL option (I think). Trying it now...
    • Edited by d2iguy Friday, September 16, 2011 12:32 PM
    Friday, September 16, 2011 12:27 PM
  • That did it. Upgrade went fine after finding that little diddy. Sorry to trouble everyone.
    Monday, September 19, 2011 5:23 PM
  • I got similar issue what is "dedicated" any screenshot can help much appreciated.
    Friday, September 26, 2014 2:35 AM