locked
Autodiscovery not working Exchange 2010 and 2013 environment RRS feed

  • Question

  • I have installed Exchange 2013 in Exchange 2010 environment everything working fine except outlook autodiscovery for exchange 2013 users. If I change EXPR from msstd:e2k10ht.abc.com    to msstd:e2013ht.abc.com  Exchange 2013 outlook Auto discover  working  and Exchange 2010 user outlook prompt for password .

    [PS] C:\Windows\system32>Get-OutlookProvider

    Name                          Server                        CertPrincipalName             TTL

    ----                          ------                        -----------------             ---

    EXCH                                                        msstd:e2013ht.abc.com       1

    EXPR                                                        msstd:e2k10ht.abc.com...   1

    WEB                                                                                       1  

    Regards

    Bhupen

    Thursday, July 18, 2013 11:37 AM

Answers

  • Hi Bhupen,

    Test AutoDiscover from the Outlook Client

     

    1. Open Outlook and login to your profile
    2. Hold ctrl and click the Outlook tray icon
    1. Select "Test E-mail Auto-configuration"
    1. A new window will pop up. Uncheck "User Guessmart" and "Secure Guessmart Authentication".
    2. Type your email address and password
    3. Click Test.
    4. Post the Log field here please


    Dame Luthas, ITILv3, MCSE Messaging 2013, MCSA, MCITP

    My Technical Blog: http://thelifestrategist.wordpress.com

    Discipline is the Difference between Goals and Accomplishments

    If this post is useful, please hit the green arrow on the left & if this is the answer hit "mark as answer"

    • Proposed as answer by Dame Luthas Monday, July 22, 2013 2:51 PM
    • Marked as answer by cara chen Tuesday, July 23, 2013 12:57 PM
    Monday, July 22, 2013 12:26 PM
  • After doing the below changes , Exchange 2010 and 2013 Autodiscovery working without any error .

    Set-ClientAccessServer -Identity e2013ht -AutodiscoverServiceInternalUri https://mail.mydomain.com/autodiscover/autodiscover.xml
    Set-WebServicesVirtualDirectory -Identity “e2013ht\EWS (Default Web Site)” –InternalUrl https://mail.mydomain.com/EWS/Exchange.asmx
    Set-OABVirtualDirectory -Identity “e2013ht\OAB (Default Web Site)” -InternalURL https://mail.mydomain.com/OAB
    Set-ActiveSyncVirtualDirectory -Identity “e2013ht\Microsoft-Server-ActiveSync (Default Web Site)” -InternalURL https://mail.mydomain.com/Microsoft-Server-Activesync

    For Outlook Anywhere,

    Set-WebServicesVirtualDirectory –Identity ‘e2013ht\EWS (Default Web Site)’ –ExternalUrl https://mail.mydomain.com/ews/exchange.asmx

    Regards

    Bhupen

    Tuesday, August 13, 2013 8:37 AM

All replies

  • Sounds like a loopback issue occurred because of the namespace conflict.

    This conflict has to resolved by changing the RPC name for Exchange 2010 Mailbox Databases to something unique (for example, the real server name of one of the members of Exchange 2010) and configuring all Exchange 2010 communication (internal and external) to occur over HTTPS instead of RPC (since this is how Exchange 2013 talked to Outlook clients).  

    When moving Exchange 2013 to Internet Facing, in addition to modifying your Load Balancer, Firewalls, DNS, Send/Receive Connectors, make the following changes to resolve the namespace problem:

    Using Exchange 2010 Management Shell:
    Change RPCClientAccessServer Attribute to be FQDN of Exchange 2010 Mailbox Databases (repeat for all Databases on Exchange 2010)
    Set-MailboxDatabase –Identity “<Database Name>” –RPCClientAccessServer “<servername>.<internaldomain>.local

    Using Exchange 2010 or 2013 Management Shell:
    Change SCP Object for Exchange 2010 to Point to Exchange 2013 (repeat for all Exchange 2010 CAS Servers); set this to whatever your internal AutoDiscover namespace is.
    Set-ClientAccessServer –Identity “servername” –AutoDiscoverServiceInternalURI https://outlook.domain.com/autodiscover/autodiscover.xml

    Using Exchange 2010 Management Console:
    Set Exchange 2010 Outlook Anywhere to NTLM (repeat for all Exchange 2010 CAS servers)
    EMC-Server Configuration-<servername>-Right Click-Properties-Outlook Anywhere Tab- Change Authentication method to “NTLM”

    Using Exchange 2013 Management Shell:
    Temporarily adjust Authentication Method on Exchange 2013 Outlook Anywhere to be NTLM (required for users on Exchange 2010)
    Set-OutlookAnywhere -Identity “<exchange2013cas>\rpc (Default Web Site)” -InternalClientAuthenticationMethod:Ntlm -IISAuthenticationMethods Basic,Ntlm,Negotiate  -SSLOffloading $false

    Once Exchange 2010 has been removed and uninstalled, run the following command to reset authentication.
    Using Exchange 2013 Management Shell:
    Adjust Authentication Method on Exchange 2013 back to Negotiate
    Set-OutlookAnywhere -Identity “<exchange2013cas>\rpc (Default Web Site)” -InternalClientAuthenticationMethod:Negotiate -InternalClientAuthenticationMethod:Ntlm -IISAuthenticationMethods Negotiate -SSLOffloading $false

    Outlook 2013 handles these changes smoothly and without issue (the user just has to restart Outlook a couple of times).  It also appears that some Outlook 2007 clients do successfully make the change, but a high percentage do not.  The only way to fix these clients is to completely delete their Outlook Profile and let it re-create using AutoDiscover (repairing the account does not appear to fix the issue). Once the account gets added back, all is well (however if you have a large number of clients, this can be very problematic).

    Dame Luthas, ITILv3, MCSE Messaging 2013, MCSA, MCITP

    My Technical Blog: http://thelifestrategist.wordpress.com/

    Discipline is the Difference between Goals and Accomplishments..

    Thursday, July 18, 2013 12:27 PM
  • Hi Bhupen,

    Test AutoDiscover from the Outlook Client

     

    1. Open Outlook and login to your profile
    2. Hold ctrl and click the Outlook tray icon
    1. Select "Test E-mail Auto-configuration"
    1. A new window will pop up. Uncheck "User Guessmart" and "Secure Guessmart Authentication".
    2. Type your email address and password
    3. Click Test.
    4. Post the Log field here please


    Dame Luthas, ITILv3, MCSE Messaging 2013, MCSA, MCITP

    My Technical Blog: http://thelifestrategist.wordpress.com

    Discipline is the Difference between Goals and Accomplishments

    If this post is useful, please hit the green arrow on the left & if this is the answer hit "mark as answer"

    • Proposed as answer by Dame Luthas Monday, July 22, 2013 2:51 PM
    • Marked as answer by cara chen Tuesday, July 23, 2013 12:57 PM
    Monday, July 22, 2013 12:26 PM
  • After doing the below changes , Exchange 2010 and 2013 Autodiscovery working without any error .

    Set-ClientAccessServer -Identity e2013ht -AutodiscoverServiceInternalUri https://mail.mydomain.com/autodiscover/autodiscover.xml
    Set-WebServicesVirtualDirectory -Identity “e2013ht\EWS (Default Web Site)” –InternalUrl https://mail.mydomain.com/EWS/Exchange.asmx
    Set-OABVirtualDirectory -Identity “e2013ht\OAB (Default Web Site)” -InternalURL https://mail.mydomain.com/OAB
    Set-ActiveSyncVirtualDirectory -Identity “e2013ht\Microsoft-Server-ActiveSync (Default Web Site)” -InternalURL https://mail.mydomain.com/Microsoft-Server-Activesync

    For Outlook Anywhere,

    Set-WebServicesVirtualDirectory –Identity ‘e2013ht\EWS (Default Web Site)’ –ExternalUrl https://mail.mydomain.com/ews/exchange.asmx

    Regards

    Bhupen

    Tuesday, August 13, 2013 8:37 AM
  • Hi guys,

    Thanks for the informative blog, I'm having a similar issue. 

    We are Ex10/Ex13 co-existence right now, and our settings seem correct as per the blog.

    My question is regarding the RPCClientAccessServer settings for Ex10 vs Ex13.  All our Ex10 DB's point to a generic load-balanced namespace 'Outlook.junk.com' while our Ex13 DB's each point to unique servers 'ServerA.junk.com', 'ServerB.junk.com', etc.

    If I still have Ex10 mailboxes, and I change the Ex10 RPC's to be unique servers in the Ex10 env, what is the impact of that change?  Will people need to create new Outlook 2007 and Outlook 2013 profiles (our 2 client platforms)?

    Or will this change it automatically, and not affect end users (except for perhaps a restart of Outlook)?

    Thanks for your help.

    Doug

    Tuesday, September 20, 2016 6:00 PM